aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/eog2/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-09-18 14:49:37 +0800
committermarcus <marcus@FreeBSD.org>2003-09-18 14:49:37 +0800
commit5797d600f46f09de6f7e9f89bd9546544d3f93e6 (patch)
treef29aa772e064572f168522a552ce158c9147a8a2 /graphics/eog2/Makefile
parentf8ccc20f69f18bf5f775fc1a7f7a5098f7173ac1 (diff)
downloadfreebsd-ports-gnome-5797d600f46f09de6f7e9f89bd9546544d3f93e6.tar.gz
freebsd-ports-gnome-5797d600f46f09de6f7e9f89bd9546544d3f93e6.tar.zst
freebsd-ports-gnome-5797d600f46f09de6f7e9f89bd9546544d3f93e6.zip
Update to GNOME 2.4.0. For all the goodies on what's changed, known issues,
future plans, etc., please see http://www.gnome.org/start/2.4/. This commit represents work done by adamw, bland, and myself as well as many other contributers: Koop Mast <einekoai@chello.nl> Akifyev Sergey <asa@gascom.ru> Franz Klammer <klammer@webonaut.com> Øyvind Kolbu <oyvind@kebab.gaffel.nu> Thomas E. Zander <riggs@rrr.de> Jeremy Messenger <mezz7@cox.net> Without these contirbuters, and our faithful users, GNOME 2.4.0 would not be possible. Please check the FreeBSD GNOME site for any FreeBSD gotchas, as well as general FAQs and documentation (GNOME 2.4 updates to be posted soon). The best way to upgrade so that you get all shared library dependencies is: portupgrade -rf -m BATCH=yes atk portupgrade -R -m BATCH=yes gnome2 Approved by: portmgr (kris, will, myself implicitly) Requested by: re as well as many other users
Diffstat (limited to 'graphics/eog2/Makefile')
-rw-r--r--graphics/eog2/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/graphics/eog2/Makefile b/graphics/eog2/Makefile
index 42b8c0b10844..b65209bd9313 100644
--- a/graphics/eog2/Makefile
+++ b/graphics/eog2/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= eog2
-PORTVERSION= 2.2.1
+PORTVERSION= 2.4.0
CATEGORIES= graphics gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.2
+MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.4
DISTNAME= eog-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -19,11 +19,16 @@ COMMENT= The Eye Of Gnome image viewer
USE_BZIP2= yes
USE_GMAKE= yes
USE_REINPLACE= yes
-USE_GNOME= gnomeprefix gnomehack gnomehier libgnomeui libgnomeprintui \
- librsvg2
+USE_GNOME= gnomeprefix gnomehack gnomehier eel2 libgnomeprintui librsvg2
USE_X_PREFIX= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.pre.mk>
-.include <bsd.port.mk>
+.if defined(WITH_EXIF) || exists(${LOCALBASE}/lib/libexif.so.8)
+LIB_DEPENDS+= exif.8:${PORTSDIR}/graphics/libexif
+.endif
+
+.include <bsd.port.post.mk>