aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/epix/Makefile
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2003-01-17 07:38:13 +0800
committerarved <arved@FreeBSD.org>2003-01-17 07:38:13 +0800
commit760104eef5204704409ce0c4441f44c4b4345e99 (patch)
tree4fe90e9475599ef237e03d0e97752cac87a1c3da /graphics/epix/Makefile
parentcb8a4a4e723f7562fcff3ecee7ab6e5febbfab4d (diff)
downloadfreebsd-ports-gnome-760104eef5204704409ce0c4441f44c4b4345e99.tar.gz
freebsd-ports-gnome-760104eef5204704409ce0c4441f44c4b4345e99.tar.zst
freebsd-ports-gnome-760104eef5204704409ce0c4441f44c4b4345e99.zip
Update to 0.8.8a
PR: 47076 Submitted by: KATO Tsuguru <tkato@prontomail.com>
Diffstat (limited to 'graphics/epix/Makefile')
-rw-r--r--graphics/epix/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/graphics/epix/Makefile b/graphics/epix/Makefile
index f198ec4e62d1..476cdd9c42a0 100644
--- a/graphics/epix/Makefile
+++ b/graphics/epix/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= epix
-PORTVERSION= 0.8.7a
+PORTVERSION= 0.8.8a
CATEGORIES= graphics
MASTER_SITES= http://mathcs.holycross.edu/~ahwang/software/
DISTNAME= ${PORTNAME}-${PORTVERSION}_src
@@ -19,10 +19,21 @@ RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2 \
latex:${PORTSDIR}/print/teTeX
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+USE_BZIP2= yes
+USE_REINPLACE= yes
+MAKE_ARGS= CXX="${CXX}" CFLAGS="${CXXFLAGS} -c" \
+ INSTALL_PROGRAM="${INSTALL_DATA}" \
+ INSTALL_BIN="${INSTALL_SCRIPT}"
PLIST_SUB= VERSION="${PORTVERSION}"
MAN1= epix.1
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/newbash.sh
+ @${REINPLACE_CMD} -e 's|COPYING ||g' ${WRKSRC}/helpfiles.sh
+
pre-build:
@(cd ${WRKSRC} ; ./newbash.sh)