aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/epsilon
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2006-10-08 21:48:37 +0800
committerstas <stas@FreeBSD.org>2006-10-08 21:48:37 +0800
commit173755349dc2dd22744f67ee65b533ef3b1c3649 (patch)
treefcddf9b33a006f3b495b40ac5641012787c2a99e /graphics/epsilon
parented21c3e01f7d2d837804666f445b9249d985c327 (diff)
downloadfreebsd-ports-gnome-173755349dc2dd22744f67ee65b533ef3b1c3649.tar.gz
freebsd-ports-gnome-173755349dc2dd22744f67ee65b533ef3b1c3649.tar.zst
freebsd-ports-gnome-173755349dc2dd22744f67ee65b533ef3b1c3649.zip
- Move to LOCALBASE
- Use new EFL framework - Update all e17 ports to the lates stable cvs snapshot - Add additional knobs/options to ports makefiles to control the feature set - Add a bunch of new e17 applications/libraries - Minor improvements/modification. Approved by: vanilla (old maintainer), sem (mentor)
Diffstat (limited to 'graphics/epsilon')
-rw-r--r--graphics/epsilon/Makefile48
-rw-r--r--graphics/epsilon/distinfo6
-rw-r--r--graphics/epsilon/pkg-plist7
3 files changed, 47 insertions, 14 deletions
diff --git a/graphics/epsilon/Makefile b/graphics/epsilon/Makefile
index 82f1245a17de..f78bf13370cf 100644
--- a/graphics/epsilon/Makefile
+++ b/graphics/epsilon/Makefile
@@ -6,21 +6,49 @@
#
PORTNAME= epsilon
-PORTVERSION= 0.3.0.007
+PORTVERSION= 20060926
PORTREVISION= 0
+PORTEPOCH= 1
CATEGORIES= graphics
-MASTER_SITES= http://enlightenment.freedesktop.org/files/
+MASTER_SITES= http://sunner.elcomnet.ru/~stas/
-MAINTAINER= vanilla@FreeBSD.org
+MAINTAINER= stas@FreeBSD.org
COMMENT= A small, display independent, and quick thumbnailing library
-LIB_DEPENDS= epeg.9:${PORTSDIR}/graphics/epeg \
- edje.5:${PORTSDIR}/graphics/edje
-
GNU_CONFIGURE= yes
+USE_BZIP2= yes
USE_GNOME= gnomehack gnometarget
-INSTALLS_SHLIB= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
- LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+USE_EFL= edje imlib2
+USE_LDCONFIG= yes
+
+OPTIONS= PNG "Enable PNG thumbnailer" on \
+ EPEG "Enable Epeg thumbnailer" on \
+ XINE "Enable Xine thumbnailer" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_PNG) || exists(${LOCALBASE}/lib/libpng.so.5)
+LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
+PLIST_SUB+= PNG=""
+.else
+PLIST_SUB+= PNG="@comment "
+.endif
+
+.if defined(WITH_EPEG) || exists(${LOCALBASE}/lib/libepeg.so.9)
+USE_EFL+= epeg
+PLIST_SUB+= EPEG=""
+.else
+PLIST_SUB+= EPEG="@comment "
+.endif
+
+.if defined(WITH_XINE)
+LIB_DEPENDS+= xine.15:${PORTSDIR}/multimedia/libxine
+CONFIGURE_ARGS+=--enable-thumbnailer-xine
+PLIST_SUB+= XINE=""
+.else
+CONFIGURE_ARGS+=--disable-thumbnailer-xine
+PLIST_SUB+= XINE="@comment "
+.endif
-.include <bsd.port.mk>
+.include "../../x11-wm/enlightenment-devel/bsd.efl.mk"
+.include <bsd.port.post.mk>
diff --git a/graphics/epsilon/distinfo b/graphics/epsilon/distinfo
index 713b3142aee4..041dce9314c8 100644
--- a/graphics/epsilon/distinfo
+++ b/graphics/epsilon/distinfo
@@ -1,3 +1,3 @@
-MD5 (epsilon-0.3.0.007.tar.gz) = 408d3c63f9efa06e93e29a691c28985e
-SHA256 (epsilon-0.3.0.007.tar.gz) = 6f40962eb8d76e0e9d76ec9f461d62c6af8561028d194358aed001827cc418fc
-SIZE (epsilon-0.3.0.007.tar.gz) = 378638
+MD5 (epsilon-20060926.tar.bz2) = 796f188c4de29d43eb67625029659abe
+SHA256 (epsilon-20060926.tar.bz2) = 0efd02f9b1dfba97bebb1f44eeedd047a849289ef3f080378b3b53a299c07465
+SIZE (epsilon-20060926.tar.bz2) = 288795
diff --git a/graphics/epsilon/pkg-plist b/graphics/epsilon/pkg-plist
index c8b5061115e7..d6500f9108ff 100644
--- a/graphics/epsilon/pkg-plist
+++ b/graphics/epsilon/pkg-plist
@@ -1,11 +1,16 @@
bin/epsilon
+bin/epsilon-config
bin/epsilon_thumb_test
bin/epsilon_thumbd
-bin/epsilon-config
include/Epsilon.h
include/Epsilon_Request.h
+%%XINE%%lib/epsilon/plugins/xine_thumbnailer.a
+%%XINE%%lib/epsilon/plugins/xine_thumbnailer.la
+%%XINE%%lib/epsilon/plugins/xine_thumbnailer.so
lib/libepsilon.a
lib/libepsilon.la
lib/libepsilon.so
lib/libepsilon.so.0
libdata/pkgconfig/epsilon.pc
+@dirrm lib/epsilon/plugins
+@dirrm lib/epsilon