aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/evas-loader-ico/Makefile
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-05-03 20:24:26 +0800
committerbapt <bapt@FreeBSD.org>2013-05-03 20:24:26 +0800
commit4532ccba9560b1cd75495ea05019a3dbb42b8328 (patch)
tree8750231324508086cb75cdcadc02339d878c0c5d /graphics/evas-loader-ico/Makefile
parentc776742e15ddb00f889861d8fe57194744d8863e (diff)
downloadfreebsd-ports-gnome-4532ccba9560b1cd75495ea05019a3dbb42b8328.tar.gz
freebsd-ports-gnome-4532ccba9560b1cd75495ea05019a3dbb42b8328.tar.zst
freebsd-ports-gnome-4532ccba9560b1cd75495ea05019a3dbb42b8328.zip
Fix build with bmake by using gmake if make is bmake
Diffstat (limited to 'graphics/evas-loader-ico/Makefile')
-rw-r--r--graphics/evas-loader-ico/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/graphics/evas-loader-ico/Makefile b/graphics/evas-loader-ico/Makefile
index 068739d6ea04..d074427cd52b 100644
--- a/graphics/evas-loader-ico/Makefile
+++ b/graphics/evas-loader-ico/Makefile
@@ -18,6 +18,11 @@ DIST_SUBDIR= e17
USE_BZIP2= yes
GNU_CONFIGURE= yes
USES= pkgconfig
+MYMAKE= ${MAKE}
+.if defined(.PARSEDIR)
+USE_GMAKE= yes
+MYMAKE= ${GMAKE}
+.endif
USE_EFL= evas librt_hack libtool_hack
USE_LDCONFIG= yes
@@ -33,11 +38,11 @@ post-patch:
${MAKEDIRS:S,$,/Makefile.in,}
do-build:
- @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MYMAKE} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET}; done)
do-install:
- @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MYMAKE} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET}; done)
.include <bsd.port.mk>