aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/evas/Makefile
diff options
context:
space:
mode:
authornakai <nakai@FreeBSD.org>2000-11-03 20:24:18 +0800
committernakai <nakai@FreeBSD.org>2000-11-03 20:24:18 +0800
commit1c2f803b0ee7687b2c837588844eff580497e647 (patch)
treeeb807ce61ab41f27823d8f791edb44f9487668f5 /graphics/evas/Makefile
parent43607e7eabefc3572dc02d9a024113647db42077 (diff)
downloadfreebsd-ports-gnome-1c2f803b0ee7687b2c837588844eff580497e647.tar.gz
freebsd-ports-gnome-1c2f803b0ee7687b2c837588844eff580497e647.tar.zst
freebsd-ports-gnome-1c2f803b0ee7687b2c837588844eff580497e647.zip
a new canvas library with Imlib2
PR: ports/22330 Submitted by: Jeremy Norris <ishmael27@home.com>
Diffstat (limited to 'graphics/evas/Makefile')
-rw-r--r--graphics/evas/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/graphics/evas/Makefile b/graphics/evas/Makefile
new file mode 100644
index 000000000000..3747889bab77
--- /dev/null
+++ b/graphics/evas/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: evas
+# Date created: 24 Oct 2000
+# Whom: Jeremy Norris <ishmael27@home.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= evas
+PORTVERSION= 0.0.1
+CATEGORIES= graphics
+MASTER_SITES= http://download.sourceforge.net/enlightenment/
+
+MAINTAINER= ports@FreeBSD.ORG
+
+LIB_DEPENDS= Imlib2.1:${PORTSDIR}/graphics/imlib2-tmp
+
+USE_X_PREFIX= yes
+USE_FREETYPE= yes
+USE_MESA= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+
+post-install:
+ strip ${PREFIX}/lib/libevas.so.0
+
+.include <bsd.port.mk>