aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/evas
diff options
context:
space:
mode:
authorgblach <gblach@FreeBSD.org>2012-12-23 04:54:59 +0800
committergblach <gblach@FreeBSD.org>2012-12-23 04:54:59 +0800
commitfb6528c60e3ea4f5ff74de6f21724d7ad28c0f7b (patch)
tree9c4bc08591050b7b536082be6db8392c913f8089 /graphics/evas
parent35e83ae5ca4ef2876eccf0e512467ede97187fb9 (diff)
downloadfreebsd-ports-gnome-fb6528c60e3ea4f5ff74de6f21724d7ad28c0f7b.tar.gz
freebsd-ports-gnome-fb6528c60e3ea4f5ff74de6f21724d7ad28c0f7b.tar.zst
freebsd-ports-gnome-fb6528c60e3ea4f5ff74de6f21724d7ad28c0f7b.zip
- Update Enlightenment to 0.17.0
- Update EFL to 1.7.4 - Convert to OptionsNG Approved by: crees (mentor)
Diffstat (limited to 'graphics/evas')
-rw-r--r--graphics/evas/Makefile39
1 files changed, 22 insertions, 17 deletions
diff --git a/graphics/evas/Makefile b/graphics/evas/Makefile
index 0dba1f239d17..be533a675525 100644
--- a/graphics/evas/Makefile
+++ b/graphics/evas/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= evas
-DISTVERSION= 1.1.0
+PORTVERSION= 1.7.4
PORTEPOCH= 2
CATEGORIES= graphics enlightenment
MASTER_SITES= # none
@@ -15,32 +15,37 @@ COMMENT= A hardware accelerated canvas API (meta-port)
NO_BUILD= yes
USE_EFL= evas
-EVAS_ENGINES= buffer opengl sdl x11
-EVAS_LOADERS= bmp eet gif ico jpeg png pmaps psd svg tga tiff wbmp xpm
+OPTIONS_MULTI= ENGINES
+OPTIONS_MULTI_ENGINES=BUFFER OPENGL SDL X11
+OPTIONS_DEFINE= BMP EET GENERIC GIF ICO JPEG \
+ PNG PMAPS PSD SVG TGA TIFF WBMP XPM
+OPTIONS_DEFAULT=BUFFER OPENGL X11 \
+ BMP EET GENERIC GIF ICO JPEG \
+ PNG PMAPS PSD TGA TIFF WBMP XPM
-.for NODE in ${EVAS_ENGINES}
-OPTIONS+= ${NODE:U} "Install ${NODE} evas engine" on
+.for NODE in ${OPTIONS_MULTI_ENGINES}
+${NODE}_DESC= Install ${NODE:L} engine
.endfor
-.for NODE in ${EVAS_LOADERS}
-OPTIONS+= ${NODE:U} "Install ${NODE} evas loader" on
+.for NODE in ${OPTIONS_DEFINE}
+${NODE}_DESC= Install ${NODE:L} loader
.endfor
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.for NODE in ${EVAS_ENGINES}
-. if !defined(WITHOUT_${NODE:U})
-USE_EFL_EVAS_ENGINES+= ${NODE}
-. endif
+.for NODE in ${OPTIONS_MULTI_ENGINES}
+. if ${PORT_OPTIONS:M${NODE}}
+USE_EFL_EVAS_ENGINES+= ${NODE:L}
+. endif
.endfor
-.for NODE in ${EVAS_LOADERS}
-. if !defined(WITHOUT_${NODE:U})
-USE_EFL_EVAS_LOADERS+= ${NODE}
-. endif
+.for NODE in ${OPTIONS_DEFINE}
+. if ${PORT_OPTIONS:M${NODE}}
+USE_EFL_EVAS_LOADERS+= ${NODE:L}
+. endif
.endfor
do-install:
${DO_NADA}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>