aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/evince
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2010-07-06 08:37:54 +0800
committermarcus <marcus@FreeBSD.org>2010-07-06 08:37:54 +0800
commite16f088cb666fdd4334c069d3c640a62edf93a48 (patch)
treee524585074b393f17dabdc635f6080ddb5fc86a5 /graphics/evince
parent12664b2025a8715aecbf6bbac6806ddc278a2a40 (diff)
downloadfreebsd-ports-gnome-e16f088cb666fdd4334c069d3c640a62edf93a48.tar.gz
freebsd-ports-gnome-e16f088cb666fdd4334c069d3c640a62edf93a48.tar.zst
freebsd-ports-gnome-e16f088cb666fdd4334c069d3c640a62edf93a48.zip
Fix a segfault on startup if ~/.gnome2/evince did not already exist.
Feature safe: yes
Diffstat (limited to 'graphics/evince')
-rw-r--r--graphics/evince/Makefile2
-rw-r--r--graphics/evince/files/patch-shell_ev-window.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/graphics/evince/Makefile b/graphics/evince/Makefile
index 35da539cf06a..c5d0ccb88d1f 100644
--- a/graphics/evince/Makefile
+++ b/graphics/evince/Makefile
@@ -8,7 +8,7 @@
PORTNAME= evince
PORTVERSION= 2.30.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics print gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
diff --git a/graphics/evince/files/patch-shell_ev-window.c b/graphics/evince/files/patch-shell_ev-window.c
new file mode 100644
index 000000000000..0e8ddac0b4f9
--- /dev/null
+++ b/graphics/evince/files/patch-shell_ev-window.c
@@ -0,0 +1,11 @@
+--- shell/ev-window.c.orig 2010-07-05 20:36:07.000000000 -0400
++++ shell/ev-window.c 2010-07-05 20:36:10.000000000 -0400
+@@ -6107,7 +6107,7 @@ ev_window_create_last_settings_metadata
+ GFile *file;
+ gchar *path;
+
+- path = g_build_filename (ev_application_get_dot_dir (EV_APP, FALSE), "last_settings", NULL);
++ path = g_build_filename (ev_application_get_dot_dir (EV_APP, TRUE), "last_settings", NULL);
+ file = g_file_new_for_path (path);
+ g_free (path);
+