aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/evince
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2005-11-05 12:53:48 +0800
committermarcus <marcus@FreeBSD.org>2005-11-05 12:53:48 +0800
commit194069571a0e4c7bad7bce0f33a042d707e9e171 (patch)
treec3c8a6312bab5325147ea9ea2ad87f0cc44a5fec /graphics/evince
parent232533f87b435da7ed2bac7daeae3e90680d9e1d (diff)
downloadfreebsd-ports-gnome-194069571a0e4c7bad7bce0f33a042d707e9e171.tar.gz
freebsd-ports-gnome-194069571a0e4c7bad7bce0f33a042d707e9e171.tar.zst
freebsd-ports-gnome-194069571a0e4c7bad7bce0f33a042d707e9e171.zip
Presenting GNOME 2.12 for FreeBSD. The release is chock full of bug fixes
and new features. Don't believe me? Then see for yourself at http://www.gnome.org/start/2.12/notes/en/. DO NOT USE portupgrade by itself to upgrade to GNOME 2.12. Instead, use the gnome_upgrade.sh script from http://www.marcuscom.com/downloads/gnome_upgrade212.sh. This script will circumvent some potential pitfalls users can see if they use portupgrade by itself. In keeping with tradition, GNOME 2.12 for FreeBSD comes with a special splash screen. The winner of this release's contest is Dominique Goncalves <dominique.goncalves@gmail.com>. His splash screen was inspired by http://art.gnome.org/contests/2.12-splash/83. The FreeBSD GNOME Team would lank to thank the following users for their contributions to this release: Matthew Luckie <mjl@luckie.org.nz> ade sajd on #freebsd-gnome Caelian on #freebsd-gnome mnag Yasuda Keisuke <kysd@po.harenet.ne.jp> Mark Hobden <markhobden@gmail.com> Sergey Akifyev <asa@agava.com> Andreas Kohn For more information on GNOME on FreeBSD, checkout http://www.FreeBSD.org/gnome/. The 2.12 documentation will be posted shortly.
Diffstat (limited to 'graphics/evince')
-rw-r--r--graphics/evince/Makefile72
-rw-r--r--graphics/evince/distinfo4
-rw-r--r--graphics/evince/files/patch-shell_main.c20
-rw-r--r--graphics/evince/pkg-plist47
4 files changed, 124 insertions, 19 deletions
diff --git a/graphics/evince/Makefile b/graphics/evince/Makefile
index 42d8fb1e39c1..190410c12660 100644
--- a/graphics/evince/Makefile
+++ b/graphics/evince/Makefile
@@ -3,13 +3,15 @@
# Whom: Adam Weinberger <adamw@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports/graphics/evince/Makefile,v 1.35 2005/10/20 01:37:54 ahze Exp $
#
PORTNAME= evince
-PORTVERSION= 0.3.0
+PORTVERSION= 0.4.0
+PORTREVISION= 2
CATEGORIES= graphics print gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.3
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.4
MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME 2 multi-format document viewer
@@ -17,38 +19,78 @@ COMMENT= GNOME 2 multi-format document viewer
LIB_DEPENDS= poppler.0:${PORTSDIR}/graphics/poppler
USE_BZIP2= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
+USE_REINPLACE= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GHOSTSCRIPT=yes
INSTALLS_OMF= yes
USE_GNOME= gnomehack intlhack gnomeprefix libgnomeui libgnomeprintui \
- desktopfileutils
+ desktopfileutils gnomedocutils
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
GCONF_SCHEMAS= evince.schemas evince-thumbnailer.schemas
+OPTIONS= DVI "Enable DVI viewer support" off \
+ T1LIB "Enable T1LIB for TYPE1 fonts to DVI (Enables DVI)" off \
+ NAUTILUS "Enable Nautilus plugin" on \
+ DBUS "Enable D-BUS support" off \
+ DJVU "Enable DJVU support" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(PACKAGE_BUILDING) || defined(PARALLEL_PACKAGE_BUILD) \
+ || exists(${LOCALBASE}/lib/libdbus-glib-1.so)
+WITH_DBUS= yes
+.endif
+
+.if defined(WITH_DVI) || defined(WITH_T1LIB)
+BUILD_DEPENDS+= tex:${PORTSDIR}/print/teTeX-base
+RUN_DEPENDS+= tex:${PORTSDIR}/print/teTeX-base
+
+CONFIGURE_ARGS+= --enable-dvi
+GCONF_SCHEMAS+= evince-thumbnailer-dvi.schemas
+. if defined(WITH_T1LIB)
+LIB_DEPENDS+= t1.5:${PORTSDIR}/devel/t1lib
+
+CONFIGURE_ARGS+= --enable-t1lib
+. endif
+.endif
+
+.if !defined(WITHOUT_NAUTILUS)
+USE_GNOME+= nautilus2
+CONFIGURE_ARGS+= --enable-nautilus
+PLIST_SUB+= NAUTILUS=""
+.else
+CONFIGURE_ARGS+= --disable-nautilus
+PLIST_SUB+= NAUTILUS="@comment "
+.endif
+
+.if exists(${X11BASE}/bin/djview)
+DJVU_DIR?= # empty
+.else
+DJVU_DIR?= -nox11
+.endif
+
.if defined(WITH_DJVU)
-LIB_DEPENDS+= djvulibre.14:${PORTSDIR}/graphics/djvulibre
+LIB_DEPENDS+= djvulibre.15:${PORTSDIR}/graphics/djvulibre${DJVU_DIR}
CONFIGURE_ARGS+= --enable-djvu
GCONF_SCHEMAS+= evince-thumbnailer-djvu.schemas
.else
CONFIGURE_ARGS+= --disable-djvu
.endif
-pre-everything::
-.if !defined(WITH_DJVU)
- @${ECHO_MSG}
- @${ECHO_MSG} "If you want DjVu support included, hit Ctrl-C now and use"
- @${ECHO_MSG} "\"make WITH_DJVU=yes\""
- @${ECHO_MSG} "NOTE: GNOME/Gtk+ users may want to avoid QT dependency required"
- @${ECHO_MSG} "by defaut djvulibre installation. They need to use
- @${ECHO_MSG} "\"make WITHOUT_X11=yes\" when build that library then."
- @${ECHO_MSG}
+.if defined(WITH_DBUS)
+LIB_DEPENDS+= dbus-glib-1.1:${PORTSDIR}/devel/dbus
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lt1lib|-lt1 -lm|' \
+ ${WRKSRC}/configure \
+ ${WRKSRC}/dvi/mdvi-lib/Makefile.in
+
post-install:
@-update-desktop-database
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/evince/distinfo b/graphics/evince/distinfo
index 1ee219b32558..381e7baf0a1b 100644
--- a/graphics/evince/distinfo
+++ b/graphics/evince/distinfo
@@ -1,2 +1,2 @@
-MD5 (evince-0.3.0.tar.bz2) = 33e760db0295b393864b969f3b62a52a
-SIZE (evince-0.3.0.tar.bz2) = 640308
+MD5 (evince-0.4.0.tar.bz2) = cc41e30108bc54a345bd6ca2556ab857
+SIZE (evince-0.4.0.tar.bz2) = 891605
diff --git a/graphics/evince/files/patch-shell_main.c b/graphics/evince/files/patch-shell_main.c
new file mode 100644
index 000000000000..05a0c788287d
--- /dev/null
+++ b/graphics/evince/files/patch-shell_main.c
@@ -0,0 +1,20 @@
+--- shell/main.c.dbus-fix 2005-09-01 04:14:54.000000000 -0400
++++ shell/main.c 2005-09-01 04:15:33.000000000 -0400
+@@ -152,7 +152,7 @@
+ if (!files) {
+ #if DBUS_VERSION <= 33
+ call = dbus_g_proxy_begin_call (remote_object, "OpenWindow",
+- DBUS_TYPE_UINT32, timestamp,
++ DBUS_TYPE_UINT32, &timestamp,
+ DBUS_TYPE_INVALID);
+
+ if (!dbus_g_proxy_end_call (remote_object, call, &error, DBUS_TYPE_INVALID)) {
+@@ -193,7 +193,7 @@
+ call = dbus_g_proxy_begin_call (remote_object, "OpenURI",
+ DBUS_TYPE_STRING, &uri,
+ DBUS_TYPE_STRING, &page_label,
+- DBUS_TYPE_UINT32, timestamp,
++ DBUS_TYPE_UINT32, &timestamp,
+ DBUS_TYPE_INVALID);
+
+ if (!dbus_g_proxy_end_call (remote_object, call, &error, DBUS_TYPE_INVALID)) {
diff --git a/graphics/evince/pkg-plist b/graphics/evince/pkg-plist
index 97ba11412ea8..19fe298a8fd8 100644
--- a/graphics/evince/pkg-plist
+++ b/graphics/evince/pkg-plist
@@ -1,14 +1,30 @@
bin/evince
bin/evince-thumbnailer
+%%NAUTILUS%%lib/nautilus/extensions-1.0/libevince-properties-page.a
+%%NAUTILUS%%lib/nautilus/extensions-1.0/libevince-properties-page.so
+%%NAUTILUS%%lib/nautilus/extensions-1.0/libevince-properties-page.so.0
share/gnome/applications/evince.desktop
-@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
share/gnome/evince/evince-password.glade
+share/gnome/evince/evince-properties.glade
+share/gnome/evince/evince-toolbar.xml
share/gnome/evince/evince-ui.xml
-share/gnome/evince/pdf-icon.png
+share/gnome/evince/hand-open.png
share/gnome/help/evince/C/evince.xml
share/gnome/help/evince/C/figures/evince_start_window.png
share/gnome/help/evince/C/legal.xml
+share/gnome/help/evince/el/evince.xml
+share/gnome/help/evince/el/figures/evince_start_window.png
+share/gnome/help/evince/es/evince.xml
+share/gnome/help/evince/es/figures/evince_start_window.png
+share/gnome/help/evince/sr/evince.xml
+share/gnome/help/evince/sr/figures/evince_start_window.png
+share/gnome/help/evince/uk/evince.xml
+share/gnome/help/evince/uk/figures/evince_start_window.png
share/gnome/omf/evince/evince-C.omf
+share/gnome/omf/evince/evince-el.omf
+share/gnome/omf/evince/evince-es.omf
+share/gnome/omf/evince/evince-sr.omf
+share/gnome/omf/evince/evince-uk.omf
share/locale/bg/LC_MESSAGES/evince.mo
share/locale/ca/LC_MESSAGES/evince.mo
share/locale/cs/LC_MESSAGES/evince.mo
@@ -17,26 +33,53 @@ share/locale/de/LC_MESSAGES/evince.mo
share/locale/el/LC_MESSAGES/evince.mo
share/locale/en_CA/LC_MESSAGES/evince.mo
share/locale/en_GB/LC_MESSAGES/evince.mo
+share/locale/es/LC_MESSAGES/evince.mo
+share/locale/et/LC_MESSAGES/evince.mo
+share/locale/eu/LC_MESSAGES/evince.mo
share/locale/fi/LC_MESSAGES/evince.mo
share/locale/fr/LC_MESSAGES/evince.mo
+share/locale/gl/LC_MESSAGES/evince.mo
+share/locale/gu/LC_MESSAGES/evince.mo
+share/locale/he/LC_MESSAGES/evince.mo
+share/locale/hi/LC_MESSAGES/evince.mo
+share/locale/hu/LC_MESSAGES/evince.mo
share/locale/ja/LC_MESSAGES/evince.mo
share/locale/ko/LC_MESSAGES/evince.mo
share/locale/lt/LC_MESSAGES/evince.mo
share/locale/nb/LC_MESSAGES/evince.mo
+share/locale/ne/LC_MESSAGES/evince.mo
share/locale/nl/LC_MESSAGES/evince.mo
share/locale/no/LC_MESSAGES/evince.mo
+share/locale/pa/LC_MESSAGES/evince.mo
+share/locale/pl/LC_MESSAGES/evince.mo
share/locale/pt_BR/LC_MESSAGES/evince.mo
share/locale/ru/LC_MESSAGES/evince.mo
share/locale/rw/LC_MESSAGES/evince.mo
+share/locale/sk/LC_MESSAGES/evince.mo
+share/locale/sq/LC_MESSAGES/evince.mo
+share/locale/sr/LC_MESSAGES/evince.mo
+share/locale/sr@Latn/LC_MESSAGES/evince.mo
share/locale/sv/LC_MESSAGES/evince.mo
+share/locale/th/LC_MESSAGES/evince.mo
+share/locale/tr/LC_MESSAGES/evince.mo
+share/locale/uk/LC_MESSAGES/evince.mo
share/locale/wa/LC_MESSAGES/evince.mo
share/locale/zh_CN/LC_MESSAGES/evince.mo
share/locale/zh_TW/LC_MESSAGES/evince.mo
@unexec rmdir %D/share/locale/rw/LC_MESSAGES 2> /dev/null || true
@unexec rmdir %D/share/locale/rw 2> /dev/null || true
@dirrm share/gnome/omf/evince
+@dirrm share/gnome/help/evince/uk/figures
+@dirrm share/gnome/help/evince/uk
+@dirrm share/gnome/help/evince/sr/figures
+@dirrm share/gnome/help/evince/sr
+@dirrm share/gnome/help/evince/es/figures
+@dirrm share/gnome/help/evince/es
+@dirrm share/gnome/help/evince/el/figures
+@dirrm share/gnome/help/evince/el
@dirrm share/gnome/help/evince/C/figures
@dirrm share/gnome/help/evince/C
@dirrm share/gnome/help/evince
@dirrm share/gnome/evince
+@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true