aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/exact-image
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-05-03 17:05:50 +0800
committerwen <wen@FreeBSD.org>2010-05-03 17:05:50 +0800
commit1848fa5ff1a651babb0acb124564b90824dc26fd (patch)
tree7c77ab593b126ebedad556af050badc9dc98dc3a /graphics/exact-image
parent05952ab2e832a1029ed8fda1ba8fd7a5c3ea3cf1 (diff)
downloadfreebsd-ports-gnome-1848fa5ff1a651babb0acb124564b90824dc26fd.tar.gz
freebsd-ports-gnome-1848fa5ff1a651babb0acb124564b90824dc26fd.tar.zst
freebsd-ports-gnome-1848fa5ff1a651babb0acb124564b90824dc26fd.zip
- Update to 0.8.0
PR: ports/146232 Submitted by: bf <bf1783@gmail.com> (maintainer)
Diffstat (limited to 'graphics/exact-image')
-rw-r--r--graphics/exact-image/Makefile3
-rw-r--r--graphics/exact-image/distinfo6
-rw-r--r--graphics/exact-image/files/patch-codecs__bmp.cc14
-rw-r--r--graphics/exact-image/files/patch-utility__Timer.cc11
4 files changed, 4 insertions, 30 deletions
diff --git a/graphics/exact-image/Makefile b/graphics/exact-image/Makefile
index 6fe721c5aa18..f00790e6f2fd 100644
--- a/graphics/exact-image/Makefile
+++ b/graphics/exact-image/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= exact-image
-PORTVERSION= 0.7.5
-PORTREVISION= 2
+PORTVERSION= 0.8.0
CATEGORIES= graphics
MASTER_SITES= http://dl.exactcode.de/oss/${PORTNAME}/
diff --git a/graphics/exact-image/distinfo b/graphics/exact-image/distinfo
index f08b2aa9fc51..a99c28b526d6 100644
--- a/graphics/exact-image/distinfo
+++ b/graphics/exact-image/distinfo
@@ -1,3 +1,3 @@
-MD5 (exact-image-0.7.5.tar.bz2) = 9cf60553cf5ed1bbbf9a59a2e17ac0a2
-SHA256 (exact-image-0.7.5.tar.bz2) = d43635e06fdb48ec8c23bbfd66f40c5a1fc64c81913220f267dd7449050d0c69
-SIZE (exact-image-0.7.5.tar.bz2) = 532314
+MD5 (exact-image-0.8.0.tar.bz2) = 06ac3816176417064dd7919e4416dd5a
+SHA256 (exact-image-0.8.0.tar.bz2) = 6f2df250ca1c55ebdc44305d7a5a14b6798acef50d883986e2f3a5967b616926
+SIZE (exact-image-0.8.0.tar.bz2) = 283332
diff --git a/graphics/exact-image/files/patch-codecs__bmp.cc b/graphics/exact-image/files/patch-codecs__bmp.cc
index 0ca75758d938..0e17f579925a 100644
--- a/graphics/exact-image/files/patch-codecs__bmp.cc
+++ b/graphics/exact-image/files/patch-codecs__bmp.cc
@@ -24,17 +24,3 @@
+ free(data);
goto bad1;
}
-
-@@ -628,9 +632,9 @@
-
- colorspace_de_palette (image, clr_tbl_size, rmap, gmap, bmap);
-
-- delete (rmap);
-- delete (gmap);
-- delete (bmap);
-+ delete[] rmap;
-+ delete[] gmap;
-+ delete[] bmap;
-
- free(clr_tbl);
- clr_tbl = NULL;
diff --git a/graphics/exact-image/files/patch-utility__Timer.cc b/graphics/exact-image/files/patch-utility__Timer.cc
deleted file mode 100644
index 4e4919b77a1c..000000000000
--- a/graphics/exact-image/files/patch-utility__Timer.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- utility/Timer.cc.orig 2009-07-10 11:30:14.000000000 -0400
-+++ utility/Timer.cc 2009-07-10 11:30:30.000000000 -0400
-@@ -145,7 +145,7 @@
- );
- return ((uint64_t)hi << 32) | lo;
- #endif
--#elif define(__mips__)
-+#elif defined(__mips__)
- unsigned int ticks;
- __asm__ __volatile__ ("dmfc0 %0,$9" : "=r" (ticks));
- return ticks;