aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/exact-image
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2012-06-01 13:26:28 +0800
committerdinoex <dinoex@FreeBSD.org>2012-06-01 13:26:28 +0800
commit530706893f31269bbfa303e069f2e76cbbe2fce7 (patch)
treea8077a0d6e20d70b39e6a7fe3e57a6dafe7c7f33 /graphics/exact-image
parent9d262811a145d3e715edefd1d5d64ceac41de547 (diff)
downloadfreebsd-ports-gnome-530706893f31269bbfa303e069f2e76cbbe2fce7.tar.gz
freebsd-ports-gnome-530706893f31269bbfa303e069f2e76cbbe2fce7.tar.zst
freebsd-ports-gnome-530706893f31269bbfa303e069f2e76cbbe2fce7.zip
- update png to 1.5.10
Diffstat (limited to 'graphics/exact-image')
-rw-r--r--graphics/exact-image/Makefile5
-rw-r--r--graphics/exact-image/files/patch-codecs__png.cc27
2 files changed, 21 insertions, 11 deletions
diff --git a/graphics/exact-image/Makefile b/graphics/exact-image/Makefile
index 972ad1ce4fe1..ae64f17c59da 100644
--- a/graphics/exact-image/Makefile
+++ b/graphics/exact-image/Makefile
@@ -7,6 +7,7 @@
PORTNAME= exact-image
PORTVERSION= 0.8.7
+PORTREVISION= 1
CATEGORIES= graphics perl5 python
MASTER_SITES= http://dl.exactcode.de/oss/${PORTNAME}/ LOCAL/bf
@@ -19,7 +20,7 @@ BUILD_DEPENDS= swig>=1.3.32:${PORTSDIR}/devel/swig13
LIB_DEPENDS= agg.2:${PORTSDIR}/graphics/agg \
jpeg.11:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff \
- png.6:${PORTSDIR}/graphics/png \
+ png15:${PORTSDIR}/graphics/png \
gif.5:${PORTSDIR}/graphics/giflib \
jasper.4:${PORTSDIR}/graphics/jasper \
IlmImf.6:${PORTSDIR}/graphics/OpenEXR \
@@ -30,7 +31,7 @@ LIB_DEPENDS= agg.2:${PORTSDIR}/graphics/agg \
CFLAGS+= -fPIC
#hack to get custom exactcode configure script to enable tiff support with
#broken headers on c++ in base system:
-CPPFLAGS+= -fpermissive
+CPPFLAGS+= -fpermissive -I${LOCALBASE}/include/libpng15
USE_BZIP2= yes
USE_GMAKE= yes
USE_PERL5= yes
diff --git a/graphics/exact-image/files/patch-codecs__png.cc b/graphics/exact-image/files/patch-codecs__png.cc
index 06b835b25a95..a5fc65d2ad75 100644
--- a/graphics/exact-image/files/patch-codecs__png.cc
+++ b/graphics/exact-image/files/patch-codecs__png.cc
@@ -1,6 +1,15 @@
---- codecs/png.cc.orig 2009-04-27 19:52:17.000000000 +0200
-+++ codecs/png.cc 2010-03-29 15:07:59.000000000 +0200
-@@ -71,7 +71,7 @@
+--- codecs/png.cc.orig 2010-03-03 22:04:44.000000000 +0100
++++ codecs/png.cc 2012-04-25 19:08:13.000000000 +0200
+@@ -17,6 +17,8 @@
+
+ #include <stdlib.h>
+ #include <png.h>
++#include <zlib.h>
++#include <pngpriv.h>
+
+ #include <iostream>
+
+@@ -71,7 +73,7 @@
/* Allocate/initialize the memory for image information. REQUIRED. */
info_ptr = png_create_info_struct(png_ptr);
if (info_ptr == NULL) {
@@ -9,7 +18,7 @@
return 0;
}
-@@ -82,7 +82,7 @@
+@@ -82,7 +84,7 @@
if (setjmp(png_jmpbuf(png_ptr))) {
/* Free all of the memory associated with the png_ptr and info_ptr */
@@ -18,7 +27,7 @@
/* If we get here, we had a problem reading the file */
return 0;
}
-@@ -99,7 +99,7 @@
+@@ -99,7 +101,7 @@
png_read_info (png_ptr, info_ptr);
png_get_IHDR (png_ptr, info_ptr, &width, &height, &bit_depth, &color_type,
@@ -27,7 +36,7 @@
image.w = width;
image.h = height;
-@@ -132,7 +132,7 @@
+@@ -132,7 +134,7 @@
#if 0 // no longer needed
/* Expand grayscale images to the full 8 bits from 2, or 4 bits/pixel */
if (color_type == PNG_COLOR_TYPE_GRAY && bit_depth > 1 && bit_depth < 8) {
@@ -36,7 +45,7 @@
image.bps = 8;
}
#endif
-@@ -196,11 +196,11 @@
+@@ -196,11 +198,11 @@
for (int pass = 0; pass < number_passes; ++pass)
for (unsigned int y = 0; y < height; ++y) {
row_pointers[0] = image.getRawData() + y * stride;
@@ -50,7 +59,7 @@
/* that's it */
return true;
-@@ -224,7 +224,7 @@
+@@ -224,7 +226,7 @@
/* Allocate/initialize the memory for image information. REQUIRED. */
info_ptr = png_create_info_struct(png_ptr);
if (info_ptr == NULL) {
@@ -59,7 +68,7 @@
return false;
}
-@@ -244,7 +244,6 @@
+@@ -244,7 +246,6 @@
else if (quality > Z_BEST_COMPRESSION) quality = Z_BEST_COMPRESSION;
png_set_compression_level(png_ptr, quality);