aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/exact-image
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-12-12 07:38:46 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-12-12 07:38:46 +0800
commit66daecee046005a7284a1f9d9175710a493324d5 (patch)
tree3fbb1a19ac71752cbc42b964a87e1f2fa415c3f3 /graphics/exact-image
parent5bebfc8a76baa1f796f2118c32b10dbb564e04fe (diff)
downloadfreebsd-ports-gnome-66daecee046005a7284a1f9d9175710a493324d5.tar.gz
freebsd-ports-gnome-66daecee046005a7284a1f9d9175710a493324d5.tar.zst
freebsd-ports-gnome-66daecee046005a7284a1f9d9175710a493324d5.zip
- Unbreak on amd64 by respecting C*FLAGS
- Minor whitespace fix Approved by: portmgr blanket MFH: 2014Q4
Diffstat (limited to 'graphics/exact-image')
-rw-r--r--graphics/exact-image/Makefile5
-rw-r--r--graphics/exact-image/files/patch-build__bottom.make31
2 files changed, 32 insertions, 4 deletions
diff --git a/graphics/exact-image/Makefile b/graphics/exact-image/Makefile
index 2bde42990236..9ab4bb95fd6d 100644
--- a/graphics/exact-image/Makefile
+++ b/graphics/exact-image/Makefile
@@ -24,7 +24,6 @@ LIB_DEPENDS= libagg.so:${PORTSDIR}/graphics/agg \
libfreetype.so:${PORTSDIR}/print/freetype2 \
libexpat.so:${PORTSDIR}/textproc/expat2
-CFLAGS+= -fPIC
#hack to get custom exactcode configure script to enable tiff support with
#broken headers on c++ in base system:
CPPFLAGS+= -fpermissive -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
@@ -32,15 +31,13 @@ USES= gmake perl5 pkgconfig python tar:bzip2
USE_XORG= x11
HAS_CONFIGURE= yes
INSTALL_WRKSRC= ${WRKSRC}/objdir
-BINS= bardecode econvert edentify empty-page hocr2pdf optimize2bw
+BINS= bardecode econvert edentify empty-page hocr2pdf optimize2bw
PLIST_FILES= ${BINS:S|^|bin/|} \
%%SITE_PERL%%/ExactImage.so \
%%SITE_PERL%%/ExactImage.pm \
%%PYTHON_SITELIBDIR%%/ExactImage.py \
%%PYTHON_SITELIBDIR%%/_ExactImage.so
-BROKEN_amd64= Fails to link
-
post-extract:
@${RM} -rf ${WRKSRC}/agg-2.4/
diff --git a/graphics/exact-image/files/patch-build__bottom.make b/graphics/exact-image/files/patch-build__bottom.make
new file mode 100644
index 000000000000..9f3371c52090
--- /dev/null
+++ b/graphics/exact-image/files/patch-build__bottom.make
@@ -0,0 +1,31 @@
+--- build/bottom.make.orig 2010-07-22 18:35:17.000000000 +0400
++++ build/bottom.make 2014-12-12 00:07:13.000000000 +0300
+@@ -43,23 +43,23 @@
+
+ $($(X_MODULE)_OUTPUT)/%.o: $(X_MODULE)/%.c
+ @echo ' C $@'
+- $(Q)$(COMPILE.c) $($(dir $@)CFLAGS) -MMD -MP -MF '$(patsubst %.o,%.d,$@)' -o '$@' '$<'
++ $(Q)$(COMPILE.c) ${CFLAGS} ${CPPFLAGS} $($(dir $@)CFLAGS) -MMD -MP -MF '$(patsubst %.o,%.d,$@)' -o '$@' '$<'
+
+ $($(X_MODULE)_OUTPUT)/%.o: $(X_MODULE)/%.m
+ @echo ' ObjC $@'
+- $(Q)$(COMPILE.c) $($(dir $@)CFLAGS) -MMD -MP -MF '$(patsubst %.o,%.d,$@)' -o '$@' '$<'
++ $(Q)$(COMPILE.c) ${CFLAGS} ${CPPFLAGS} $($(dir $@)CFLAGS) -MMD -MP -MF '$(patsubst %.o,%.d,$@)' -o '$@' '$<'
+
+ $($(X_MODULE)_OUTPUT)/%.o: $($(X_MODULE)_OUTPUT)/%.cc
+ @echo ' C++ $@'
+- $(Q)$(COMPILE.cc) $($(dir $@)CXXFLAGS) -MMD -MP -MF '$(patsubst %.o,%.d,$@)' -o '$@' '$<'
++ $(Q)$(COMPILE.cc) ${CXXFLAGS} ${CPPFLAGS} $($(dir $@)CXXFLAGS) -MMD -MP -MF '$(patsubst %.o,%.d,$@)' -o '$@' '$<'
+
+ $($(X_MODULE)_OUTPUT)/%.o: $(X_MODULE)/%.cc
+ @echo ' C++ $@'
+- $(Q)$(COMPILE.cc) $($(dir $@)CXXFLAGS) -MMD -MP -MF '$(patsubst %.o,%.d,$@)' -o '$@' '$<'
++ $(Q)$(COMPILE.cc) ${CXXFLAGS} ${CPPFLAGS} $($(dir $@)CXXFLAGS) -MMD -MP -MF '$(patsubst %.o,%.d,$@)' -o '$@' '$<'
+
+ $($(X_MODULE)_OUTPUT)/%.o: $(X_MODULE)/%.mm
+ @echo ' ObjC++ $@'
+- $(Q)$(COMPILE.cc) $($(dir $@)CXXFLAGS) -MMD -MP -MF '$(patsubst %.o,%.d,$@)' -o '$@' '$<'
++ $(Q)$(COMPILE.cc) ${CXXFLAGS} ${CPPFLAGS} $($(dir $@)CXXFLAGS) -MMD -MP -MF '$(patsubst %.o,%.d,$@)' -o '$@' '$<'
+
+ # only implicit rules if one binary per module ...
+ ifeq ($(words $(BINARY)), 1)