aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/exact-image
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2010-12-14 15:30:56 +0800
committerstas <stas@FreeBSD.org>2010-12-14 15:30:56 +0800
commitea0b2f30fe3fda2784bed10c50a24cff87e5bae0 (patch)
treed85ff1f5968af1d6a70c1852bacf3e546d97c800 /graphics/exact-image
parentff78984cfcc8530917b60f277d53c92434a50fd2 (diff)
downloadfreebsd-ports-gnome-ea0b2f30fe3fda2784bed10c50a24cff87e5bae0.tar.gz
freebsd-ports-gnome-ea0b2f30fe3fda2784bed10c50a24cff87e5bae0.tar.zst
freebsd-ports-gnome-ea0b2f30fe3fda2784bed10c50a24cff87e5bae0.zip
- Update e17 applications suite to the recent snapshot.
Thanks to Grzegorz Blach <magik@roorback.net> for doing the hard work preparing the initial version of the update! PR: ports/148038 Submitted by: Grzegorz Blach <magik@roorback.net> (based on)
Diffstat (limited to 'graphics/exact-image')
-rw-r--r--graphics/exact-image/Makefile1
-rw-r--r--graphics/exact-image/files/patch-edisplay_Makefile15
-rw-r--r--graphics/exact-image/files/patch-edisplay_edisplay.cc24
3 files changed, 40 insertions, 0 deletions
diff --git a/graphics/exact-image/Makefile b/graphics/exact-image/Makefile
index 0abd3d46b154..7c7088585c10 100644
--- a/graphics/exact-image/Makefile
+++ b/graphics/exact-image/Makefile
@@ -7,6 +7,7 @@
PORTNAME= exact-image
PORTVERSION= 0.8.1
+PORTREVISION= 1
CATEGORIES= graphics perl5 python
MASTER_SITES= http://dl.exactcode.de/oss/${PORTNAME}/
diff --git a/graphics/exact-image/files/patch-edisplay_Makefile b/graphics/exact-image/files/patch-edisplay_Makefile
new file mode 100644
index 000000000000..61a4a180a8f2
--- /dev/null
+++ b/graphics/exact-image/files/patch-edisplay_Makefile
@@ -0,0 +1,15 @@
+Index: Makefile
+===================================================================
+--- edisplay/Makefile (revision 1751)
++++ edisplay/Makefile (revision 1752)
+@@ -4,7 +4,9 @@
+ BINARY = edisplay
+ BINARY_EXT = $(X_EXEEXT)
+
+-CPPFLAGS += -I . -I lib -I gfx $(shell pkg-config evas --atleast-version 0.9.9.050 && echo -D WITHEVAS_X11_CONNECTION)
++CPPFLAGS += -I . -I lib -I gfx
++CPPFLAGS += $(shell pkg-config evas --atleast-version 0.9.9.050 && echo -D WITHEVAS_X11_CONNECTION)
++CPPFLAGS += $(shell pkg-config evas --atleast-version 0.9.9.49898 && echo -D WITHEVAS_X11_SCREEN)
+
+ DEPS += $(X_OUTARCH)/gfx/X11Helper$(X_OBJEXT) $(X_OUTARCH)/gfx/EvasHelper$(X_OBJEXT) $(X_OUTARCH)/utility/Timer$(X_OBJEXT) $(X_OUTARCH)/utility/ArgumentList$(X_OBJEXT) $(lib_BINARY) $(codecs_BINARY)
+
diff --git a/graphics/exact-image/files/patch-edisplay_edisplay.cc b/graphics/exact-image/files/patch-edisplay_edisplay.cc
new file mode 100644
index 000000000000..4f909e6ed84f
--- /dev/null
+++ b/graphics/exact-image/files/patch-edisplay_edisplay.cc
@@ -0,0 +1,24 @@
+Index: edisplay.cc
+===================================================================
+--- edisplay/edisplay.cc (revision 1751)
++++ edisplay/edisplay.cc (revision 1752)
+@@ -269,12 +269,14 @@
+
+ /* the following is specific to the engine */
+ einfo->info.display = dpy;
+- einfo->info.visual =
+- einfo->func.best_visual_get (dpy, DefaultScreen(dpy));
+- einfo->info.colormap =
+- einfo->func.best_colormap_get(dpy,DefaultScreen(dpy));
+-
++#ifdef WITHEVAS_X11_SCREEN
++ einfo->info.screen = DefaultScreen(dpy);
++ einfo->info.visual = einfo->func.best_visual_get(einfo);
++ einfo->info.colormap = einfo->func.best_colormap_get(einfo);
++#else
++ einfo->info.visual = einfo->func.best_visual_get(dpy, DefaultScreen(dpy));
+ einfo->info.colormap = einfo->func.best_colormap_get(dpy, DefaultScreen(dpy));
++#endif
+ einfo->info.drawable = win;
+ einfo->info.depth = depth;
+