aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/exact-image
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2007-08-14 06:42:32 +0800
committersat <sat@FreeBSD.org>2007-08-14 06:42:32 +0800
commitd4dd1af213ac60f9d140d191d7841ce14aa24a08 (patch)
tree6fdc138c92e33818ff354eb3edba80f9bf36e52c /graphics/exact-image
parent2083037b7635c1c481b23fc53eac0ae2303da08c (diff)
downloadfreebsd-ports-gnome-d4dd1af213ac60f9d140d191d7841ce14aa24a08.tar.gz
freebsd-ports-gnome-d4dd1af213ac60f9d140d191d7841ce14aa24a08.tar.zst
freebsd-ports-gnome-d4dd1af213ac60f9d140d191d7841ce14aa24a08.zip
Add graphics/exact-image:
ExactImage is a fast imaging library including a command line frontend. WWW: http://www.exactcode.de/oss/exact-image/ Author: Rene Rebe <rene@exactcode.de>
Diffstat (limited to 'graphics/exact-image')
-rw-r--r--graphics/exact-image/Makefile68
-rw-r--r--graphics/exact-image/distinfo3
-rw-r--r--graphics/exact-image/pkg-descr4
3 files changed, 75 insertions, 0 deletions
diff --git a/graphics/exact-image/Makefile b/graphics/exact-image/Makefile
new file mode 100644
index 000000000000..8e9bd4c2f41a
--- /dev/null
+++ b/graphics/exact-image/Makefile
@@ -0,0 +1,68 @@
+# New ports collection makefile for: exact-image
+# Date created: 2 September 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= exact-image
+PORTVERSION= 0.4.0
+CATEGORIES= graphics
+MASTER_SITES= http://dl.exactcode.de/oss/${PORTNAME}/ CENKES
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Fast image processing library
+
+BUILD_DEPENDS= swig>=1.3.31:${PORTSDIR}/devel/swig13
+LIB_DEPENDS= agg.2:${PORTSDIR}/graphics/agg \
+ evas.1:${PORTSDIR}/graphics/evas \
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ tiff.4:${PORTSDIR}/graphics/tiff \
+ png.5:${PORTSDIR}/graphics/png \
+ ungif.5:${PORTSDIR}/graphics/libungif \
+ jasper.4:${PORTSDIR}/graphics/jasper \
+ Iex.4:${PORTSDIR}/graphics/OpenEXR \
+ lcms.1:${PORTSDIR}/graphics/lcms
+
+CFLAGS+= -fPIC
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_PERL5= yes
+USE_XORG= x11
+HAS_CONFIGURE= yes
+INSTALL_WRKSRC= ${WRKSRC}/objdir
+BINS= econvert edisplay edentify optimize2bw empty-page
+PLIST_FILES= ${BINS:S|^|bin/|} %%SITE_PERL%%/ExactImage.so \
+ %%SITE_PERL%%/ExactImage.pm
+PORT_VERBS= ExactImage ${BINS}
+
+post-extract:
+ @${RM} -rf ${WRKSRC}/agg-2.4/
+
+post-patch:
+ @${REINPLACE_CMD} -e '1s|/.*|/bin/sh|;s|libpng|libpng12|'\
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/^Q =/d;s|$$[(]COMPILE.cc[)]|${CXX} $${CPPFLAGS} -c|;\
+ s|$$[(]CXX[)]|${CXX}|;s|$$[(]COMPILE.c[)]|${CC} $${CPPFLAGS} -c|'\
+ ${WRKSRC}/build/bottom.make
+ @${REINPLACE_CMD} -e '/^CFLAGS =/d;/^CXXFLAGS =/d;/march=/d;\
+ /mtune=/d;/call cc-option/d;' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e '/CFLAGS=/s|".*"|"${CFLAGS} -I${LOCALBASE}/include"|;\
+ /LIBS=/s|".*"|"-L${LOCALBASE}/lib -lX11"|' ${WRKSRC}/config/pkgcheck-x11.c
+ @${REINPLACE_CMD} -e 's|$$prg|$$prg -I${LOCALBASE}/include|'\
+ ${WRKSRC}/config/functions
+
+post-configure:
+ @${REINPLACE_CMD} -e '/EVASGL/s|1|0|' ${WRKSRC}/config.h
+ @${ECHO_CMD} '#define WITHLIBPNG 1' >> ${WRKSRC}/config.h
+ @${ECHO_CMD} 'WITHLIBPNG = 1' >> ${WRKSRC}/config.make
+ @${ECHO_CMD} 'EVASGL = 0' >> ${WRKSRC}/config.make
+
+do-install:
+ @cd ${INSTALL_WRKSRC}/&&for i in ${BINS};do\
+ ${INSTALL_PROGRAM} */$$i ${PREFIX}/bin/;done
+ @cd ${INSTALL_WRKSRC}/api/&&\
+ ${INSTALL_PROGRAM} ExactImage.so ${SITE_PERL}/;\
+ ${INSTALL_DATA} ExactImage.pm ${SITE_PERL}/
+
+.include <bsd.port.mk>
diff --git a/graphics/exact-image/distinfo b/graphics/exact-image/distinfo
new file mode 100644
index 000000000000..4648737d6d09
--- /dev/null
+++ b/graphics/exact-image/distinfo
@@ -0,0 +1,3 @@
+MD5 (exact-image-0.4.0.tar.bz2) = 2e51094bbda00b7f483c6201e606ad80
+SHA256 (exact-image-0.4.0.tar.bz2) = 4bb3eb0cd10b875564935bbb749275146b0a4c8f90427c816f18a2692aff3966
+SIZE (exact-image-0.4.0.tar.bz2) = 461877
diff --git a/graphics/exact-image/pkg-descr b/graphics/exact-image/pkg-descr
new file mode 100644
index 000000000000..8493b65e8328
--- /dev/null
+++ b/graphics/exact-image/pkg-descr
@@ -0,0 +1,4 @@
+ExactImage is a fast imaging library including a command line frontend.
+
+WWW: http://www.exactcode.de/oss/exact-image/
+Author: Rene Rebe <rene@exactcode.de>