aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/f-spot/Makefile
diff options
context:
space:
mode:
authorromain <romain@FreeBSD.org>2010-06-01 20:41:30 +0800
committerromain <romain@FreeBSD.org>2010-06-01 20:41:30 +0800
commita523e4f72b6d5c7092b0a5440ca1aebb7191b7f8 (patch)
tree6e09e52ec8cbf6b9b4bdfba4e36561ce331f0349 /graphics/f-spot/Makefile
parent0bd76cdabc83b69f902d2b870c04cf5a704d79f6 (diff)
downloadfreebsd-ports-gnome-a523e4f72b6d5c7092b0a5440ca1aebb7191b7f8.tar.gz
freebsd-ports-gnome-a523e4f72b6d5c7092b0a5440ca1aebb7191b7f8.tar.zst
freebsd-ports-gnome-a523e4f72b6d5c7092b0a5440ca1aebb7191b7f8.zip
- Update lang/mono to 2.6.4;
- Update a bunch of C# ports as well (audio/taglib-sharp, deskutils/tomboy, devel/mono-tools, devel/monodevelop, devel/monodevelop-boo, devel/monodevelop-database, devel/monodevelop-java, devel/monodevelop-vala, graphics/f-spot, lang/boo [1], lang/mono-basic, mail/gmime24, gmime24-sharp, multimedia/banshee, multimedia/banshee-mirage, multimedia/moonlight, www/mod_mono, www/webkit-sharp, www/xsp, x11-toolkits/gnome-desktop-sharp20, x11-toolkits/gtk-sharp20, x11-toolkits/libgdiplus). PR: ports/143657 [1] Submitted by: glewis [1]
Diffstat (limited to 'graphics/f-spot/Makefile')
-rw-r--r--graphics/f-spot/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/graphics/f-spot/Makefile b/graphics/f-spot/Makefile
index 8cbf7c6b52c5..614fb9b9b93d 100644
--- a/graphics/f-spot/Makefile
+++ b/graphics/f-spot/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= f-spot
-PORTVERSION= 0.6.1.5
-PORTREVISION= 3
+PORTVERSION= 0.6.2
PORTEPOCH= 1
CATEGORIES= graphics gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
@@ -19,9 +18,11 @@ COMMENT= Personal photo management to the GNOME desktop
LIB_DEPENDS= lcms.1:${PORTSDIR}/graphics/lcms \
exif.12:${PORTSDIR}/graphics/libexif \
gphoto2.2:${PORTSDIR}/graphics/libgphoto2
-BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/ndesk-dbus-glib-1.0.pc:${PORTSDIR}/devel/ndesk-dbus-glib
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/ndesk-dbus-glib-1.0.pc:${PORTSDIR}/devel/ndesk-dbus-glib \
+ ${LOCALBASE}/libdata/pkgconfig/mono-addins.pc:${PORTSDIR}/devel/mono-addins
RUN_DEPENDS= dbus-daemon:${PORTSDIR}/devel/dbus \
- ${LOCALBASE}/libdata/pkgconfig/ndesk-dbus-glib-1.0.pc:${PORTSDIR}/devel/ndesk-dbus-glib
+ ${LOCALBASE}/libdata/pkgconfig/ndesk-dbus-glib-1.0.pc:${PORTSDIR}/devel/ndesk-dbus-glib \
+ ${LOCALBASE}/libdata/pkgconfig/mono-addins.pc:${PORTSDIR}/devel/mono-addins
USE_BZIP2= yes
USE_SQLITE= yes
@@ -32,6 +33,7 @@ USE_GMAKE= yes
INSTALLS_ICONS= yes
INSTALLS_OMF= yes
USE_LDCONFIG= yes
+GCONF_SCHEMAS= f-spot.schemas
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"