aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/feh
diff options
context:
space:
mode:
authorzeising <zeising@FreeBSD.org>2017-12-31 19:08:25 +0800
committerzeising <zeising@FreeBSD.org>2017-12-31 19:08:25 +0800
commite844f14c3a2b4e3cf0db141ccb91fcd4f4a051ca (patch)
treea3c29f8a03f0fc240abeada571f48e5b5730b2e6 /graphics/feh
parent108058db1b90584bac76cd3050ebefbdd2f691fb (diff)
downloadfreebsd-ports-gnome-e844f14c3a2b4e3cf0db141ccb91fcd4f4a051ca.tar.gz
freebsd-ports-gnome-e844f14c3a2b4e3cf0db141ccb91fcd4f4a051ca.tar.zst
freebsd-ports-gnome-e844f14c3a2b4e3cf0db141ccb91fcd4f4a051ca.zip
Update to 2.23
Use our own getopt instead of bundled version. ChangeLog: https://feh.finalrewind.org/archive/2.23/
Diffstat (limited to 'graphics/feh')
-rw-r--r--graphics/feh/Makefile4
-rw-r--r--graphics/feh/distinfo6
-rw-r--r--graphics/feh/files/patch-config.mk15
-rw-r--r--graphics/feh/files/patch-src_Makefile11
4 files changed, 28 insertions, 8 deletions
diff --git a/graphics/feh/Makefile b/graphics/feh/Makefile
index 7efec1656473..e100ee663d92 100644
--- a/graphics/feh/Makefile
+++ b/graphics/feh/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= feh
-PORTVERSION= 2.22.2
+PORTVERSION= 2.23
CATEGORIES= graphics
MASTER_SITES= http://feh.finalrewind.org/ \
LOCAL/uqs
@@ -22,7 +22,7 @@ USES= cpe desktop-file-utils gmake perl5 shebangfix tar:bzip2
CPE_VENDOR= daniel_friesel
USE_PERL5= run
-CPPFLAGS+= -I${LOCALBASE}/include -std=c99
+CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ENV+= LDFLAGS="${LDFLAGS}"
diff --git a/graphics/feh/distinfo b/graphics/feh/distinfo
index 5c5faeb00fd8..2990dbfc38d2 100644
--- a/graphics/feh/distinfo
+++ b/graphics/feh/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1510336682
-SHA256 (feh-2.22.2.tar.bz2) = 05a81fbe0997f6274c7617efc351647be38e5244c2624bd203459025c9a68ecd
-SIZE (feh-2.22.2.tar.bz2) = 2129840
+TIMESTAMP = 1514713644
+SHA256 (feh-2.23.tar.bz2) = 16df3cb813526a549e854aa82f80bcb299b9e83dd687ab4216a84e86f61722a1
+SIZE (feh-2.23.tar.bz2) = 2130344
diff --git a/graphics/feh/files/patch-config.mk b/graphics/feh/files/patch-config.mk
index 40a00f233faa..0e31e21c63f0 100644
--- a/graphics/feh/files/patch-config.mk
+++ b/graphics/feh/files/patch-config.mk
@@ -1,6 +1,6 @@
---- config.mk.orig 2015-05-24 09:46:21 UTC
+--- config.mk.orig 2017-12-28 18:28:35 UTC
+++ config.mk
-@@ -6,12 +6,12 @@ PREFIX ?= /usr/local
+@@ -22,12 +22,12 @@ endif
# Directories for manuals, executables, docs, data, etc.
main_dir = ${DESTDIR}${PREFIX}
@@ -13,5 +13,14 @@
-example_dir = ${main_dir}/share/doc/feh/examples
+example_dir = ${main_dir}/share/examples/feh
desktop_dir = ${main_dir}/share/applications
+ icon_dir = ${ICON_PREFIX}/hicolor
+ 48_icon_dir = ${icon_dir}/48x48/apps
+@@ -38,7 +38,7 @@ CFLAGS ?= -g -O2
+ CFLAGS += -Wall -Wextra -pedantic
- # default CFLAGS
+ # Settings for glibc >= 2.19 - may need to be adjusted for other systems
+-CFLAGS += -std=c11 -D_POSIX_C_SOURCE=200809L -D_XOPEN_SOURCE=500
++CFLAGS += -std=c11
+
+ ifeq (${curl},1)
+ CFLAGS += -DHAVE_LIBCURL
diff --git a/graphics/feh/files/patch-src_Makefile b/graphics/feh/files/patch-src_Makefile
new file mode 100644
index 000000000000..38111a691727
--- /dev/null
+++ b/graphics/feh/files/patch-src_Makefile
@@ -0,0 +1,11 @@
+--- src/Makefile.orig 2017-12-28 18:28:35 UTC
++++ src/Makefile
+@@ -5,8 +5,6 @@ TARGETS = \
+ events.c \
+ feh_png.c \
+ filelist.c \
+- getopt.c \
+- getopt1.c \
+ gib_hash.c \
+ gib_imlib.c \
+ gib_list.c \