aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/ffff
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
committermiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
commitbce9b81f9d6099820f3839d7809d6b08c1d2ae7b (patch)
treef5dd7c3a8dbebad79bdb5e844aeb69c59a9fd12c /graphics/ffff
parent2eea5f1d2e44418020f8f4db08d40bea6915b6e8 (diff)
downloadfreebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.gz
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.zst
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Diffstat (limited to 'graphics/ffff')
-rw-r--r--graphics/ffff/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/graphics/ffff/Makefile b/graphics/ffff/Makefile
index 97169e52c902..c412f020e819 100644
--- a/graphics/ffff/Makefile
+++ b/graphics/ffff/Makefile
@@ -9,27 +9,24 @@ PORTNAME= ffff
PORTVERSION= 323
PORTREVISION= 1
CATEGORIES= graphics
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SFE
DISTNAME= FFFF${PORTVERSION}-src
MAINTAINER= rossiya@gmail.com
COMMENT= A fast mandelbrot fractal generator
-LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
USE_DOS2UNIX= yes
-USE_GCC= 3.2+
-USE_GL= yes
+USE_GL= glut
USE_ZIP= yes
SOURCE= FFFF3 FragmentProgram FragmentProgramARB10 GPUProgram \
PixelBuffer VertexProgram VertexProgramATI VertexProgramNV \
extensions vpext
-CXXFLAGS+= -I${X11BASE}/include -I${X11BASE}/include/GL ${PTHREAD_CFLAGS} \
+CXXFLAGS+= -I${LOCALBASE}/include/GL ${PTHREAD_CFLAGS} \
-D__linux__
-LDFLAGS+= -L${X11BASE}/lib ${PTHREAD_LIBS} -lglut -lGL -lXext -lX11 -lXmu \
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lglut -lGL -lXext -lX11 -lXmu \
-lGLU -lm
PLIST_FILES= bin/ffff