aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/ffff
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-04-26 06:48:54 +0800
committermiwi <miwi@FreeBSD.org>2008-04-26 06:48:54 +0800
commitf7a879e78df4e1acd706cff915dd560b627098f7 (patch)
tree6d42446c6041e9f678b2d0f29deeacbee0f4a9c6 /graphics/ffff
parent89803df2776246102a14f39d7fac8c7e277ef7f6 (diff)
downloadfreebsd-ports-gnome-f7a879e78df4e1acd706cff915dd560b627098f7.tar.gz
freebsd-ports-gnome-f7a879e78df4e1acd706cff915dd560b627098f7.tar.zst
freebsd-ports-gnome-f7a879e78df4e1acd706cff915dd560b627098f7.zip
- Fix build after xorg cleanup
Submitted by: pointyhat via pav
Diffstat (limited to 'graphics/ffff')
-rw-r--r--graphics/ffff/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/graphics/ffff/Makefile b/graphics/ffff/Makefile
index c412f020e819..9373d8793047 100644
--- a/graphics/ffff/Makefile
+++ b/graphics/ffff/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ffff
PORTVERSION= 323
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= SFE
DISTNAME= FFFF${PORTVERSION}-src
@@ -15,17 +15,17 @@ DISTNAME= FFFF${PORTVERSION}-src
MAINTAINER= rossiya@gmail.com
COMMENT= A fast mandelbrot fractal generator
-
+USE_XORG= x11 xmu xext
USE_DOS2UNIX= yes
-USE_GL= glut
+USE_GL= gl glut
USE_ZIP= yes
SOURCE= FFFF3 FragmentProgram FragmentProgramARB10 GPUProgram \
PixelBuffer VertexProgram VertexProgramATI VertexProgramNV \
extensions vpext
-CXXFLAGS+= -I${LOCALBASE}/include/GL ${PTHREAD_CFLAGS} \
- -D__linux__
+CXXFLAGS+= -I${LOCALBASE}/include/GL -D__linux__ -I${LOCALBASE}/include/ \
+ ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lglut -lGL -lXext -lX11 -lXmu \
-lGLU -lm