aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/fly
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-02-03 02:45:27 +0800
committerantoine <antoine@FreeBSD.org>2014-02-03 02:45:27 +0800
commit780142f963609adfc6104b4178b100a58c7e2863 (patch)
tree23d1e52799486ab1253c0295db903b9ba4e87e8d /graphics/fly
parent8b1a1f6f061d669506c6709f3b188a80ca392050 (diff)
downloadfreebsd-ports-gnome-780142f963609adfc6104b4178b100a58c7e2863.tar.gz
freebsd-ports-gnome-780142f963609adfc6104b4178b100a58c7e2863.tar.zst
freebsd-ports-gnome-780142f963609adfc6104b4178b100a58c7e2863.zip
Stage support
Diffstat (limited to 'graphics/fly')
-rw-r--r--graphics/fly/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/graphics/fly/Makefile b/graphics/fly/Makefile
index 8c700fe94ccf..79d298709ad9 100644
--- a/graphics/fly/Makefile
+++ b/graphics/fly/Makefile
@@ -11,26 +11,23 @@ MASTER_SITES= http://fossies.org/unix/www/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple drawing language to generate GIFs on the fly
-LIB_DEPENDS= gd:${PORTSDIR}/graphics/gd
+LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd
PORTDOCS= *
PORTEXAMPLES= *
PLIST_FILES= bin/fly
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS EXAMPLES
+
do-build:
cd ${WRKSRC} && ${CC} ${CFLAGS} -I${LOCALBASE}/include fly.c -o fly \
-L${LOCALBASE}/lib -lgd
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/fly ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${DOCSDIR})
-.endif
-.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}
- @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${EXAMPLESDIR})
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/fly ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
.include <bsd.port.mk>