aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/fotoxx
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2013-03-30 18:14:48 +0800
committerkwm <kwm@FreeBSD.org>2013-03-30 18:14:48 +0800
commit1df82b82b8e4916942769a9be2281318c08d559f (patch)
tree70c9d14dfe6e85b84013e70eedf351166ffec834 /graphics/fotoxx
parent19b600840d82e29f5918a0c624d9843c92b2c20d (diff)
downloadfreebsd-ports-gnome-1df82b82b8e4916942769a9be2281318c08d559f.tar.gz
freebsd-ports-gnome-1df82b82b8e4916942769a9be2281318c08d559f.tar.zst
freebsd-ports-gnome-1df82b82b8e4916942769a9be2281318c08d559f.zip
Fix the build after glib 2.34 update.
Submitted by: miwi Approved by: portmgr (miwi) Obtained from: debian patchtracker (adapted from)
Diffstat (limited to 'graphics/fotoxx')
-rw-r--r--graphics/fotoxx/Makefile2
-rw-r--r--graphics/fotoxx/files/patch-fotoxx-11.03.cc13
-rw-r--r--graphics/fotoxx/files/patch-zfuncs.cc22
-rw-r--r--graphics/fotoxx/files/patch-zfuncs.h22
4 files changed, 52 insertions, 7 deletions
diff --git a/graphics/fotoxx/Makefile b/graphics/fotoxx/Makefile
index 37392f7be1da..a48e12e2d02e 100644
--- a/graphics/fotoxx/Makefile
+++ b/graphics/fotoxx/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fotoxx
PORTVERSION= 11.03
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= http://kornelix.squarespace.com/downloads/ \
http://www.rodperson.com/DL/
diff --git a/graphics/fotoxx/files/patch-fotoxx-11.03.cc b/graphics/fotoxx/files/patch-fotoxx-11.03.cc
index 292dd0f6a234..d5a09e11bcd5 100644
--- a/graphics/fotoxx/files/patch-fotoxx-11.03.cc
+++ b/graphics/fotoxx/files/patch-fotoxx-11.03.cc
@@ -1,5 +1,5 @@
---- fotoxx-11.03.cc.orig 2011-02-28 17:04:24.000000000 +0100
-+++ fotoxx-11.03.cc 2011-05-26 10:36:11.000000000 +0200
+--- fotoxx-11.03.cc.orig 2011-02-28 16:04:24.000000000 +0000
++++ fotoxx-11.03.cc 2013-03-30 08:59:16.000000000 +0000
@@ -24,6 +24,13 @@
#include <tiffio.h>
#include "zfuncs.h"
@@ -14,6 +14,15 @@
#define fversion "Fotoxx v.11.03 2011.03.01" // version and date
#define fversioncc 16 // cc to use for window title bar
#define flicense "Free software - GNU General Public License v.3"
+@@ -200,7 +207,7 @@
+ PXM *Dpxm16 = 0; // drawing window pixmap, 1x 16-bits
+ PXM *Dpxm8 = 0; // drawing window pixmap, Mscale 8-bits
+
+-mutex Fpixmap_lock; // lock for accessing PXM pixmaps
++mutex_tp Fpixmap_lock; // lock for accessing PXM pixmaps
+
+ int Fww, Fhh; // input image dimensions
+ int E1ww, E1hh, E3ww, E3hh; // edit image dimensions
@@ -986,7 +993,7 @@
}
diff --git a/graphics/fotoxx/files/patch-zfuncs.cc b/graphics/fotoxx/files/patch-zfuncs.cc
index f92ddf042292..f6158620de8b 100644
--- a/graphics/fotoxx/files/patch-zfuncs.cc
+++ b/graphics/fotoxx/files/patch-zfuncs.cc
@@ -1,5 +1,5 @@
---- zfuncs.cc.orig 2011-02-28 17:04:24.000000000 +0100
-+++ zfuncs.cc 2011-05-26 10:04:13.000000000 +0200
+--- zfuncs.cc.orig 2011-02-28 16:04:24.000000000 +0000
++++ zfuncs.cc 2013-03-30 09:00:04.000000000 +0000
@@ -24,6 +24,15 @@
#include "zfuncs.h"
@@ -16,6 +16,15 @@
/**************************************************************************
system-level utility functions
+@@ -281,7 +290,7 @@
+ // safely access parameters from multiple threads
+ // limitation: one lock for any number of parameters
+
+-mutex zget_lock = PTHREAD_MUTEX_INITIALIZER;
++mutex_tp zget_lock = PTHREAD_MUTEX_INITIALIZER;
+
+ int zget_locked(int &param) // lock and return parameter
+ {
@@ -778,23 +787,27 @@
char fname[200]; // null-terminated file name within directory
};
@@ -117,3 +126,12 @@
if (strEqu(pp,"root")) snprintf(zuserdir,199,"/root/.%s",zappname); // get /root/.appname
else snprintf(zuserdir,199,"%s/.%s",getenv("HOME"),zappname); // or /home/user/.appname
+@@ -3435,7 +3441,7 @@
+ pthread_t tids[tmax];
+ int tlocks[tmax];
+ int zinit = 0;
+-mutex zmutex;
++mutex_tp zmutex;
+
+ void zlockInit() // initz. call from main()
+ {
diff --git a/graphics/fotoxx/files/patch-zfuncs.h b/graphics/fotoxx/files/patch-zfuncs.h
index 4cfd1a9c6209..01a996ece9b6 100644
--- a/graphics/fotoxx/files/patch-zfuncs.h
+++ b/graphics/fotoxx/files/patch-zfuncs.h
@@ -1,5 +1,5 @@
---- zfuncs.h.orig 2011-02-28 17:04:24.000000000 +0100
-+++ zfuncs.h 2011-05-25 17:50:21.000000000 +0200
+--- zfuncs.h.orig 2011-02-28 16:04:24.000000000 +0000
++++ zfuncs.h 2013-03-30 08:58:28.000000000 +0000
@@ -36,7 +36,13 @@
#include <signal.h>
#include <execinfo.h>
@@ -15,3 +15,21 @@
#define int8 char // number types
#define int16 short
+@@ -52,7 +58,7 @@
+
+ #define wstrerror(err) strerror(WEXITSTATUS(err)) // get text status for child process
+
+-#define mutex pthread_mutex_t // abbreviations
++#define mutex_tp pthread_mutex_t // abbreviations
+ #define mutex_init pthread_mutex_init
+ #define mutex_lock pthread_mutex_lock
+ #define mutex_trylock pthread_mutex_trylock
+@@ -504,7 +510,7 @@
+ {
+ char wmi[8];
+ Vxstring * vd; // vector of xstrings
+- mutex qmutex; // for multi-thread access
++ mutex_tp qmutex; // for multi-thread access
+ int qcap; // queue capacity
+ int qcount; // curr. queue count
+ int ent1; // first entry pointer