aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/fpc-imagemagick
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2009-01-14 10:46:22 +0800
committeracm <acm@FreeBSD.org>2009-01-14 10:46:22 +0800
commita8010c76abeca848ada3e80d3f349efc5ff25d80 (patch)
treeaa140733c0421ef376ec6c00a6ed8cfed89c0a5f /graphics/fpc-imagemagick
parentea4199b39230c1347525192e00486fcca5da40e4 (diff)
downloadfreebsd-ports-gnome-a8010c76abeca848ada3e80d3f349efc5ff25d80.tar.gz
freebsd-ports-gnome-a8010c76abeca848ada3e80d3f349efc5ff25d80.tar.zst
freebsd-ports-gnome-a8010c76abeca848ada3e80d3f349efc5ff25d80.zip
- New port: graphics/fpc-imagemagick
Free Pascal interface to ImageMagick
Diffstat (limited to 'graphics/fpc-imagemagick')
-rw-r--r--graphics/fpc-imagemagick/Makefile23
-rw-r--r--graphics/fpc-imagemagick/pkg-plist15
2 files changed, 38 insertions, 0 deletions
diff --git a/graphics/fpc-imagemagick/Makefile b/graphics/fpc-imagemagick/Makefile
new file mode 100644
index 000000000000..af5f0057b928
--- /dev/null
+++ b/graphics/fpc-imagemagick/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: fpc-imagemagick
+# Date created: 2009-01-06
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+CATEGORIES= graphics lang
+PKGNAMESUFFIX= -imagemagick
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Free Pascal interface to ImageMagick
+
+USE_FPC= yes
+
+MASTERDIR= ${.CURDIR}/../../lang/fpc
+WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}
+EXTRACTUNITDIR+= ${WRKUNITDIR}
+
+OPTIONS= IMAGEMAGICK "Install ImageMagick image proccesing tool" on
+
+.include "${MASTERDIR}/Makefile"
diff --git a/graphics/fpc-imagemagick/pkg-plist b/graphics/fpc-imagemagick/pkg-plist
new file mode 100644
index 000000000000..f276cca2f436
--- /dev/null
+++ b/graphics/fpc-imagemagick/pkg-plist
@@ -0,0 +1,15 @@
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/imagemagick/Package.fpc
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/imagemagick/buildim.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/imagemagick/magick_wand.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/imagemagick/imagemagick.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/imagemagick/buildim.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/imagemagick/magick_wand.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/imagemagick/imagemagick.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/imagemagick/libpbuildim.a
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/imagemagick/libpmagick_wand.a
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/imagemagick/libpimagemagick.a
+@dirrm lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/imagemagick
+@dirrmtry lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%
+@dirrmtry lib/fpc/%%PORTVERSION%%/units
+@dirrmtry lib/fpc/%%PORTVERSION%%
+@dirrmtry lib/fpc