aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/frontline/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-09-14 00:49:28 +0800
committersobomax <sobomax@FreeBSD.org>2002-09-14 00:49:28 +0800
commit7c87c06e5b4d234930300e071e8fc03b1fb163b9 (patch)
tree732b26612830a843046ad53ef8d1a342814f3e78 /graphics/frontline/Makefile
parent0995f919972ed6837445211cafd5965688286c20 (diff)
downloadfreebsd-ports-gnome-7c87c06e5b4d234930300e071e8fc03b1fb163b9.tar.gz
freebsd-ports-gnome-7c87c06e5b4d234930300e071e8fc03b1fb163b9.tar.zst
freebsd-ports-gnome-7c87c06e5b4d234930300e071e8fc03b1fb163b9.zip
Add frontline 0.5.1, an autotrace GUI FRONTend like streamLINE(TM).
Diffstat (limited to 'graphics/frontline/Makefile')
-rw-r--r--graphics/frontline/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/graphics/frontline/Makefile b/graphics/frontline/Makefile
new file mode 100644
index 000000000000..82c2d05a2ef9
--- /dev/null
+++ b/graphics/frontline/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: frontline
+# Date created: 12 September 2002
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= frontline
+PORTVERSION= 0.5.1
+CATEGORIES= graphics gnome
+MASTER_SITES= http://autotrace.sourceforge.net/frontline/
+
+MAINTAINER= gnome@FreeBSD.org
+
+LIB_DEPENDS= autotrace.1:${PORTSDIR}/graphics/autotrace \
+ art_lgpl_2.5:${PORTSDIR}/graphics/libart_lgpl2
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack gnomelibs imlib
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+
+.include <bsd.port.mk>