aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/fv
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-12-25 05:53:51 +0800
committerantoine <antoine@FreeBSD.org>2014-12-25 05:53:51 +0800
commitd32a56e748b2ee9e871cfc9925d479bc1a67f3c0 (patch)
treeb02dcc288d7d639cbec84a1697fa9602c8c232a2 /graphics/fv
parentfe7f26b0d7fac856eb285de45c97743ea7fb26bf (diff)
downloadfreebsd-ports-gnome-d32a56e748b2ee9e871cfc9925d479bc1a67f3c0.tar.gz
freebsd-ports-gnome-d32a56e748b2ee9e871cfc9925d479bc1a67f3c0.tar.zst
freebsd-ports-gnome-d32a56e748b2ee9e871cfc9925d479bc1a67f3c0.zip
Properly support png 1.5
Diffstat (limited to 'graphics/fv')
-rw-r--r--graphics/fv/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/graphics/fv/Makefile b/graphics/fv/Makefile
index 341c1c13043a..ca097426ad56 100644
--- a/graphics/fv/Makefile
+++ b/graphics/fv/Makefile
@@ -13,15 +13,15 @@ COMMENT= Viewer of hdr/pfm images
LICENSE= GPLv2
-LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
USES= gmake pkgconfig zip
USE_GL= glut
ALL_TARGET= ${PORTNAME}
-CXXFLAGS+= $$(pkg-config --cflags libpng15) \
+CXXFLAGS+= $$(pkg-config --cflags libpng) \
-I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS+= $$(pkg-config --libs libpng15) \
+LDFLAGS+= $$(pkg-config --libs libpng) \
-L${LOCALBASE}/lib -lglut -lGLU -lGL -lbz2 -lm -lz -llzma \
${PTHREAD_LIBS}