aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/fyre
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2004-07-11 23:29:17 +0800
committeradamw <adamw@FreeBSD.org>2004-07-11 23:29:17 +0800
commit0784c04d8e6845eaac16c4c91a35ec8681bb0ff3 (patch)
tree93b938a63dec9a4e017c13185036a60e271e320d /graphics/fyre
parent1d5ddc8d7a66e89ca55bb6ffb3180a781bf8396d (diff)
downloadfreebsd-ports-gnome-0784c04d8e6845eaac16c4c91a35ec8681bb0ff3.tar.gz
freebsd-ports-gnome-0784c04d8e6845eaac16c4c91a35ec8681bb0ff3.tar.zst
freebsd-ports-gnome-0784c04d8e6845eaac16c4c91a35ec8681bb0ff3.zip
Add fyre, a chaos map renderer with a spiffy Gtk+ 2 interface.
It makes durn purty pictures. Fyre provides a rendering of the Peter de Jong map, with an interactive GTK+ 2 frontend and a command line interface for easy and efficient rendering of high-resolution, high quality images. This program was previously known as 'de Jong Explorer', but has been renamed to make way for supporting other chaotic functions. All the images you can create with this program are based on the simple Peter de Jong map equations: x' = sin(a * y) - cos(b * x) y' = sin(c * x) - cos(d * y) WWW: http://fyre.navi.cx/
Diffstat (limited to 'graphics/fyre')
-rw-r--r--graphics/fyre/Makefile49
-rw-r--r--graphics/fyre/distinfo2
-rw-r--r--graphics/fyre/files/patch-Makefile41
-rw-r--r--graphics/fyre/pkg-descr14
-rw-r--r--graphics/fyre/pkg-plist6
5 files changed, 112 insertions, 0 deletions
diff --git a/graphics/fyre/Makefile b/graphics/fyre/Makefile
new file mode 100644
index 000000000000..27755ba2bde2
--- /dev/null
+++ b/graphics/fyre/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: fyre
+# Date created: 2004 11 July
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fyre
+PORTVERSION= 0.6
+CATEGORIES= graphics
+MASTER_SITES= http://navi.cx/releases/
+
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= Chaos map rendering system with GTK+-2 interface
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GNOME= libglade2
+
+USE_GMAKE= yes
+ALL_TARGET= ${PORTNAME}
+MAKE_ENV+= CPPFLAGS="${CPPFLAGS}"
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "i386"
+.if defined(WITH_OPTIMIZED_CFLAGS)
+CPPFLAGS+= -march=i686 -O3 -ffast-math \
+ -fomit-frame-pointer -D__NO_INLINE__
+.else
+pre-everything::
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} "Define WITH_OPTIMIZED_CFLAGS to enable"
+ @${ECHO_CMD} "compiler optimizations."
+ @${ECHO_CMD} ""
+.endif
+.endif
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/gnome/${PORTNAME}
+ @${INSTALL_DATA} ${WRKSRC}/data/*.glade \
+ ${PREFIX}/share/gnome/${PORTNAME}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.post.mk>
diff --git a/graphics/fyre/distinfo b/graphics/fyre/distinfo
new file mode 100644
index 000000000000..d4de81785937
--- /dev/null
+++ b/graphics/fyre/distinfo
@@ -0,0 +1,2 @@
+MD5 (fyre-0.6.tar.bz2) = 63a1570d44a5e3600a2348a2bceb87a4
+SIZE (fyre-0.6.tar.bz2) = 61440
diff --git a/graphics/fyre/files/patch-Makefile b/graphics/fyre/files/patch-Makefile
new file mode 100644
index 000000000000..d47d9d70e7e9
--- /dev/null
+++ b/graphics/fyre/files/patch-Makefile
@@ -0,0 +1,41 @@
+--- Makefile.orig Sun Jul 11 02:26:40 2004
++++ Makefile Sun Jul 11 11:13:07 2004
+@@ -1,21 +1,21 @@
+ # -march=i686 speeds this up quite a bit on my machine (even more so
+ # than -march=athlon-xp) so if this looks like a recent x86 machine,
+ # stick that in CFLAGS
+-CFLAGS += $(shell if grep mmx /proc/cpuinfo > /dev/null; then echo -march=i686; fi)
++#CFLAGS += $(shell if grep mmx /proc/cpuinfo > /dev/null; then echo -march=i686; fi)
+
+ # -O3 and -ffast-math should make it go much faster on any system
+-ifeq ($(CC),icc)
+- CFLAGS += -O3
+-else
+- CFLAGS += -O3 -ffast-math
+-endif
++#ifeq ($(CC),icc)
++# CFLAGS += -O3
++#else
++# CFLAGS += -O3 -ffast-math
++#endif
+
+ # Disable glibc versions of functions that have faster versions
+ # as gcc inlines. This should speed up trig on some systems.
+-CFLAGS += -D__NO_INLINE__
++#CFLAGS += -D__NO_INLINE__
+
+ PKGS += libglade-2.0 gtk+-2.0
+-CFLAGS += '-DGLADEDIR="data"'
++CFLAGS += '-DGLADEDIR="${PREFIX}/share/gnome/fyre"'
+ CFLAGS += $(shell pkg-config --cflags $(PKGS))
+ LIBS += $(shell pkg-config --libs $(PKGS))
+
+@@ -50,7 +50,7 @@
+ $(CC) -o $@ $(OBJS) $(LIBS)
+
+ %.o: %.c src/*.h
+- $(CC) -c -o $@ $< $(CFLAGS)
++ $(CC) -c -o $@ $< $(CFLAGS) $(CPPFLAGS)
+
+ clean:
+ rm -f $(BIN) src/*.o
diff --git a/graphics/fyre/pkg-descr b/graphics/fyre/pkg-descr
new file mode 100644
index 000000000000..a0a18754b9ed
--- /dev/null
+++ b/graphics/fyre/pkg-descr
@@ -0,0 +1,14 @@
+Fyre provides a rendering of the Peter de Jong map, with an interactive
+GTK+ 2 frontend and a command line interface for easy and efficient
+rendering of high-resolution, high quality images.
+
+This program was previously known as 'de Jong Explorer', but has been
+renamed to make way for supporting other chaotic functions.
+
+All the images you can create with this program are based on the simple
+Peter de Jong map equations:
+
+ x' = sin(a * y) - cos(b * x)
+ y' = sin(c * x) - cos(d * y)
+
+WWW: http://fyre.navi.cx/
diff --git a/graphics/fyre/pkg-plist b/graphics/fyre/pkg-plist
new file mode 100644
index 000000000000..46fb3221f7ee
--- /dev/null
+++ b/graphics/fyre/pkg-plist
@@ -0,0 +1,6 @@
+bin/fyre
+%%PORTDOCS%%%%DOCSDIR%%/README
+share/gnome/fyre/animation-render.glade
+share/gnome/fyre/explorer.glade
+@dirrm share/gnome/fyre
+%%PORTDOCS%%@dirrm %%DOCSDIR%%