aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gauche-gl/Makefile
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2003-01-25 22:06:53 +0800
committernork <nork@FreeBSD.org>2003-01-25 22:06:53 +0800
commite3e66af9a23016ec1a3bd3bacfc1260eb5d2f70c (patch)
tree9b6be05017cc9086edc97f9264dd7d1756e7b61a /graphics/gauche-gl/Makefile
parent63055fa6cf89304bd4d6a18cbcab96112525b759 (diff)
downloadfreebsd-ports-gnome-e3e66af9a23016ec1a3bd3bacfc1260eb5d2f70c.tar.gz
freebsd-ports-gnome-e3e66af9a23016ec1a3bd3bacfc1260eb5d2f70c.tar.zst
freebsd-ports-gnome-e3e66af9a23016ec1a3bd3bacfc1260eb5d2f70c.zip
Add gauche-gl 0.2.1, openGL binding for Gauche.
PR: ports/46285 Submitted by: Kimura Fuyuki <fuyuki@hadaly.org>
Diffstat (limited to 'graphics/gauche-gl/Makefile')
-rw-r--r--graphics/gauche-gl/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/graphics/gauche-gl/Makefile b/graphics/gauche-gl/Makefile
new file mode 100644
index 000000000000..dcad85021c0b
--- /dev/null
+++ b/graphics/gauche-gl/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: Gauche-gl
+# Date created: 16 December 2002
+# Whom: Kimura Fuyuki <fuyuki@hadaly.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gl
+PORTVERSION= 0.2.1
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gauche
+PKGNAMEPREFIX= gauche-
+DISTNAME= Gauche-${PORTNAME}-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= fuyuki@hadaly.org
+
+BUILD_DEPENDS= gosh:${PORTSDIR}/lang/gauche
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+WRKSRC= ${WRKDIR}/Gauche-${PORTNAME}
+USE_MESA= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include"
+
+EXAMPLESDIR= ${PREFIX}/share/examples/gauche/${PORTNAME}
+DOCSDIR= ${PREFIX}/share/doc/gauche/${PORTNAME}
+PLIST_SUB= VERSION="`gauche-config -V`" \
+ TARGET="${CONFIGURE_TARGET}"
+
+do-install:
+ cd ${WRKSRC}/src; ${MAKE} ${INSTALL_TARGET}
+ cd ${WRKSRC}/lib; ${MAKE} ${INSTALL_TARGET}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/examples/* ${EXAMPLESDIR}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>