aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gd1/Makefile
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2001-10-26 20:07:02 +0800
committerroam <roam@FreeBSD.org>2001-10-26 20:07:02 +0800
commit546b9e0e1c99f3432cf8959334bf3ec0564bf572 (patch)
tree712a44ac6c9a2e813fdb69066c077a7b2c794102 /graphics/gd1/Makefile
parent84ce805e5e119415489f90afbfcac1a73f08a487 (diff)
downloadfreebsd-ports-gnome-546b9e0e1c99f3432cf8959334bf3ec0564bf572.tar.gz
freebsd-ports-gnome-546b9e0e1c99f3432cf8959334bf3ec0564bf572.tar.zst
freebsd-ports-gnome-546b9e0e1c99f3432cf8959334bf3ec0564bf572.zip
Install the HTML documentation.
Approved by: silence on -ports
Diffstat (limited to 'graphics/gd1/Makefile')
-rw-r--r--graphics/gd1/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/graphics/gd1/Makefile b/graphics/gd1/Makefile
index 3a67bd9a3207..b0d7e82fb62f 100644
--- a/graphics/gd1/Makefile
+++ b/graphics/gd1/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gd
PORTVERSION= 1.8.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES+= graphics
MASTER_SITES= http://www.boutell.com/gd/http/ \
ftp://ftp.boutell.com/pub/boutell/gd/ \
@@ -35,6 +35,8 @@ USE_XPM= yes
INSTALLS_SHLIB= yes
+DOCS= index.html
+
post-extract:
bzip2 -d < ${_DISTDIR}/gd_gif_in.c.bz2 > ${WRKSRC}/gd_gif_in.c
@@ -44,4 +46,10 @@ pre-everything:
@${ECHO_MSG} "'make -DWITH_X11' instead"
.endif
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+.endif
+
.include <bsd.port.mk>