aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gd
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2013-08-09 22:05:52 +0800
committerdinoex <dinoex@FreeBSD.org>2013-08-09 22:05:52 +0800
commit14d2aa29a0faada324c532f4dd6339b0d61a7262 (patch)
tree4b54bdffc904e7c6b2e7107151b63bada3f0ecb6 /graphics/gd
parenta46f79024f1840906c8b267d5228b5a662b00b13 (diff)
downloadfreebsd-ports-gnome-14d2aa29a0faada324c532f4dd6339b0d61a7262.tar.gz
freebsd-ports-gnome-14d2aa29a0faada324c532f4dd6339b0d61a7262.tar.zst
freebsd-ports-gnome-14d2aa29a0faada324c532f4dd6339b0d61a7262.zip
- update libdg to 2.1.0
Diffstat (limited to 'graphics/gd')
-rw-r--r--graphics/gd/Makefile130
-rw-r--r--graphics/gd/distinfo4
-rw-r--r--graphics/gd/files/Makefile.bsd52
-rw-r--r--graphics/gd/files/configure44
-rw-r--r--graphics/gd/files/makefonts31
-rw-r--r--graphics/gd/files/patch-bdftogd4
-rw-r--r--graphics/gd/files/patch-cve-2009-354615
-rw-r--r--graphics/gd/files/patch-gd_gif_out.c24
-rw-r--r--graphics/gd/files/patch-gd_png.c41
-rw-r--r--graphics/gd/files/patch-gdtest.c44
-rw-r--r--graphics/gd/pkg-plist9
11 files changed, 156 insertions, 242 deletions
diff --git a/graphics/gd/Makefile b/graphics/gd/Makefile
index 4a28e68c0fde..a316a98f89cd 100644
--- a/graphics/gd/Makefile
+++ b/graphics/gd/Makefile
@@ -1,74 +1,83 @@
# Created by: jeff@cetlink.net
# $FreeBSD$
-PORTNAME= gd
-PORTVERSION= 2.0.35
-PORTREVISION?= 9
+PORTNAME= libgd
+PORTVERSION= 2.1.0
+PORTREVISION?= 0
PORTEPOCH= 1
CATEGORIES+= graphics
-MASTER_SITES= http://www.libgd.org/releases/ \
- ${MASTER_SITE_RINGSERVER}
-MASTER_SITE_SUBDIR= graphics/gd
-PKGNAMESUFFIX?= ${NOX11_SUFFIX}${PKGNAMESUFFIX2}
+MASTER_SITES= http://cdn.bitbucket.org/libgd/gd-libgd/downloads/
MAINTAINER?= dinoex@FreeBSD.org
COMMENT?= A graphics library for fast creation of images
LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
+ tiff:${PORTSDIR}/graphics/tiff \
png15:${PORTSDIR}/graphics/png \
freetype:${PORTSDIR}/print/freetype2
CONFLICTS= bazaar-1.*
-USE_BZIP2= yes
-SCRIPTDIR= ${FILESDIR}
-MAKE_ENV= WRKSRC="${WRKSRC}"
-MAKEFILE= ${FILESDIR}/Makefile.bsd
-CPPFLAGS+= -DHAVE_ERRNO_H -DHAVE_FT2BUILD_H -DHAVE_LIBFREETYPE -DHAVE_LIBJPEG -DHAVE_LIBPNG \
- -DHAVE_LIBZ -DHAVE_STDDEF_H -DHAVE_STDINT_H -DHAVE_STDLIB_H
-LDFLAGS+= -L${WRKSRC}
-LDFLAGS2= -L${PREFIX}/lib -L${LOCALBASE}/lib
-FEATURES= GD_JPEG GD_FREETYPE GD_PNG GD_GIF GD_GIFANIM GD_OPENPOLYGON
+USE_XZ= yes
+USES= pkgconfig
+GNU_CONFIGURE= yes
+GNU_CONFIGURE_ENV= PKG_CONFIG_LIBDIR=${LOCALBASE}/libdata/pkgconfig
+GNU_CONFIGURE_ARGS=
USE_LDCONFIG= yes
WANT_PERL= yes
-OPTIONS_DEFINE= FONTCONFIG ICONV XPM
+OPTIONS_DEFINE= FONTCONFIG ICONV VPX XPM
OPTIONS_DEFAULT=FONTCONFIG
NO_OPTIONS_SORT=yes
.include <bsd.port.options.mk>
+PKGCONFIGDIR?= ${LOCALBASE}/libdata/pkgconfig
+# force gdlib-config --ldflags
+LDFLAGS+= -L${LOCALBASE}/lib
+
.if ${PORT_OPTIONS:MFONTCONFIG}
LIB_DEPENDS+= fontconfig:${PORTSDIR}/x11-fonts/fontconfig
-CPPFLAGS+= -I${LOCALBASE}/include -DHAVE_LIBFONTCONFIG -DHAVE_PTHREAD ${PTHREAD_CFLAGS}
-LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib -lfontconfig
-LDFLAGS2+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib
-FEATURES+= GD_FONTCONFIG
+.else
+GNU_CONFIGURE_ARGS+= --with-fontconfig=no
.endif
.if ${PORT_OPTIONS:MICONV}
USES+= iconv
-CPPFLAGS+= -DHAVE_ICONV -DHAVE_ICONV_H -DHAVE_ICONV_T_DEF
-LDFLAGS+= -L${LOCALBASE}/lib -liconv
+GNU_CONFIGURE_ARGS+= --with-libiconv-prefix=${LOCALBASE}
+.else
+GNU_CONFIGURE_ARGS+= --without-libiconv
+GNU_CONFIGURE_ARGS+= --with-libiconv-prefix=no
+.endif
+
+.if ${PORT_OPTIONS:MVPX}
+LIB_DEPENDS+= vpx:${PORTSDIR}/multimedia/libvpx
+.else
+CONFIGURE_ARGS+= --without-vpx
.endif
# honor global WITHOUT_X11
.if !defined(WITHOUT_X11)
.if ${PORT_OPTIONS:MXPM}
USE_XORG= xpm x11
-CPPFLAGS+= -I${LOCALBASE}/include/X11 -I${LOCALBASE}/include -DHAVE_LIBXPM
-LDFLAGS+= -L${LOCALBASE}/lib -lXpm -lX11
-LDFLAGS2+= -L${LOCALBASE}/lib
-FEATURES+= GD_XPM
+GNU_CONFIGURE_ARGS+= --with-x
+.else
+GNU_CONFIGURE_ARGS+= --with-xpm=no
.endif
.endif
-FONTBASE= ${LOCALBASE}/lib/X11/fonts
-
-# supprt for bitmap fonts
+# The GD_FONTS environment variable can be set to specify the gzipped
+# tar-ball containing the fonts in bdf format and the bdf file names.
+# The tarball is the first argument, the tiny, small, medium-bold,
+# large, and giant fonts follow.
+#
+# For example:
+# GD_FONTS="/usr/ports/distfiles/x-koi8u.tgz koi6x10.bdf koi8x13.bdf \
+# koi9x15.bdf koi12x24.bdf koi10x20.bdf"
+#
.if defined(GD_FONTS)
USE_PERL5_BUILD= yes
-SCRIPTS_ENV+= GD_FONTS="${GD_FONTS}"
+WRKFONTS= ${WRKSRC}/src
.endif
pre-extract::
@@ -76,30 +85,47 @@ pre-extract::
@${ECHO_MSG} "GD_FONTS can be set to specify an alternative list of .bdf files"
@${ECHO_MSG} ""
-post-configure:
- ${SED} -e 's|@libdir@|${PREFIX}/lib|' \
- -e 's|@includedir@|${PREFIX}/include|' \
- -e 's|@VERSION@|${PORTVERSION}|' \
- -e 's|@GDLIB_MAJOR@|${PORTVERSION:C/([0-9]*).*/\1/1}|' \
- -e 's|@GDLIB_MINOR@|${PORTVERSION:C/[0-9]*[.]([0-9]).*/\1/1}|' \
- -e 's|@GDLIB_REVISION@|${PORTVERSION:C/.*[.]([0-9]*)/\1/1}|' \
- -e 's|@LDFLAGS@|${LDFLAGS2}|' \
- -e 's|@LIBS@|-lgd|' \
- -e 's|@LIBICONV@|${LIBICONV}|' \
- -e 's|@FEATURES@|${FEATURES}|' \
- ${WRKSRC}/config/gdlib-config.in \
- > ${WRKDIR}/gdlib-config
+post-extract:
+.if defined(GD_FONTS)
+ cd ${WRKFONTS} && ${SH} ${FILESDIR}/makefonts extract ${GD_FONTS}
+.endif
+
+pre-configure:
+.if defined(GD_FONTS)
+ cd ${WRKFONTS} && ${SH} ${FILESDIR}/makefonts configure ${GD_FONTS}
+.endif
+ # force PKGCONFIGDIR
+ ${REINPLACE_CMD} \
+ -e 's|^pkgconfigdir =.*|pkgconfigdir = ${PKGCONFIGDIR}|' \
+ ${WRKSRC}/config/Makefile.in
+ # bump shlib version
${REINPLACE_CMD} \
- -e 's|#define DEFAULT_FONTPATH .*|#define DEFAULT_FONTPATH "${FONTBASE}/TTF:${FONTBASE}/Type1:${FONTBASE}"|' \
- ${WRKSRC}/gd.h
+ -e 's|GDLIB_CURRENT=.*|GDLIB_CURRENT=5|' \
+ ${WRKSRC}/configure
+ # workaround for broken configure
+.if ! ${PORT_OPTIONS:MICONV}
+ ${REINPLACE_CMD} \
+ -e 's|iconv|noiconv|' \
+ ${WRKSRC}/configure
+.endif
+.if ! ${PORT_OPTIONS:MXPM}
+ ${REINPLACE_CMD} \
+ -e 's|xpm|noxpm|' \
+ ${WRKSRC}/configure
+.endif
+.if ! ${PORT_OPTIONS:MFONTCONFIG}
+ ${REINPLACE_CMD} \
+ -e 's|fontconfig|nofontconfig|' \
+ ${WRKSRC}/configure
+.endif
+
+.if defined(GD_FONTS)
+pre-build:
+ cd ${WRKFONTS} && ${SH} ${FILESDIR}/makefonts build ${GD_FONTS}
+.endif
post-install:
- ${INSTALL_DATA} ${WRKSRC}/gdfx.h ${WRKSRC}/gdhelpers.h \
+ ${INSTALL_DATA} ${WRKSRC}/src/gdhelpers.h \
${PREFIX}/include/
- ${INSTALL_SCRIPT} ${WRKDIR}/gdlib-config ${PREFIX}/bin/
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/index.html ${DOCSDIR}
-.endif
.include <bsd.port.mk>
diff --git a/graphics/gd/distinfo b/graphics/gd/distinfo
index a124c3ab4acf..5a470af3de53 100644
--- a/graphics/gd/distinfo
+++ b/graphics/gd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gd-2.0.35.tar.bz2) = bf222490749d2a9a9ac3593b01eb55aed98461ff81202414707f61b42aa300f9
-SIZE (gd-2.0.35.tar.bz2) = 1212730
+SHA256 (libgd-2.1.0.tar.xz) = fa6665dfe3d898019671293c84d77067a3d2ede50884dbcb6df899d508370e5a
+SIZE (libgd-2.1.0.tar.xz) = 2004304
diff --git a/graphics/gd/files/Makefile.bsd b/graphics/gd/files/Makefile.bsd
deleted file mode 100644
index 6c989ec2257e..000000000000
--- a/graphics/gd/files/Makefile.bsd
+++ /dev/null
@@ -1,52 +0,0 @@
-# Makefile
-PROGS= pngtogd pngtogd2 gdtopng gd2topng gd2copypal gdparttopng webpng \
- gd2togif gdcmpgif giftogd2 annotate
-TESTS= gdtest gddemo gd2time gdtestft testac fontsizetest fontwheeltest
-SRCS= gd.c gd_gd.c gd_gd2.c gd_io.c gd_io_dp.c gd_io_file.c \
- gd_io_ss.c gd_jpeg.c gd_png.c gd_ss.c gd_topal.c \
- gd_wbmp.c gdcache.c gdfontg.c gdfontl.c gdfontmb.c \
- gdfonts.c gdfontt.c gdft.c gdfx.c gdhelpers.c gdhelpers.h \
- gdkanji.c gdtables.c gdxpm.c gd_security.c \
- wbmp.c gd_gif_in.c gd_gif_out.c
-MAKEDIR=/usr/share/mk
-LIB=gd
-SHLIB_MAJOR=4
-SHLIB_MINOR=0
-INCS= gd.h gd_io.h gdcache.h gdfontg.h gdfontl.h gdfontmb.h \
- gdfonts.h gdfontt.h entities.h
-SHLIB_NAME!= ${MAKE} -V SHLIB_NAME LIB=${LIB} \
- SHLIB_MAJOR=${SHLIB_MAJOR} SHLIB_MINOR=${SHLIB_MINOR} -f ${MAKEDIR}/bsd.lib.mk
-
-CFLAGS+= -I${.CURDIR} -I${LOCALBASE}/include/freetype2/freetype \
- -I${LOCALBASE}/include/freetype2 -I${LOCALBASE}/include \
- -DHAVE_LIBPNG -DHAVE_LIBJPEG -DHAVE_LIBFREETYPE -DHAVE_LIBZ \
- ${CPPFLAGS}
-LDADD= -L${LOCALBASE}/lib -lpng -lz -ljpeg -lfreetype -lm \
- ${LDFLAGS}
-
-# The package comes with tests, but without any sort of test-harness,
-# to run them all automaticly. So building tests is disabled here. -mi
-all: lib${LIB}.a ${SHLIB_NAME} ${PROGS} # ${TESTS}
-
-lib${LIB}.a ${SHLIB_NAME}: ${SRCS}
- ${MAKE} LIB=${LIB} SRCS="${SRCS}" \
- SHLIB_MAJOR=${SHLIB_MAJOR} SHLIB_MINOR=${SHLIB_MINOR} \
- CFLAGS="${CFLAGS}" LDADD="${LDADD}" \
- -f ${MAKEDIR}/bsd.lib.mk ${.TARGET}
-
-${PROGS} ${TESTS}: ${SHLIB_NAME} lib${LIB}.a
- ${MAKE} PROG=${.TARGET} NO_MAN=1 NOMAN=1 LDADD="-L${.CURDIR} -lgd" \
- CFLAGS="${CFLAGS}" -f ${MAKEDIR}/bsd.prog.mk
-
-install:
- mkdir -p ${PREFIX}/include
- ${MAKE} LIB=${LIB} LIBDIR=${PREFIX}/lib NOPROFILE=true NO_PROFILE=true \
- SHLIB_MAJOR=${SHLIB_MAJOR} SHLIB_MINOR=${SHLIB_MINOR} \
- -f ${MAKEDIR}/bsd.lib.mk install
- cd ${.CURDIR} && ${BSD_INSTALL_DATA} ${INCS} ${PREFIX}/include
- cd ${.CURDIR} && ${BSD_INSTALL_PROGRAM} ${PROGS} ${PREFIX}/bin/
- ${BSD_INSTALL_SCRIPT} ${.CURDIR}/bdftogd ${PREFIX}/bin/
-
-.if exists(${.CURDIR}/Makefile.fonts)
-.include "Makefile.fonts"
-.endif
diff --git a/graphics/gd/files/configure b/graphics/gd/files/configure
deleted file mode 100644
index 3ab959bb3dbf..000000000000
--- a/graphics/gd/files/configure
+++ /dev/null
@@ -1,44 +0,0 @@
-#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/graphics/gd/files/configure,v 1.1 2004-01-14 06:14:42 dinoex Exp $
-
-# The GD_FONTS environment variable can be set to specify the gzipped
-# tar-ball containing the fonts in bdf format and the bdf file names.
-#
-# For example:
-# GD_FONTS="/usr/ports/distfiles/x-koi8u.tgz koi6x10.bdf koi8x13.bdf \
-# koi9x15.bdf koi12x24.bdf koi10x20.bdf"
-#
-# This can be usefull for slave ports, like ukrainian/gd, which may
-# now provide alternative fonts easily.
-
-# TODO: . handle multiple archiving formats: tgz, tar.bz2, zip
-# . allow for passing already extracted font-files
-
-if [ -z "$GD_FONTS" ]
-then
- echo "GD_FONTS can be set to specify an alternative list of .bdf files"
- echo "See $0 for details..."
- exit 0
-fi
-
-set $GD_FONTS
-#
-# The tarball is the first argument, the tiny, small, medium-bold,
-# large, and giant fonts follow.
-#
-
-tarball=$1
-shift
-tar -xvzpf $tarball -C $WRKSRC $@
-
-rm -f $WRKSRC/Makefile.fonts
-
-for font in Tiny Small MediumBold Large Giant
-do
- f=`echo $font | tr -d [[:lower:]] | tr [[:upper:]] [[:lower:]]`
- rm -f $WRKSRC/gdfont$f.[ch]
- printf 'gdfont%s.c gdfont%s.h: %s\
- perl ${.CURDIR}/bdftogd gdFont%s font%s < %s\n' \
- $f $f $1 $font $f $1 >> $WRKSRC/Makefile.fonts
- shift
-done
diff --git a/graphics/gd/files/makefonts b/graphics/gd/files/makefonts
new file mode 100644
index 000000000000..5891403d82cc
--- /dev/null
+++ b/graphics/gd/files/makefonts
@@ -0,0 +1,31 @@
+#!/bin/sh
+# $FreeBSD$
+
+target="${1}"
+shift
+tarball="${1}"
+shift
+fonts="Tiny Small MediumBold Large Giant"
+case "${target}" in
+extract)
+ tar -xvzpf "${tarball}" $@
+ ;;
+configure)
+ for font in ${fonts}
+ do
+ f=`echo "${font}" | tr -d [[:lower:]] | tr [[:upper:]] [[:lower:]]`
+ mv -v "gdfont${f}.c" "gdfont${f}.c.dist"
+ mv -v "gdfont${f}.h" "gdfont${f}.h.dist"
+ done
+ ;;
+build)
+ set -x
+ for font in ${fonts}
+ do
+ f=`echo "${font}" | tr -d [[:lower:]] | tr [[:upper:]] [[:lower:]]`
+ perl ./bdftogd "gdFont${font}" "font${f}" < "${1}"
+ shift
+ done
+ ;;
+esac
+# eof
diff --git a/graphics/gd/files/patch-bdftogd b/graphics/gd/files/patch-bdftogd
index f77dbb34a2cd..b0eb14d63c05 100644
--- a/graphics/gd/files/patch-bdftogd
+++ b/graphics/gd/files/patch-bdftogd
@@ -1,5 +1,5 @@
---- bdftogd.orig Fri Feb 2 18:41:00 2007
-+++ bdftogd Tue Feb 13 19:55:02 2007
+--- src/bdftogd.orig 2013-06-25 11:58:23.000000000 +0200
++++ src/bdftogd 2013-08-01 07:06:11.000000000 +0200
@@ -24,6 +24,9 @@
my $filename = shift;
$filename = 'gd' . $filename unless $filename =~ /^gd/i;
diff --git a/graphics/gd/files/patch-cve-2009-3546 b/graphics/gd/files/patch-cve-2009-3546
deleted file mode 100644
index f483039105b8..000000000000
--- a/graphics/gd/files/patch-cve-2009-3546
+++ /dev/null
@@ -1,15 +0,0 @@
-Adopted-From: http://svn.php.net/viewvc/php/php-src/branches/PHP_5_2/ext/gd/libgd/gd_gd.c?r1=289557&r2=289556&pathrev=289557&view=patch
-
---- gd_gd.c.orig 2006-04-05 19:52:22.000000000 +0400
-+++ gd_gd.c 2009-11-06 18:06:50.000000000 +0300
-@@ -44,6 +44,10 @@
- {
- goto fail1;
- }
-+ if (im->colorsTotal > gdMaxColors)
-+ {
-+ goto fail1;
-+ }
- }
- /* Int to accommodate truecolor single-color transparency */
- if (!gdGetInt (&im->transparent, in))
diff --git a/graphics/gd/files/patch-gd_gif_out.c b/graphics/gd/files/patch-gd_gif_out.c
deleted file mode 100644
index 95ce116472c3..000000000000
--- a/graphics/gd/files/patch-gd_gif_out.c
+++ /dev/null
@@ -1,24 +0,0 @@
---- gd_gif_out.c~ 2007-01-04 15:44:31.000000000 +0300
-+++ gd_gif_out.c 2013-06-13 17:11:11.000000000 +0400
-@@ -586,9 +586,9 @@
- int InitCodeSize;
- int i;
- GifCtx ctx;
-+ memset(&ctx, 0, sizeof(ctx));
- ctx.Interlace = GInterlace;
- ctx.in_count = 1;
-- memset(&ctx, 0, sizeof(ctx));
- ColorMapSize = 1 << BitsPerPixel;
-
- RWidth = ctx.Width = GWidth;
-@@ -735,9 +735,9 @@
- int InitCodeSize;
- int i;
- GifCtx ctx;
-+ memset(&ctx, 0, sizeof(ctx));
- ctx.Interlace = GInterlace;
- ctx.in_count = 1;
-- memset(&ctx, 0, sizeof(ctx));
- ColorMapSize = 1 << BitsPerPixel;
-
- if (LeftOfs < 0) LeftOfs = 0;
diff --git a/graphics/gd/files/patch-gd_png.c b/graphics/gd/files/patch-gd_png.c
index d0af770b29da..34b0c0a4b665 100644
--- a/graphics/gd/files/patch-gd_png.c
+++ b/graphics/gd/files/patch-gd_png.c
@@ -1,28 +1,17 @@
---- gd_png.c.orig 2007-06-14 21:51:41.000000000 +0200
-+++ gd_png.c 2010-03-28 11:23:08.000000000 +0200
-@@ -149,7 +149,7 @@
- return NULL;
- }
+--- src/gd_png.c.orig 2013-06-25 11:58:23.000000000 +0200
++++ src/gd_png.c 2013-08-01 07:08:18.000000000 +0200
+@@ -196,6 +196,14 @@
+ png_read_info (png_ptr, info_ptr); /* read all PNG info up to image data */
-- if (!png_check_sig (sig, 8)) { /* bad signature */
-+ if (png_sig_cmp (sig, 0, 8)) { /* bad signature */
- return NULL; /* bad signature */
- }
-
-@@ -193,6 +193,16 @@
- png_read_info (png_ptr, info_ptr); /* read all PNG info up to image data */
-
- png_get_IHDR (png_ptr, info_ptr, &width, &height, &bit_depth, &color_type, &interlace_type, NULL, NULL);
-+
-+ if (overflow2(sizeof (int), width))
-+ {
-+ return NULL;
-+ }
-+ if (overflow2(sizeof (int) * width, height))
-+ {
-+ return NULL;
-+ }
+ png_get_IHDR (png_ptr, info_ptr, &width, &height, &bit_depth, &color_type, &interlace_type, NULL, NULL);
++
++ if (overflow2(sizeof (int), width)) {
++ return NULL;
++ }
++ if (overflow2(sizeof (int) * width, height)) {
++ return NULL;
++ }
+
- if ((color_type == PNG_COLOR_TYPE_RGB) || (color_type == PNG_COLOR_TYPE_RGB_ALPHA)) {
- im = gdImageCreateTrueColor ((int) width, (int) height);
- } else {
+ if ((color_type == PNG_COLOR_TYPE_RGB) || (color_type == PNG_COLOR_TYPE_RGB_ALPHA)
+ || color_type == PNG_COLOR_TYPE_GRAY_ALPHA) {
+ im = gdImageCreateTrueColor ((int) width, (int) height);
diff --git a/graphics/gd/files/patch-gdtest.c b/graphics/gd/files/patch-gdtest.c
index b9514c5fa67d..e76e47ddd61a 100644
--- a/graphics/gd/files/patch-gdtest.c
+++ b/graphics/gd/files/patch-gdtest.c
@@ -1,17 +1,17 @@
---- gdtest.c.orig Sat Feb 3 02:41:00 2007
-+++ gdtest.c Sat Feb 17 14:09:35 2007
-@@ -36,6 +36,8 @@
- gdSink imgsnk;
- int foreground;
- int i;
-+ gdIOCtx *ctx;
-+
- if (argc != 2)
- {
- fprintf (stderr, "Usage: gdtest filename.png\n");
-@@ -58,6 +60,35 @@
+--- src/gdtest.c.orig 2013-06-25 11:58:23.000000000 +0200
++++ src/gdtest.c 2013-08-01 07:12:08.000000000 +0200
+@@ -35,6 +35,8 @@
+ gdSink imgsnk;
+ int foreground;
+ int i;
++ gdIOCtx *ctx;
++
+ if (argc != 2) {
+ fprintf(stderr, "Usage: gdtest filename.png\n");
+ exit (1);
+@@ -55,6 +57,35 @@
- CompareImages ("Initial Versions", ref, im);
+ CompareImages ("Initial Versions", ref, im);
+ /* */
+ /* Send to GIF File then Ptr */
@@ -43,16 +43,16 @@
+ gdImageDestroy(im2);
+ ctx->gd_free(ctx);
- /* */
- /* Send to PNG File then Ptr */
+ /* */
+ /* Send to PNG File then Ptr */
@@ -268,6 +299,10 @@
+ printf ("[Merged Image has %d colours]\n", im2->colorsTotal);
+ CompareImages ("Merged (gdtest.png, gdtest_merge.png)", im2, im3);
- printf ("[Merged Image has %d colours]\n", im2->colorsTotal);
- CompareImages ("Merged (gdtest.png, gdtest_merge.png)", im2, im3);
++ out = fopen ("test/gdtest_merge_out.png", "wb");
++ gdImagePng(im2, out);
++ fclose(out);
+
-+ out = fopen ("test/gdtest_merge_out.png", "wb");
-+ gdImagePng(im2, out);
-+ fclose(out);
+ gdImageDestroy (im2);
+ gdImageDestroy (im3);
- gdImageDestroy (im2);
- gdImageDestroy (im3);
diff --git a/graphics/gd/pkg-plist b/graphics/gd/pkg-plist
index c3303b6189cf..620c445ca1cb 100644
--- a/graphics/gd/pkg-plist
+++ b/graphics/gd/pkg-plist
@@ -13,6 +13,8 @@ bin/pngtogd2
bin/webpng
include/entities.h
include/gd.h
+include/gd_color_map.h
+include/gd_errors.h
include/gd_io.h
include/gdcache.h
include/gdfontg.h
@@ -22,8 +24,9 @@ include/gdfonts.h
include/gdfontt.h
include/gdfx.h
include/gdhelpers.h
+include/gdpp.h
lib/libgd.a
+lib/libgd.la
lib/libgd.so
-lib/libgd.so.4
-%%PORTDOCS%%%%DOCSDIR%%/index.html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
+lib/libgd.so.5
+libdata/pkgconfig/gdlib.pc