aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gdal/Makefile
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2010-08-04 23:04:36 +0800
committerosa <osa@FreeBSD.org>2010-08-04 23:04:36 +0800
commitb8521d421ec46ee92c032fa4ab089122840ce219 (patch)
tree57062ba75d0f41260f2564cdcadd1f0511b6b925 /graphics/gdal/Makefile
parenta0dabf20668de65a684f206613cf5e43d5a21212 (diff)
downloadfreebsd-ports-gnome-b8521d421ec46ee92c032fa4ab089122840ce219.tar.gz
freebsd-ports-gnome-b8521d421ec46ee92c032fa4ab089122840ce219.tar.zst
freebsd-ports-gnome-b8521d421ec46ee92c032fa4ab089122840ce219.zip
Add support for ECW and JPEG2000 formats via graphics/libecwj2.
Do not bump PORTREVISION because support of these formats are switched off by default. Submitted by: glebius (maintainer)
Diffstat (limited to 'graphics/gdal/Makefile')
-rw-r--r--graphics/gdal/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/graphics/gdal/Makefile b/graphics/gdal/Makefile
index 12a3634e1c5e..2784a1b18851 100644
--- a/graphics/gdal/Makefile
+++ b/graphics/gdal/Makefile
@@ -31,6 +31,7 @@ BUILD_DEPENDS+= ${LOCALBASE}/bin/doxygen:${PORTSDIR}/devel/doxygen
OPTIONS= CFITSIO "FITS support" off \
CURL "Curl support" off \
+ ECW "ECW & JPEG2000 support" off \
EXPAT "Expat support" off \
GEOS "GEOS support" off \
GEOTIFF "GeoTIFF support" on \
@@ -71,6 +72,13 @@ CONFIGURE_ARGS+= --with-curl=${LOCALBASE}/bin/curl-config
CONFIGURE_ARGS+= --with-curl=no
.endif
+.if defined(WITH_ECW)
+LIB_DEPENDS+= NCSEcw.0:${PORTSDIR}/graphics/libecwj2
+CONFIGURE_ARGS+= --with-ecw=${LOCALBASE}
+.else
+CONFIGURE_ARGS+= --with-ecw=no
+.endif
+
.if defined(WITH_EXPAT)
LIB_DEPENDS+= expat.6:${PORTSDIR}/textproc/expat2
CONFIGURE_ARGS+= --with-expat=${LOCALBASE} \