aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gdtclft
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2001-08-24 03:25:30 +0800
committermi <mi@FreeBSD.org>2001-08-24 03:25:30 +0800
commit74e65e452011493b6e2b81f151742bf107170d3f (patch)
tree4cd263ea03a2553cb8105cb4d54c46487b218a3d /graphics/gdtclft
parentd7aafbfa10ce06b5b54dd3d7f50d17c230fb7bdc (diff)
downloadfreebsd-ports-gnome-74e65e452011493b6e2b81f151742bf107170d3f.tar.gz
freebsd-ports-gnome-74e65e452011493b6e2b81f151742bf107170d3f.tar.zst
freebsd-ports-gnome-74e65e452011493b6e2b81f151742bf107170d3f.zip
Do not bogusly link with -lttf. gd itself links with -lfreetype only,
and we don't care ourselves.
Diffstat (limited to 'graphics/gdtclft')
-rw-r--r--graphics/gdtclft/Makefile1
-rw-r--r--graphics/gdtclft/files/Makefile.bsd2
2 files changed, 1 insertions, 2 deletions
diff --git a/graphics/gdtclft/Makefile b/graphics/gdtclft/Makefile
index e5b3f4cd9a36..83c18227dcb6 100644
--- a/graphics/gdtclft/Makefile
+++ b/graphics/gdtclft/Makefile
@@ -20,7 +20,6 @@ LIB_DEPENDS= tcl${TCL_DVER}.1:${PORTSDIR}/lang/tcl${TCL_DVER} \
TCL_VER= 8.3
TCL_DVER= ${TCL_VER:S/.//}
-USE_FREETYPE= yes
MAKEFILE= ${FILESDIR}/Makefile.bsd
MAKE_ENV= TCL_VER=${TCL_VER} MKDIR="${MKDIR}" \
INSTALL_DATA="${INSTALL_DATA}"
diff --git a/graphics/gdtclft/files/Makefile.bsd b/graphics/gdtclft/files/Makefile.bsd
index 2949a54eea69..1e6980b97f8f 100644
--- a/graphics/gdtclft/files/Makefile.bsd
+++ b/graphics/gdtclft/files/Makefile.bsd
@@ -19,7 +19,7 @@ TCL_STUB_LIB_SPEC!= . ${PREFIX}/lib/tcl${TCL_VER}/tclConfig.sh; \
TCL_STUB_LIB_SPEC= -L${PREFIX}/lib -ltclstub${TCL_VER:S/.//}
.endif
-LDADD = -L${PREFIX}/lib -lgd -lttf -lpng -lz -lm ${TCL_STUB_LIB_SPEC}
+LDADD = -L${PREFIX}/lib -lgd -lpng -lz -lm ${TCL_STUB_LIB_SPEC}
CFLAGS +=-I${PREFIX}/include/tcl${TCL_VER} -I${PREFIX}/include/gd
CFLAGS +=-DNDEBUG -Wall -I. -DUSE_TCL_STUBS -I${PREFIX}/include