aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gdtclft
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2014-05-01 01:43:50 +0800
committermi <mi@FreeBSD.org>2014-05-01 01:43:50 +0800
commita0a7c24539a1753fcf89d3daca943cf3112819b5 (patch)
tree98f9902f8ab7e67295650cc250b7b034fc1c8871 /graphics/gdtclft
parent0bacded7d613f4a64953070209b1fe79dcf97ab5 (diff)
downloadfreebsd-ports-gnome-a0a7c24539a1753fcf89d3daca943cf3112819b5.tar.gz
freebsd-ports-gnome-a0a7c24539a1753fcf89d3daca943cf3112819b5.tar.zst
freebsd-ports-gnome-a0a7c24539a1753fcf89d3daca943cf3112819b5.zip
Fix-up a bug in the new code, which prevented safe-interpreters from using even the already opened file-handles.
Bump PORTREVISION. Reviewed by: John Ellson (upstream maintainer)
Diffstat (limited to 'graphics/gdtclft')
-rw-r--r--graphics/gdtclft/Makefile2
-rw-r--r--graphics/gdtclft/files/patch-improve11
2 files changed, 7 insertions, 6 deletions
diff --git a/graphics/gdtclft/Makefile b/graphics/gdtclft/Makefile
index d967d98c17c7..765ae3019533 100644
--- a/graphics/gdtclft/Makefile
+++ b/graphics/gdtclft/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Gdtclft
PORTVERSION= 2.2.5
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= graphics tcl
MASTER_SITES=
DISTNAME= ${PORTNAME}${PORTVERSION}
diff --git a/graphics/gdtclft/files/patch-improve b/graphics/gdtclft/files/patch-improve
index 36b3bd4304b0..f2700dc59ea1 100644
--- a/graphics/gdtclft/files/patch-improve
+++ b/graphics/gdtclft/files/patch-improve
@@ -302,7 +302,7 @@ Use freely and get yourself a pademelon...
+ if (2+subcmdVec[subi].subcmds+subcmdVec[subi].ishandle > (unsigned)argc) {
Tcl_SetResult(interp, "GD handle(s) not specified", TCL_STATIC);
return TCL_ERROR;
-@@ -369,12 +392,26 @@
+@@ -369,12 +392,27 @@
subcmdVec[subi].ishandle);
argi++) {
- if (! gdHandleXlate(interp, gdData->handleTbl,
@@ -321,10 +321,11 @@ Use freely and get yourself a pademelon...
+ if (clientData != NULL && subcmdVec[subi].unsafearg != 0) {
+ const char *fname =
+ Tcl_GetString(objv[subcmdVec[subi].unsafearg]);
-+ if (!Tcl_IsChannelExisting(fname))
-+ Tcl_AppendResult(interp, "Access to ", fname,
-+ " not allowed in safe interpreter", TCL_STATIC);
-+ return TCL_ERROR;
++ if (!Tcl_IsChannelExisting(fname)) {
++ Tcl_AppendResult(interp, "Access to ", fname,
++ " not allowed in safe interpreter", TCL_STATIC);
++ return TCL_ERROR;
++ }
+ }
+
/* Call the subcommand function. */
etions'>-0/+52 * Fix build with gcc 3.4markus2004-08-212-0/+30 * - Fix build with gcc 3.4pav2004-08-212-0/+77 * - Convert to OPTIONSpav2004-08-211-9/+7 * - Convert to OPTIONSpav2004-08-211-2/+5 * - Convert to OPTIONSpav2004-08-211-5/+7 * Fix build with gcc 3.4arved2004-08-211-2/+11 * Fix build on CURRENTarved2004-08-211-0/+10 * - Update to 0.55pav2004-08-216-437/+435 * Fix dependency and unbreak.linimon2004-08-211-3/+4 * Reset bouncing maintainer address.linimon2004-08-201-1/+1 * Update to 3.0.2.nork2004-08-182-4/+4 * Add template <> to explicit specialization to fix build.arved2004-08-171-0/+20 * - Mark BROKEN for gcc 3.4pav2004-08-171-1/+7 * Correct a setgid "games" vulnerability.nectar2004-08-172-0/+16 * Chase the gstreamer shared lib bump.marcus2004-08-172-2/+2 * Fix build with gcc 3.4arved2004-08-162-0/+31 * - Update to 1.0.7pav2004-08-165-36/+6 * As previously announced, remove these broken/insecure/obsolete ports.kris2004-08-162-18/+0 * Reset maintainer:kris2004-08-161-1/+1 * BROKEN: Does not buildkris2004-08-161-0/+2 * Fix plist.krion2004-08-151-1/+1 * - Fix build with gcc 3.4 [1]bland2004-08-133-4/+22 * Update to 0.3vs2004-08-126-67/+54 * - Update to 5.7.3hq2004-08-104-1272/+29 * Update to 0.8.1.30vs2004-08-098-12/+118 * Update to 1.3.7.mezz2004-08-092-3/+3 * Fix build with gcc-3.4krion2004-08-091-6/+7 * Fix build with gcc-3.4krion2004-08-091-0/+12 * Fix build with gcc-3.4krion2004-08-093-6/+15 * Fix installkrion2004-08-092-2/+3 * Drop maintainership.krion2004-08-085-5/+5 * Add missing @dirrmkrion2004-08-081-0/+1 * Add missing glut dependency, remove BROKEN.des2004-08-083-6/+3 * Add gtklife 3.0,krion2004-08-086-0/+255 * Update to version 0.5.2krion2004-08-083-3/+7 * Fix build with gcc 3.4arved2004-08-071-0/+98 * - Update to 2.6.4 (unbreak)vs2004-08-063-8/+6 * Update to 1.4.2vs2004-08-053-10/+10 * - Fix conjuration with gcc-3.4.2pav2004-08-043-0/+50 * Bump PORTREVISION to chase the gstreamer shared lib version.marcus2004-08-032-1/+2 * Change maintainer's emailkrion2004-08-031-1/+1 * upgrade to 2.8.7ijliao2004-08-022-3/+3 * - Update to 0.0.7pav2004-08-013-4/+7 * Update to version 1.7krion2004-07-314-63/+6 * Update to version 1.6krion2004-07-312-3/+3 * - Mark IGNORE on FreeBSD 4.x - it compiles but does not runpav2004-07-311-1/+7 * . Update to 2.3.3.22, a version written this century. It could do withglewis2004-07-3111-284/+94 * Add cake 2004.07.09,krion2004-07-3011-0/+447 * - Fix fetching, unbreakpav2004-07-302-5/+4 * Remove extra directory.adamw2004-07-292-2/+0 * Move a bunch of now unique stuff out of gnomehier and intoadamw2004-07-284-2/+6 * "Wrong PKGORIGINs are often caused by a wrong order of CATEGORIES after a rep...vs2004-07-281-1/+1 * Move emulators/freesci to gamesvs2004-07-261-0/+1 * Update to 1.3.6.mezz2004-07-262-3/+3 * Update to version 0.5.1krion2004-07-266-59/+20 * Update to 1.3.5.mezz2004-07-243-5/+3 * - Add the X_WINDOW_SYSTEM={xorg,xfree86-4,xfree86-3} variable to bsd.port.mk,anholt2004-07-246-27/+14 * Change MASTER_SITES, the Wesnoth developers want people to start to usemezz2004-07-232-2/+4 * replace patch-r_part.c with the vendor-versionarved2004-07-231-16/+7 * Change maintainer's email.krion2004-07-227-7/+7 * Fix gnome-stones by removing a patch that was installing the game plug-insmarcus2004-07-216-28/+10 * Update to version 0.0.9krion2004-07-206-6/+43 * Update to version 0.0.9krion2004-07-204-23/+7 * Remove contiguous blank line.krion2004-07-201-1/+0 * Update to version 0.0.9krion2004-07-203-23/+14 * - drop maintainershipdinoex2004-07-191-1/+1 * update to xfce4-4.0.6oliver2004-07-193-3/+5 * Update to version 0.3.0krion2004-07-183-112/+174 * Add Dodging Diamond 2, an old school shoot-em up game.pav2004-07-178-0/+136 * Update to 3.0.1arved2004-07-172-4/+4 * Mark BROKEN on amd64, program crashes after a few secondsarved2004-07-171-1/+7 * - Update to 1.4.2pav2004-07-173-3/+45 * BROKEN: Unfetchablekris2004-07-151-0/+2 * Childsplay is a 'suite' of educational games for young children, like gcompris,pav2004-07-1410-0/+288 * Update to version 1.2.4krion2004-07-145-29/+15 * Update to version 0.5krion2004-07-146-115/+19 * Update to 1.3.3.mezz2004-07-134-4/+6 * - Unbreakmarkus2004-07-132-4/+2 * - Update to 1.4.1pav2004-07-122-7/+3 * - Portlintpav2004-07-121-1/+1 * Support WITHOUT_NLSkrion2004-07-112-8/+15 * Support WITHOUT_NLSkrion2004-07-112-3/+10 * Update to 1.3.2.mezz2004-07-114-15/+15 * BROKEN: Missing dependencykris2004-07-113-0/+6 * BROKEN: Size mismatchkris2004-07-111-0/+2 * Apply a big libtool patch to allow porters to use the libtool installed bymarcus2004-07-108-8/+8 * Fix wrapper-scriptvs2004-07-091-17/+2 * Use the new GConf handling policy, this will be required for GNOME 2.7/2.8 ormezz2004-07-085-280/+66 * - Unbreak pkg-message creation on read-only ports treepav2004-07-071-0/+1 * Add bygfoot, a football (a.k.a. soccer) management game. Bygfoot allows you topav2004-07-075-0/+72 * Use the new gconf schema stuff.adamw2004-07-071-2/+2 * Add bugsquish, a pointlessly cheesy game with REALLY obnoxiousadamw2004-07-065-0/+86 * - [ -d for testing directorypav2004-07-062-2/+2 * - [ -d for directoriespav2004-07-062-4/+5 * Assign maintainership to submitter of previous PRs.vs2004-07-051-1/+1 * Update to 0.8, see the changelog for full detail.mezz2004-07-056-10/+42 * Add games/wargus, a Warcraft2 Mod that allows you to play Warcraft2 withlofi2004-07-047-0/+327 * Add stratagus, a free cross-platform real-time strategy gaming enginelofi2004-07-046-0/+104 * -Update to 1.3.1.mezz2004-07-045-133/+199 * Update to 0.7.11.mezz2004-07-0410-156/+500 * Update to version 1.1.5markus2004-07-043-48/+63 * Add polypuzzle, a small polygon puzzle written in Tk.pav2004-07-036-0/+89 * - Fix MENUCOLORS-support on -CURRENTvs2004-07-022-7/+28 * Autotools cleanup. Remove autoconf257 (259), automake17 (18), andade2004-07-022-4/+4 * - Update xpenguins-daemon addon to 1.2pav2004-07-023-8/+9 * - Move intltool copying to pre-configure. This fixes build in clean environmentpav2004-07-011-1/+1 * Upgrade to 0.6.5b.tg2004-07-013-10/+28 * Add missing dependencykrion2004-07-011-2/+3 * Update to 0.6.0.adamw2004-07-013-13/+25 * Add WITH_MENUCOLORS tweak for console-version:vs2004-06-302-7/+19 * Update to 0.0.6krion2004-06-303-4/+23 * Update to 5.7.2vs2004-06-293-5/+194 * Upgrade to 0.6.5.tg2004-06-2811-230/+12 * Update to version 0.9krion2004-06-282-4/+4 * Utilize USE_GL knobkrion2004-06-281-2/+2 * Mark as BROKEN on 4.xkrion2004-06-281-1/+7 * Fix buildkrion2004-06-281-10/+13 * Update to version 0.6krion2004-06-286-66/+72 * . Fix a whitespace bogon (space -> tab).glewis2004-06-251-1/+1 * Update to 0.5.0.adamw2004-06-254-16/+23 * Update to 2.6.2bland2004-06-234-6/+6 * Unbreak on amd64 since plib is built with -fPIC.thierry2004-06-231-4/+0 * . Update checksums on the distribution files and restore a more completeglewis2004-06-222-5/+13 * . Unbreak with a MASTER_SITE that contains the distribution files with theglewis2004-06-221-14/+1 * Now builds on amd64.kris2004-06-222-4/+4 * Set an expiry date of 2004-08-20 for these BROKEN/IGNORE/FORBIDDENkris2004-06-2210-1/+21 * Add gnome-music-quiz, a small quiz game that plays songs from your Rhythmboxpav2004-06-226-0/+90 * . Fix the build for gcc 3.4:glewis2004-06-226-0/+150 * Update to 2.6.1 (unbreak).vs2004-06-212-5/+3 * Make slightly less verbose on install. Should have been committedlinimon2004-06-201-0/+2 * Switch MASTER_SITES to Gentoo's mirrors to improve reliability.thierry2004-06-201-1/+2 * BROKEN on amd64: Does not buildkris2004-06-191-0/+4 * Mark BROKEN for -STABLE. This port needs a recent C++ compiler and requirestg2004-06-181-2/+7 * Update to 0.31vs2004-06-1820-535/+142 * - Convert varargs to stdargale2004-06-184-13/+98 * Upgrade to 0.9.2 which includes several stability improvements as well asjhb2004-06-182-3/+3 * - Update to 0.4.3cpav2004-06-174-7/+28 * Update to bomberclone version 0.11.3edwin2004-06-163-4/+12 * Allow compilation with a much more beautiful card set. That,tg2004-06-152-0/+21 * Mail to maintainer is returned with:kris2004-06-152-2/+2 * Use more recent C++ compiler to fix building on 4.x.tg2004-06-151-0/+1 * BROKEN on 5.x: install failskris2004-06-151-1/+7 * BROKEN on 5.x: Does not compilekris2004-06-151-1/+7 * Fix build on -currentkris2004-06-151-1/+1 * Chase the gstreamer shared lib version, and bump PORTREVISION wheremarcus2004-06-151-1/+1 * Update to version 1.3krion2004-06-155-79/+105 * - Add missing dependencykrion2004-06-141-0/+2 * Update to 0.7.9, see the changelog for details: http://changelog.wesnoth.org/mezz2004-06-146-184/+718 * Update to 3.0.nork2004-06-133-11/+13 * Update to 1.2 release.ale2004-06-133-4/+5 * Upgrade to Alpha 6.thierry2004-06-124-34/+3 * Add netpanzer, multiplayer, fast paced, tactical, isometric tank warfare game.pav2004-06-1216-0/+926 * - Update to version 1.1krion2004-06-125-28/+4 * - Utilize EXTRACT_SUFXkrion2004-06-111-1/+1 * - Utilize USE_GLkrion2004-06-111-1/+1 * Update to version 3.2.3lofi2004-06-108-9/+29 * Fix showstopper. Bump PORTREVISION.tg2004-06-092-0/+12 * BROKEN: Build failskris2004-06-091-0/+2 * BROKEN: Unfetchablekris2004-06-091-0/+2 * Add freedokoerwin2004-06-081-0/+1 * New port freedoko. FreeDoko lets you play the card game Doppelkopf.tg2004-06-0712-0/+498 * Update description and home page.tg2004-06-071-6/+12 * Sync with new bsd.autotools.mkade2004-06-0510-0/+10 * - Update to 2004.05.22pav2004-06-054-32/+323 * Fix compilation on -STABLE, reset MAINTAINER.lofi2004-06-042-1/+12