aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gdtclft
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2001-02-08 06:45:36 +0800
committermi <mi@FreeBSD.org>2001-02-08 06:45:36 +0800
commit263c7550c3a7cd88c38171f953f206152f297849 (patch)
tree0d90cf23757b1b69ede983d89efb2cfc8f8a9de1 /graphics/gdtclft
parent13ad1c9811166d630f066bb40b8ad8ca1391c59c (diff)
downloadfreebsd-ports-gnome-263c7550c3a7cd88c38171f953f206152f297849.tar.gz
freebsd-ports-gnome-263c7550c3a7cd88c38171f953f206152f297849.tar.zst
freebsd-ports-gnome-263c7550c3a7cd88c38171f953f206152f297849.zip
This should remove the problems of using various make-targets before
installing the TCL port, which is required to install and use this one, but is not required for some of the other bsd.ports.mk targets.
Diffstat (limited to 'graphics/gdtclft')
-rw-r--r--graphics/gdtclft/files/Makefile.bsd8
1 files changed, 8 insertions, 0 deletions
diff --git a/graphics/gdtclft/files/Makefile.bsd b/graphics/gdtclft/files/Makefile.bsd
index f9a16cd9919f..da8d1a98b4e6 100644
--- a/graphics/gdtclft/files/Makefile.bsd
+++ b/graphics/gdtclft/files/Makefile.bsd
@@ -9,8 +9,16 @@ SRCS = gdhandle.c gdCmd.c
PREFIX ?=/usr/local
TCL_VER ?=8.2
+.if exists(${PREFIX}/lib/tcl${TCL_VER}/tclConfig.sh)
+# If for some reason the file does not exist -- make the best guess. In
+# reality, it will exist by the time we are actually doing the build, so
+# the quality of the guess does not matter. But we still try well. -mi
TCL_STUB_LIB_SPEC!= . ${PREFIX}/lib/tcl${TCL_VER}/tclConfig.sh; \
echo $$TCL_STUB_LIB_SPEC
+.else
+TCL_STUB_LIB_SPEC= -L${PREFIX}/lib -ltclstub${TCL_VER:S/.//}
+.endif
+
LDADD = -L${PREFIX}/lib -lgd -lttf -lpng -lz -lm ${TCL_STUB_LIB_SPEC}
CFLAGS +=-I${PREFIX}/include/tcl${TCL_VER} -I${PREFIX}/include/gd