aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/geeqie
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2010-05-22 21:07:47 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2010-05-22 21:07:47 +0800
commit0587e50f393bf3d150b564d49835c5e68f463fc7 (patch)
tree07c1b73c65edf8bb3677834fa68020728928b856 /graphics/geeqie
parent9af37506d66b24a5dd86d4fe94f29264d0b15b4c (diff)
downloadfreebsd-ports-gnome-0587e50f393bf3d150b564d49835c5e68f463fc7.tar.gz
freebsd-ports-gnome-0587e50f393bf3d150b564d49835c5e68f463fc7.tar.zst
freebsd-ports-gnome-0587e50f393bf3d150b564d49835c5e68f463fc7.zip
- Don't use unsupported find option
Reported by: Jochen Keil <jochen dot keil at gmail dot com>
Diffstat (limited to 'graphics/geeqie')
-rw-r--r--graphics/geeqie/Makefile1
-rw-r--r--graphics/geeqie/files/patch-plugins-ufraw-geeqie-ufraw35
2 files changed, 36 insertions, 0 deletions
diff --git a/graphics/geeqie/Makefile b/graphics/geeqie/Makefile
index 86b5537b8fb3..f3cf066b2c59 100644
--- a/graphics/geeqie/Makefile
+++ b/graphics/geeqie/Makefile
@@ -7,6 +7,7 @@
PORTNAME= geeqie
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
diff --git a/graphics/geeqie/files/patch-plugins-ufraw-geeqie-ufraw b/graphics/geeqie/files/patch-plugins-ufraw-geeqie-ufraw
new file mode 100644
index 000000000000..467d822c0d24
--- /dev/null
+++ b/graphics/geeqie/files/patch-plugins-ufraw-geeqie-ufraw
@@ -0,0 +1,35 @@
+--- plugins/ufraw/geeqie-ufraw.orig 2010-02-18 00:21:15.000000000 +0300
++++ plugins/ufraw/geeqie-ufraw 2010-05-22 17:06:21.000000000 +0400
+@@ -37,7 +37,7 @@
+
+ basename=${input%.*}
+ dirname=${basename%/*}
+- xmp=`find "$dirname" -maxdepth 1 -path "$basename.*" -regextype posix-egrep -iregex "$XMP_REGEX" -print | head -n 1`
++ xmp=`find -E "$dirname" -maxdepth 1 -path "$basename.*" -iregex "$XMP_REGEX" -print | head -n 1`
+ [ -f "$xmp" ] || return 1
+
+ output=`get_output_from_id "$idfile"`
+@@ -75,7 +75,7 @@
+ rawfile=$1
+ basename=${rawfile%.*}
+ dirname=${basename%/*}
+- outfiles=`find "$dirname" -maxdepth 1 -path "$basename.*" -regextype posix-egrep \( -iregex "$OUT_REGEX" -o -regex "$ID_REGEX" \) -print `
++ outfiles=`find -E "$dirname" -maxdepth 1 -path "$basename.*" \( -iregex "$OUT_REGEX" -o -regex "$ID_REGEX" \) -print `
+ [ -z "$outfiles" ] # return true if no possible output file exists
+
+ # raw+jpeg pair created by the camera is considered processed,
+@@ -136,12 +136,12 @@
+ {
+ list=`mktemp /tmp/geeqie-ufraw-list.XXXXXXXXXX` || exit 1
+
+- find "$@" -regextype posix-egrep -iregex "$RAW_REGEX" -print | while read rawfile ; do
++ find -E "$@" -iregex "$RAW_REGEX" -print | while read rawfile ; do
+ raw_file_not_processed "$rawfile" && echo "$rawfile"
+ done >>$list
+
+ #refresh output from changed id files
+- find "$@" -regextype posix-egrep -regex "$ID_REGEX" -print | while read idfile ; do
++ find -E "$@" -regex "$ID_REGEX" -print | while read idfile ; do
+ id_file_changed "$idfile" && echo "$idfile"
+ done >>$list
+