aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gegl
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2008-10-03 17:42:36 +0800
committergahr <gahr@FreeBSD.org>2008-10-03 17:42:36 +0800
commit80ab08da7a8ab305cd53a48f235b4f453070d12c (patch)
tree6758047378d0ffc1d572c3ed250ce91acc94d62e /graphics/gegl
parentdfceecd775450bc092df1541e71dd4fae6bfe24f (diff)
downloadfreebsd-ports-gnome-80ab08da7a8ab305cd53a48f235b4f453070d12c.tar.gz
freebsd-ports-gnome-80ab08da7a8ab305cd53a48f235b4f453070d12c.tar.zst
freebsd-ports-gnome-80ab08da7a8ab305cd53a48f235b4f453070d12c.zip
- New port: gegl
GEGL (Generic Graphics Library) is a graph based image processing framework. GEGL provides infrastructure to do demand based cached non destructive image editing on larger than RAM buffers. Through babl it provides support for a wide range of color models and pixel storage formats for input and output. WWW: http://gegl.org/
Diffstat (limited to 'graphics/gegl')
-rw-r--r--graphics/gegl/Makefile69
-rw-r--r--graphics/gegl/distinfo3
-rw-r--r--graphics/gegl/pkg-descr9
-rw-r--r--graphics/gegl/pkg-plist252
4 files changed, 333 insertions, 0 deletions
diff --git a/graphics/gegl/Makefile b/graphics/gegl/Makefile
new file mode 100644
index 000000000000..cf99c513678e
--- /dev/null
+++ b/graphics/gegl/Makefile
@@ -0,0 +1,69 @@
+# New ports collection Makefile for: gegl
+# Date created: 3 October 2008
+# Whom: gahr
+#
+# $FreeBSD$
+#
+
+PORTNAME= gegl
+PORTVERSION= 0.0.18
+CATEGORIES= graphics
+MASTER_SITES= ftp://ftp.gimp.org/pub/gegl/0.0/
+
+MAINTAINER= gahr@FreeBSD.org
+COMMENT= A graph based image processing framework
+
+LIB_DEPENDS= babl-0.0:${PORTSDIR}/x11/babl \
+ png.5:${PORTSDIR}/graphics/png \
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ IlmImf.6:${PORTSDIR}/graphics/OpenEXR \
+ cairo.2:${PORTSDIR}/graphics/cairo \
+ avcodec.1:${PORTSDIR}/multimedia/ffmpeg \
+ rsvg-2.2:${PORTSDIR}/graphics/librsvg2
+
+USE_GNOME= glib20 gtk20 pango pkgconfig gnomehack
+USE_SDL= sdl
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_LDCONFIG= ${PREFIX}/lib/gegl-0.0
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
+ CFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+EXAMPLES= 2geglbuffer gegl-paint geglbuffer-add-image \
+ geglbuffer-clock hello-world hello-world-video
+
+.if !defined(NOPORTDOCS)
+BUILD_DEPENDS+= a2x:${PORTSDIR}/textproc/asciidoc
+.else
+CONFIGURE_ARGS+= --disable-docs
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|-T||' ${WRKSRC}/docs/Makefile.am ${WRKSRC}/docs/Makefile.in
+
+post-build:
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC}/docs && ${GMAKE}
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}/gallery
+ (cd ${WRKSRC}/docs && \
+ ${COPYTREE_SHARE} \*.html ${DOCSDIR} && \
+ ${INSTALL_DATA} ChangeLog gegl.css gegl.devhelp devhelp.css ${DOCSDIR} && \
+ ${INSTALL_DATA} gallery/OpenRaster* ${DOCSDIR}/gallery && \
+ ${INSTALL_DATA} gallery/clones* ${DOCSDIR}/gallery && \
+ ${INSTALL_DATA} gallery/index.html ${DOCSDIR}/gallery )
+.endif
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}/data
+ ${INSTALL_DATA} ${WRKSRC}/examples/data/surfer.png ${EXAMPLESDIR}/data
+.for ex in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/examples/${ex}.c ${EXAMPLESDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/gegl/distinfo b/graphics/gegl/distinfo
new file mode 100644
index 000000000000..5da41802dafd
--- /dev/null
+++ b/graphics/gegl/distinfo
@@ -0,0 +1,3 @@
+MD5 (gegl-0.0.18.tar.bz2) = e458409440a7b51f446df321c3657e4d
+SHA256 (gegl-0.0.18.tar.bz2) = 58d5c2c415684f5744dd8dec80a1c230fc4b02ecea6c9edf3b5ef3ed4046ef93
+SIZE (gegl-0.0.18.tar.bz2) = 1204867
diff --git a/graphics/gegl/pkg-descr b/graphics/gegl/pkg-descr
new file mode 100644
index 000000000000..2298a1a0e8a1
--- /dev/null
+++ b/graphics/gegl/pkg-descr
@@ -0,0 +1,9 @@
+GEGL (Generic Graphics Library) is a graph based image
+processing framework.
+
+GEGL provides infrastructure to do demand based cached
+non destructive image editing on larger than RAM buffers.
+Through babl it provides support for a wide range of color
+models and pixel storage formats for input and output.
+
+WWW: http://gegl.org/
diff --git a/graphics/gegl/pkg-plist b/graphics/gegl/pkg-plist
new file mode 100644
index 000000000000..304cdafa25f6
--- /dev/null
+++ b/graphics/gegl/pkg-plist
@@ -0,0 +1,252 @@
+bin/gegl
+include/gegl-0.0/gegl-buffer.h
+include/gegl-0.0/gegl-chant.h
+include/gegl-0.0/gegl-color.h
+include/gegl-0.0/gegl-config.c
+include/gegl-0.0/gegl-curve.h
+include/gegl-0.0/gegl-paramspecs.h
+include/gegl-0.0/gegl-plugin.h
+include/gegl-0.0/gegl-utils.h
+include/gegl-0.0/gegl.h
+include/gegl-0.0/operation/gegl-operation-area-filter.h
+include/gegl-0.0/operation/gegl-operation-composer.h
+include/gegl-0.0/operation/gegl-operation-filter.h
+include/gegl-0.0/operation/gegl-operation-meta.h
+include/gegl-0.0/operation/gegl-operation-point-composer.h
+include/gegl-0.0/operation/gegl-operation-point-filter.h
+include/gegl-0.0/operation/gegl-operation-point-render.h
+include/gegl-0.0/operation/gegl-operation-sink.h
+include/gegl-0.0/operation/gegl-operation-source.h
+include/gegl-0.0/operation/gegl-operation-temporal.h
+include/gegl-0.0/operation/gegl-operation.h
+lib/libgegl-0.0.la
+lib/libgegl-0.0.so.18
+lib/libgegl-0.0.so
+lib/gegl-0.0/add.la
+lib/gegl-0.0/add.so
+lib/gegl-0.0/affine.la
+lib/gegl-0.0/affine.so
+lib/gegl-0.0/bilateral-filter.la
+lib/gegl-0.0/bilateral-filter.so
+lib/gegl-0.0/box-blur.la
+lib/gegl-0.0/box-blur.so
+lib/gegl-0.0/brightness-contrast.la
+lib/gegl-0.0/brightness-contrast.so
+lib/gegl-0.0/c2g.la
+lib/gegl-0.0/c2g.so
+lib/gegl-0.0/checkerboard.la
+lib/gegl-0.0/checkerboard.so
+lib/gegl-0.0/clear.la
+lib/gegl-0.0/clear.so
+lib/gegl-0.0/clone.la
+lib/gegl-0.0/clone.so
+lib/gegl-0.0/color-burn.la
+lib/gegl-0.0/color-burn.so
+lib/gegl-0.0/color-dodge.la
+lib/gegl-0.0/color-dodge.so
+lib/gegl-0.0/color-temperature.la
+lib/gegl-0.0/color-temperature.so
+lib/gegl-0.0/color.la
+lib/gegl-0.0/color.so
+lib/gegl-0.0/contrast-curve.la
+lib/gegl-0.0/contrast-curve.so
+lib/gegl-0.0/convert-format.la
+lib/gegl-0.0/convert-format.so
+lib/gegl-0.0/crop.la
+lib/gegl-0.0/crop.so
+lib/gegl-0.0/darken.la
+lib/gegl-0.0/darken.so
+lib/gegl-0.0/difference-of-gaussians.la
+lib/gegl-0.0/difference-of-gaussians.so
+lib/gegl-0.0/difference.la
+lib/gegl-0.0/difference.so
+lib/gegl-0.0/display.la
+lib/gegl-0.0/display.so
+lib/gegl-0.0/divide.la
+lib/gegl-0.0/divide.so
+lib/gegl-0.0/dropshadow.la
+lib/gegl-0.0/dropshadow.so
+lib/gegl-0.0/dst-atop.la
+lib/gegl-0.0/dst-atop.so
+lib/gegl-0.0/dst-in.la
+lib/gegl-0.0/dst-in.so
+lib/gegl-0.0/dst-out.la
+lib/gegl-0.0/dst-out.so
+lib/gegl-0.0/dst-over.la
+lib/gegl-0.0/dst-over.so
+lib/gegl-0.0/dst.la
+lib/gegl-0.0/dst.so
+lib/gegl-0.0/exclusion.la
+lib/gegl-0.0/exclusion.so
+lib/gegl-0.0/exr-load.la
+lib/gegl-0.0/exr-load.so
+lib/gegl-0.0/ff-load.la
+lib/gegl-0.0/ff-load.so
+lib/gegl-0.0/fractal-explorer.la
+lib/gegl-0.0/fractal-explorer.so
+lib/gegl-0.0/gamma.la
+lib/gegl-0.0/gamma.so
+lib/gegl-0.0/gaussian-blur.la
+lib/gegl-0.0/gaussian-blur.so
+lib/gegl-0.0/grey.la
+lib/gegl-0.0/grey.so
+lib/gegl-0.0/hard-light.la
+lib/gegl-0.0/hard-light.so
+lib/gegl-0.0/introspect.la
+lib/gegl-0.0/introspect.so
+lib/gegl-0.0/invert.la
+lib/gegl-0.0/invert.so
+lib/gegl-0.0/jpg-load.la
+lib/gegl-0.0/jpg-load.so
+lib/gegl-0.0/layer.la
+lib/gegl-0.0/layer.so
+lib/gegl-0.0/levels.la
+lib/gegl-0.0/levels.so
+lib/gegl-0.0/lighten.la
+lib/gegl-0.0/lighten.so
+lib/gegl-0.0/load-buffer.la
+lib/gegl-0.0/load-buffer.so
+lib/gegl-0.0/load.la
+lib/gegl-0.0/load.so
+lib/gegl-0.0/magick-load.la
+lib/gegl-0.0/magick-load.so
+lib/gegl-0.0/mblur.la
+lib/gegl-0.0/mblur.so
+lib/gegl-0.0/mono-mixer.la
+lib/gegl-0.0/mono-mixer.so
+lib/gegl-0.0/multiply.la
+lib/gegl-0.0/multiply.so
+lib/gegl-0.0/noise.la
+lib/gegl-0.0/noise.so
+lib/gegl-0.0/nop.la
+lib/gegl-0.0/nop.so
+lib/gegl-0.0/normal.la
+lib/gegl-0.0/normal.so
+lib/gegl-0.0/opacity.la
+lib/gegl-0.0/opacity.so
+lib/gegl-0.0/open-buffer.la
+lib/gegl-0.0/open-buffer.so
+lib/gegl-0.0/over.la
+lib/gegl-0.0/over.so
+lib/gegl-0.0/overlay.la
+lib/gegl-0.0/overlay.so
+lib/gegl-0.0/pixbuf.la
+lib/gegl-0.0/pixbuf.so
+lib/gegl-0.0/plus.la
+lib/gegl-0.0/plus.so
+lib/gegl-0.0/png-load.la
+lib/gegl-0.0/png-load.so
+lib/gegl-0.0/png-save.la
+lib/gegl-0.0/png-save.so
+lib/gegl-0.0/raw-load.la
+lib/gegl-0.0/raw-load.so
+lib/gegl-0.0/rectangle.la
+lib/gegl-0.0/rectangle.so
+lib/gegl-0.0/remap.la
+lib/gegl-0.0/remap.so
+lib/gegl-0.0/save-buffer.la
+lib/gegl-0.0/save-buffer.so
+lib/gegl-0.0/save-pixbuf.la
+lib/gegl-0.0/save-pixbuf.so
+lib/gegl-0.0/screen.la
+lib/gegl-0.0/screen.so
+lib/gegl-0.0/shift.la
+lib/gegl-0.0/shift.so
+lib/gegl-0.0/snn-mean.la
+lib/gegl-0.0/snn-mean.so
+lib/gegl-0.0/soft-light.la
+lib/gegl-0.0/soft-light.so
+lib/gegl-0.0/src-atop.la
+lib/gegl-0.0/src-atop.so
+lib/gegl-0.0/src-in.la
+lib/gegl-0.0/src-in.so
+lib/gegl-0.0/src-out.la
+lib/gegl-0.0/src-out.so
+lib/gegl-0.0/src-over.la
+lib/gegl-0.0/src-over.so
+lib/gegl-0.0/src.la
+lib/gegl-0.0/src.so
+lib/gegl-0.0/stress.la
+lib/gegl-0.0/stress.so
+lib/gegl-0.0/stretch-contrast.la
+lib/gegl-0.0/stretch-contrast.so
+lib/gegl-0.0/subtract.la
+lib/gegl-0.0/subtract.so
+lib/gegl-0.0/svg-huerotate.la
+lib/gegl-0.0/svg-huerotate.so
+lib/gegl-0.0/svg-load.la
+lib/gegl-0.0/svg-load.so
+lib/gegl-0.0/svg-luminancetoalpha.la
+lib/gegl-0.0/svg-luminancetoalpha.so
+lib/gegl-0.0/svg-matrix.la
+lib/gegl-0.0/svg-matrix.so
+lib/gegl-0.0/svg-multiply.la
+lib/gegl-0.0/svg-multiply.so
+lib/gegl-0.0/svg-saturate.la
+lib/gegl-0.0/svg-saturate.so
+lib/gegl-0.0/text.la
+lib/gegl-0.0/text.so
+lib/gegl-0.0/threshold.la
+lib/gegl-0.0/threshold.so
+lib/gegl-0.0/tonemap.la
+lib/gegl-0.0/tonemap.so
+lib/gegl-0.0/unsharp-mask.la
+lib/gegl-0.0/unsharp-mask.so
+lib/gegl-0.0/value-invert.la
+lib/gegl-0.0/value-invert.so
+lib/gegl-0.0/whitebalance.la
+lib/gegl-0.0/whitebalance.so
+lib/gegl-0.0/write-buffer.la
+lib/gegl-0.0/write-buffer.so
+lib/gegl-0.0/xor.la
+lib/gegl-0.0/xor.so
+libdata/pkgconfig/gegl.pc
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/api.html
+%%PORTDOCS%%%%DOCSDIR%%/brightness-contrast.c.html
+%%PORTDOCS%%%%DOCSDIR%%/class-hierarchy.html
+%%PORTDOCS%%%%DOCSDIR%%/devhelp.css
+%%PORTDOCS%%%%DOCSDIR%%/gallery/OpenRaster-00.png
+%%PORTDOCS%%%%DOCSDIR%%/gallery/OpenRaster-00.txt
+%%PORTDOCS%%%%DOCSDIR%%/gallery/OpenRaster-00.xml
+%%PORTDOCS%%%%DOCSDIR%%/gallery/OpenRaster-01.png
+%%PORTDOCS%%%%DOCSDIR%%/gallery/OpenRaster-01.txt
+%%PORTDOCS%%%%DOCSDIR%%/gallery/OpenRaster-01.xml
+%%PORTDOCS%%%%DOCSDIR%%/gallery/OpenRaster-04.png
+%%PORTDOCS%%%%DOCSDIR%%/gallery/OpenRaster-04.txt
+%%PORTDOCS%%%%DOCSDIR%%/gallery/OpenRaster-04.xml
+%%PORTDOCS%%%%DOCSDIR%%/gallery/clones.png
+%%PORTDOCS%%%%DOCSDIR%%/gallery/clones.txt
+%%PORTDOCS%%%%DOCSDIR%%/gallery/clones.xml
+%%PORTDOCS%%%%DOCSDIR%%/gallery/index.html
+%%PORTDOCS%%%%DOCSDIR%%/gegl-operation-area-filter.h.html
+%%PORTDOCS%%%%DOCSDIR%%/gegl-operation-composer.h.html
+%%PORTDOCS%%%%DOCSDIR%%/gegl-operation-filter.h.html
+%%PORTDOCS%%%%DOCSDIR%%/gegl-operation-meta.h.html
+%%PORTDOCS%%%%DOCSDIR%%/gegl-operation-point-composer.h.html
+%%PORTDOCS%%%%DOCSDIR%%/gegl-operation-point-filter.h.html
+%%PORTDOCS%%%%DOCSDIR%%/gegl-operation-point-render.h.html
+%%PORTDOCS%%%%DOCSDIR%%/gegl-operation-sink.h.html
+%%PORTDOCS%%%%DOCSDIR%%/gegl-operation-source.h.html
+%%PORTDOCS%%%%DOCSDIR%%/gegl-operation-temporal.h.html
+%%PORTDOCS%%%%DOCSDIR%%/gegl-operation.h.html
+%%PORTDOCS%%%%DOCSDIR%%/gegl-plugin.h.html
+%%PORTDOCS%%%%DOCSDIR%%/gegl.css
+%%PORTDOCS%%%%DOCSDIR%%/gegl.devhelp
+%%PORTDOCS%%%%DOCSDIR%%/gegl.h.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/operations.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/2geglbuffer.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/data/surfer.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gegl-paint.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/geglbuffer-add-image.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/geglbuffer-clock.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hello-world-video.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hello-world.c
+@dirrm include/gegl-0.0/operation
+@dirrm include/gegl-0.0
+@dirrm lib/gegl-0.0
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/gallery
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/data
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%