aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/geos35
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-02-07 21:13:39 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2017-02-07 21:13:39 +0800
commit1abd7edc0cd7e79ee7543a1f6d8ea7593006bced (patch)
treebbbf75c5e58aaf8303a7970f06028d4ca2258f2e /graphics/geos35
parent79d49c3efd1ab0cad4511e25053ba360d411212e (diff)
downloadfreebsd-ports-gnome-1abd7edc0cd7e79ee7543a1f6d8ea7593006bced.tar.gz
freebsd-ports-gnome-1abd7edc0cd7e79ee7543a1f6d8ea7593006bced.tar.zst
freebsd-ports-gnome-1abd7edc0cd7e79ee7543a1f6d8ea7593006bced.zip
- Copy graphics/geos at version 3.5 to graphics/geos35
This is needed to fix osm2pgsql which is not compatible with geos 3.6. For this purpose, the port was simplified (unneeded options and files removed) and conflicts with graphics/geos were resolved (includes placed under include/geos35, libraries renamed to libgeos35.{a,so}, geos-config renamed to geos-config35). The library behaves correct wrt SONAME, as it points to libgeos-${PORTVERSION}.so
Diffstat (limited to 'graphics/geos35')
-rw-r--r--graphics/geos35/Makefile44
-rw-r--r--graphics/geos35/distinfo3
-rw-r--r--graphics/geos35/pkg-descr7
-rw-r--r--graphics/geos35/pkg-plist381
4 files changed, 435 insertions, 0 deletions
diff --git a/graphics/geos35/Makefile b/graphics/geos35/Makefile
new file mode 100644
index 000000000000..93fbef5b324a
--- /dev/null
+++ b/graphics/geos35/Makefile
@@ -0,0 +1,44 @@
+# Created by: Leonardo Martins <lmartins@nepe.eee.ufg.br>
+# $FreeBSD$
+
+PORTNAME= geos
+PORTVERSION= 3.5.0
+PORTREVISION= 3
+CATEGORIES= graphics geography
+MASTER_SITES= http://download.osgeo.org/geos/ \
+ LOCAL/sunpoet
+PKGNAMESUFFIX= 35
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= GEOS implements all the OpenGIS "Simple Features for SQL"
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+CONFIGURE_ARGS= --program-suffix=35 \
+ ac_cv_path_SWIG=${LOCALBASE}/bin/swig3.0
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+TEST_TARGET= check
+USE_LDCONFIG= yes
+USES= gmake libtool tar:bzip2
+
+PLIST_SUB= PORTVERSION=${PORTVERSION}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lstdc++||' ${WRKSRC}/tests/geostest/Makefile.in ${WRKSRC}/tests/thread/Makefile.in
+
+post-configure:
+ @${FIND} ${WRKSRC} -name Makefile -exec ${REINPLACE_CMD} -e '/CXXFLAGS = / s| -O2||' '{}' \;
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/include/geos35
+ @${MV} ${STAGEDIR}${PREFIX}/include/geos ${STAGEDIR}${PREFIX}/include/geos35
+ @${MV} ${STAGEDIR}${PREFIX}/include/*.h ${STAGEDIR}${PREFIX}/include/geos35
+ @${RM} ${STAGEDIR}${PREFIX}/lib/libgeos_c*
+ @${MV} ${STAGEDIR}${PREFIX}/lib/libgeos.a ${STAGEDIR}${PREFIX}/lib/libgeos35.a
+ @${MV} ${STAGEDIR}${PREFIX}/lib/libgeos.so ${STAGEDIR}${PREFIX}/lib/libgeos35.so
+ @${FIND} ${STAGEDIR}${PREFIX}/include -type f -exec ${REINPLACE_CMD} -i '' \
+ -e 's|include <geos|&35/geos|' {} \;
+
+.include <bsd.port.mk>
diff --git a/graphics/geos35/distinfo b/graphics/geos35/distinfo
new file mode 100644
index 000000000000..37cf247bfe95
--- /dev/null
+++ b/graphics/geos35/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1479915831
+SHA256 (geos-3.5.0.tar.bz2) = 49982b23bcfa64a53333dab136b82e25354edeb806e5a2e2f5b8aa98b1d0ae02
+SIZE (geos-3.5.0.tar.bz2) = 1949397
diff --git a/graphics/geos35/pkg-descr b/graphics/geos35/pkg-descr
new file mode 100644
index 000000000000..91b59fd37449
--- /dev/null
+++ b/graphics/geos35/pkg-descr
@@ -0,0 +1,7 @@
+GEOS (Geometry Engine - Open Source) is a C++ port of the
+Java Topology Suite (JTS). As such, it aims to contain the complete
+functionality of JTS in C++. This includes all the OpenGIS "Simple
+Features for SQL" spatial predicate functions and spatial operators,
+as well as specific JTS topology functions such as IsValid().
+
+WWW: http://trac.osgeo.org/geos/
diff --git a/graphics/geos35/pkg-plist b/graphics/geos35/pkg-plist
new file mode 100644
index 000000000000..ca5f73eda6bd
--- /dev/null
+++ b/graphics/geos35/pkg-plist
@@ -0,0 +1,381 @@
+bin/geos-config35
+include/geos35/geos.h
+include/geos35/geos/algorithm/Angle.h
+include/geos35/geos/algorithm/BoundaryNodeRule.h
+include/geos35/geos/algorithm/CGAlgorithms.h
+include/geos35/geos/algorithm/CentralEndpointIntersector.h
+include/geos35/geos/algorithm/Centroid.h
+include/geos35/geos/algorithm/CentroidArea.h
+include/geos35/geos/algorithm/CentroidLine.h
+include/geos35/geos/algorithm/CentroidPoint.h
+include/geos35/geos/algorithm/ConvexHull.h
+include/geos35/geos/algorithm/ConvexHull.inl
+include/geos35/geos/algorithm/HCoordinate.h
+include/geos35/geos/algorithm/InteriorPointArea.h
+include/geos35/geos/algorithm/InteriorPointLine.h
+include/geos35/geos/algorithm/InteriorPointPoint.h
+include/geos35/geos/algorithm/LineIntersector.h
+include/geos35/geos/algorithm/MCPointInRing.h
+include/geos35/geos/algorithm/MinimumDiameter.h
+include/geos35/geos/algorithm/NotRepresentableException.h
+include/geos35/geos/algorithm/PointInRing.h
+include/geos35/geos/algorithm/PointLocator.h
+include/geos35/geos/algorithm/RayCrossingCounter.h
+include/geos35/geos/algorithm/RobustDeterminant.h
+include/geos35/geos/algorithm/SIRtreePointInRing.h
+include/geos35/geos/algorithm/SimplePointInRing.h
+include/geos35/geos/algorithm/distance/DiscreteHausdorffDistance.h
+include/geos35/geos/algorithm/distance/DistanceToPoint.h
+include/geos35/geos/algorithm/distance/PointPairDistance.h
+include/geos35/geos/algorithm/locate/IndexedPointInAreaLocator.h
+include/geos35/geos/algorithm/locate/PointOnGeometryLocator.h
+include/geos35/geos/algorithm/locate/SimplePointInAreaLocator.h
+include/geos35/geos/export.h
+include/geos35/geos/geom.h
+include/geos35/geos/geom/BinaryOp.h
+include/geos35/geos/geom/Coordinate.h
+include/geos35/geos/geom/Coordinate.inl
+include/geos35/geos/geom/CoordinateArraySequence.h
+include/geos35/geos/geom/CoordinateArraySequenceFactory.h
+include/geos35/geos/geom/CoordinateArraySequenceFactory.inl
+include/geos35/geos/geom/CoordinateFilter.h
+include/geos35/geos/geom/CoordinateList.h
+include/geos35/geos/geom/CoordinateSequence.h
+include/geos35/geos/geom/CoordinateSequenceFactory.h
+include/geos35/geos/geom/CoordinateSequenceFilter.h
+include/geos35/geos/geom/Dimension.h
+include/geos35/geos/geom/Envelope.h
+include/geos35/geos/geom/Envelope.inl
+include/geos35/geos/geom/Geometry.h
+include/geos35/geos/geom/GeometryCollection.h
+include/geos35/geos/geom/GeometryCollection.inl
+include/geos35/geos/geom/GeometryComponentFilter.h
+include/geos35/geos/geom/GeometryFactory.h
+include/geos35/geos/geom/GeometryFactory.inl
+include/geos35/geos/geom/GeometryFilter.h
+include/geos35/geos/geom/GeometryList.h
+include/geos35/geos/geom/IntersectionMatrix.h
+include/geos35/geos/geom/LineSegment.h
+include/geos35/geos/geom/LineSegment.inl
+include/geos35/geos/geom/LineString.h
+include/geos35/geos/geom/Lineal.h
+include/geos35/geos/geom/LinearRing.h
+include/geos35/geos/geom/Location.h
+include/geos35/geos/geom/MultiLineString.h
+include/geos35/geos/geom/MultiLineString.inl
+include/geos35/geos/geom/MultiPoint.h
+include/geos35/geos/geom/MultiPolygon.h
+include/geos35/geos/geom/MultiPolygon.inl
+include/geos35/geos/geom/Point.h
+include/geos35/geos/geom/Polygon.h
+include/geos35/geos/geom/Polygonal.h
+include/geos35/geos/geom/PrecisionModel.h
+include/geos35/geos/geom/PrecisionModel.inl
+include/geos35/geos/geom/Puntal.h
+include/geos35/geos/geom/Triangle.h
+include/geos35/geos/geom/prep/AbstractPreparedPolygonContains.h
+include/geos35/geos/geom/prep/BasicPreparedGeometry.h
+include/geos35/geos/geom/prep/PreparedGeometry.h
+include/geos35/geos/geom/prep/PreparedGeometryFactory.h
+include/geos35/geos/geom/prep/PreparedLineString.h
+include/geos35/geos/geom/prep/PreparedLineStringIntersects.h
+include/geos35/geos/geom/prep/PreparedPoint.h
+include/geos35/geos/geom/prep/PreparedPolygon.h
+include/geos35/geos/geom/prep/PreparedPolygonContains.h
+include/geos35/geos/geom/prep/PreparedPolygonContainsProperly.h
+include/geos35/geos/geom/prep/PreparedPolygonCovers.h
+include/geos35/geos/geom/prep/PreparedPolygonIntersects.h
+include/geos35/geos/geom/prep/PreparedPolygonPredicate.h
+include/geos35/geos/geom/util/ComponentCoordinateExtracter.h
+include/geos35/geos/geom/util/CoordinateOperation.h
+include/geos35/geos/geom/util/GeometryCombiner.h
+include/geos35/geos/geom/util/GeometryEditor.h
+include/geos35/geos/geom/util/GeometryEditorOperation.h
+include/geos35/geos/geom/util/GeometryExtracter.h
+include/geos35/geos/geom/util/GeometryTransformer.h
+include/geos35/geos/geom/util/LinearComponentExtracter.h
+include/geos35/geos/geom/util/PointExtracter.h
+include/geos35/geos/geom/util/PolygonExtracter.h
+include/geos35/geos/geom/util/ShortCircuitedGeometryVisitor.h
+include/geos35/geos/geom/util/SineStarFactory.h
+include/geos35/geos/geomUtil.h
+include/geos35/geos/geomgraph.h
+include/geos35/geos/geomgraph/Depth.h
+include/geos35/geos/geomgraph/DirectedEdge.h
+include/geos35/geos/geomgraph/DirectedEdge.inl
+include/geos35/geos/geomgraph/DirectedEdgeStar.h
+include/geos35/geos/geomgraph/Edge.h
+include/geos35/geos/geomgraph/EdgeEnd.h
+include/geos35/geos/geomgraph/EdgeEndStar.h
+include/geos35/geos/geomgraph/EdgeIntersection.h
+include/geos35/geos/geomgraph/EdgeIntersectionList.h
+include/geos35/geos/geomgraph/EdgeList.h
+include/geos35/geos/geomgraph/EdgeNodingValidator.h
+include/geos35/geos/geomgraph/EdgeRing.h
+include/geos35/geos/geomgraph/GeometryGraph.h
+include/geos35/geos/geomgraph/GeometryGraph.inl
+include/geos35/geos/geomgraph/GraphComponent.h
+include/geos35/geos/geomgraph/Label.h
+include/geos35/geos/geomgraph/Node.h
+include/geos35/geos/geomgraph/NodeFactory.h
+include/geos35/geos/geomgraph/NodeMap.h
+include/geos35/geos/geomgraph/PlanarGraph.h
+include/geos35/geos/geomgraph/Position.h
+include/geos35/geos/geomgraph/Quadrant.h
+include/geos35/geos/geomgraph/TopologyLocation.h
+include/geos35/geos/geomgraph/index/EdgeSetIntersector.h
+include/geos35/geos/geomgraph/index/MonotoneChain.h
+include/geos35/geos/geomgraph/index/MonotoneChainEdge.h
+include/geos35/geos/geomgraph/index/MonotoneChainIndexer.h
+include/geos35/geos/geomgraph/index/SegmentIntersector.h
+include/geos35/geos/geomgraph/index/SimpleEdgeSetIntersector.h
+include/geos35/geos/geomgraph/index/SimpleMCSweepLineIntersector.h
+include/geos35/geos/geomgraph/index/SimpleSweepLineIntersector.h
+include/geos35/geos/geomgraph/index/SweepLineEvent.h
+include/geos35/geos/geomgraph/index/SweepLineEventObj.h
+include/geos35/geos/geomgraph/index/SweepLineSegment.h
+include/geos35/geos/geomgraphindex.h
+include/geos35/geos/geosAlgorithm.h
+include/geos35/geos/index/ItemVisitor.h
+include/geos35/geos/index/SpatialIndex.h
+include/geos35/geos/index/bintree/Bintree.h
+include/geos35/geos/index/bintree/Interval.h
+include/geos35/geos/index/bintree/Key.h
+include/geos35/geos/index/bintree/Node.h
+include/geos35/geos/index/bintree/NodeBase.h
+include/geos35/geos/index/bintree/Root.h
+include/geos35/geos/index/chain/MonotoneChain.h
+include/geos35/geos/index/chain/MonotoneChainBuilder.h
+include/geos35/geos/index/chain/MonotoneChainOverlapAction.h
+include/geos35/geos/index/chain/MonotoneChainSelectAction.h
+include/geos35/geos/index/intervalrtree/IntervalRTreeBranchNode.h
+include/geos35/geos/index/intervalrtree/IntervalRTreeLeafNode.h
+include/geos35/geos/index/intervalrtree/IntervalRTreeNode.h
+include/geos35/geos/index/intervalrtree/SortedPackedIntervalRTree.h
+include/geos35/geos/index/quadtree/DoubleBits.h
+include/geos35/geos/index/quadtree/IntervalSize.h
+include/geos35/geos/index/quadtree/Key.h
+include/geos35/geos/index/quadtree/Node.h
+include/geos35/geos/index/quadtree/NodeBase.h
+include/geos35/geos/index/quadtree/Quadtree.h
+include/geos35/geos/index/quadtree/Root.h
+include/geos35/geos/index/strtree/AbstractNode.h
+include/geos35/geos/index/strtree/AbstractSTRtree.h
+include/geos35/geos/index/strtree/Boundable.h
+include/geos35/geos/index/strtree/Interval.h
+include/geos35/geos/index/strtree/ItemBoundable.h
+include/geos35/geos/index/strtree/SIRtree.h
+include/geos35/geos/index/strtree/STRtree.h
+include/geos35/geos/index/sweepline/SweepLineEvent.h
+include/geos35/geos/index/sweepline/SweepLineIndex.h
+include/geos35/geos/index/sweepline/SweepLineInterval.h
+include/geos35/geos/index/sweepline/SweepLineOverlapAction.h
+include/geos35/geos/indexBintree.h
+include/geos35/geos/indexChain.h
+include/geos35/geos/indexQuadtree.h
+include/geos35/geos/indexStrtree.h
+include/geos35/geos/indexSweepline.h
+include/geos35/geos/inline.h
+include/geos35/geos/io.h
+include/geos35/geos/io/ByteOrderDataInStream.h
+include/geos35/geos/io/ByteOrderDataInStream.inl
+include/geos35/geos/io/ByteOrderValues.h
+include/geos35/geos/io/CLocalizer.h
+include/geos35/geos/io/ParseException.h
+include/geos35/geos/io/StringTokenizer.h
+include/geos35/geos/io/WKBConstants.h
+include/geos35/geos/io/WKBReader.h
+include/geos35/geos/io/WKBWriter.h
+include/geos35/geos/io/WKTReader.h
+include/geos35/geos/io/WKTReader.inl
+include/geos35/geos/io/WKTWriter.h
+include/geos35/geos/io/Writer.h
+include/geos35/geos/linearref/ExtractLineByLocation.h
+include/geos35/geos/linearref/LengthIndexOfPoint.h
+include/geos35/geos/linearref/LengthIndexedLine.h
+include/geos35/geos/linearref/LengthLocationMap.h
+include/geos35/geos/linearref/LinearGeometryBuilder.h
+include/geos35/geos/linearref/LinearIterator.h
+include/geos35/geos/linearref/LinearLocation.h
+include/geos35/geos/linearref/LocationIndexOfLine.h
+include/geos35/geos/linearref/LocationIndexOfPoint.h
+include/geos35/geos/linearref/LocationIndexedLine.h
+include/geos35/geos/noding.h
+include/geos35/geos/noding/BasicSegmentString.h
+include/geos35/geos/noding/FastNodingValidator.h
+include/geos35/geos/noding/FastSegmentSetIntersectionFinder.h
+include/geos35/geos/noding/GeometryNoder.h
+include/geos35/geos/noding/IntersectionAdder.h
+include/geos35/geos/noding/IntersectionFinderAdder.h
+include/geos35/geos/noding/IteratedNoder.h
+include/geos35/geos/noding/MCIndexNoder.h
+include/geos35/geos/noding/MCIndexNoder.inl
+include/geos35/geos/noding/MCIndexSegmentSetMutualIntersector.h
+include/geos35/geos/noding/NodableSegmentString.h
+include/geos35/geos/noding/NodedSegmentString.h
+include/geos35/geos/noding/Noder.h
+include/geos35/geos/noding/NodingValidator.h
+include/geos35/geos/noding/Octant.h
+include/geos35/geos/noding/OrientedCoordinateArray.h
+include/geos35/geos/noding/ScaledNoder.h
+include/geos35/geos/noding/SegmentIntersectionDetector.h
+include/geos35/geos/noding/SegmentIntersector.h
+include/geos35/geos/noding/SegmentNode.h
+include/geos35/geos/noding/SegmentNodeList.h
+include/geos35/geos/noding/SegmentPointComparator.h
+include/geos35/geos/noding/SegmentSetMutualIntersector.h
+include/geos35/geos/noding/SegmentString.h
+include/geos35/geos/noding/SegmentStringUtil.h
+include/geos35/geos/noding/SimpleNoder.h
+include/geos35/geos/noding/SingleInteriorIntersectionFinder.h
+include/geos35/geos/noding/SinglePassNoder.h
+include/geos35/geos/noding/snapround/HotPixel.h
+include/geos35/geos/noding/snapround/HotPixel.inl
+include/geos35/geos/noding/snapround/MCIndexPointSnapper.h
+include/geos35/geos/noding/snapround/MCIndexSnapRounder.h
+include/geos35/geos/noding/snapround/SimpleSnapRounder.h
+include/geos35/geos/nodingSnapround.h
+include/geos35/geos/opBuffer.h
+include/geos35/geos/opDistance.h
+include/geos35/geos/opLinemerge.h
+include/geos35/geos/opOverlay.h
+include/geos35/geos/opPolygonize.h
+include/geos35/geos/opPredicate.h
+include/geos35/geos/opRelate.h
+include/geos35/geos/opValid.h
+include/geos35/geos/operation.h
+include/geos35/geos/operation/GeometryGraphOperation.h
+include/geos35/geos/operation/IsSimpleOp.h
+include/geos35/geos/operation/buffer/BufferBuilder.h
+include/geos35/geos/operation/buffer/BufferInputLineSimplifier.h
+include/geos35/geos/operation/buffer/BufferOp.h
+include/geos35/geos/operation/buffer/BufferParameters.h
+include/geos35/geos/operation/buffer/BufferSubgraph.h
+include/geos35/geos/operation/buffer/OffsetCurveBuilder.h
+include/geos35/geos/operation/buffer/OffsetCurveSetBuilder.h
+include/geos35/geos/operation/buffer/OffsetSegmentGenerator.h
+include/geos35/geos/operation/buffer/OffsetSegmentString.h
+include/geos35/geos/operation/buffer/RightmostEdgeFinder.h
+include/geos35/geos/operation/buffer/SubgraphDepthLocater.h
+include/geos35/geos/operation/distance/ConnectedElementLocationFilter.h
+include/geos35/geos/operation/distance/ConnectedElementPointFilter.h
+include/geos35/geos/operation/distance/DistanceOp.h
+include/geos35/geos/operation/distance/GeometryLocation.h
+include/geos35/geos/operation/intersection/Rectangle.h
+include/geos35/geos/operation/intersection/RectangleIntersection.h
+include/geos35/geos/operation/intersection/RectangleIntersectionBuilder.h
+include/geos35/geos/operation/linemerge/EdgeString.h
+include/geos35/geos/operation/linemerge/LineMergeDirectedEdge.h
+include/geos35/geos/operation/linemerge/LineMergeEdge.h
+include/geos35/geos/operation/linemerge/LineMergeGraph.h
+include/geos35/geos/operation/linemerge/LineMerger.h
+include/geos35/geos/operation/linemerge/LineSequencer.h
+include/geos35/geos/operation/overlay/EdgeSetNoder.h
+include/geos35/geos/operation/overlay/ElevationMatrix.h
+include/geos35/geos/operation/overlay/ElevationMatrixCell.h
+include/geos35/geos/operation/overlay/FuzzyPointLocator.h
+include/geos35/geos/operation/overlay/LineBuilder.h
+include/geos35/geos/operation/overlay/MaximalEdgeRing.h
+include/geos35/geos/operation/overlay/MinimalEdgeRing.h
+include/geos35/geos/operation/overlay/MinimalEdgeRing.inl
+include/geos35/geos/operation/overlay/OffsetPointGenerator.h
+include/geos35/geos/operation/overlay/OverlayNodeFactory.h
+include/geos35/geos/operation/overlay/OverlayOp.h
+include/geos35/geos/operation/overlay/OverlayResultValidator.h
+include/geos35/geos/operation/overlay/PointBuilder.h
+include/geos35/geos/operation/overlay/PolygonBuilder.h
+include/geos35/geos/operation/overlay/snap/GeometrySnapper.h
+include/geos35/geos/operation/overlay/snap/LineStringSnapper.h
+include/geos35/geos/operation/overlay/snap/SnapIfNeededOverlayOp.h
+include/geos35/geos/operation/overlay/snap/SnapOverlayOp.h
+include/geos35/geos/operation/polygonize/EdgeRing.h
+include/geos35/geos/operation/polygonize/PolygonizeDirectedEdge.h
+include/geos35/geos/operation/polygonize/PolygonizeEdge.h
+include/geos35/geos/operation/polygonize/PolygonizeGraph.h
+include/geos35/geos/operation/polygonize/Polygonizer.h
+include/geos35/geos/operation/predicate/RectangleContains.h
+include/geos35/geos/operation/predicate/RectangleIntersects.h
+include/geos35/geos/operation/predicate/SegmentIntersectionTester.h
+include/geos35/geos/operation/relate/EdgeEndBuilder.h
+include/geos35/geos/operation/relate/EdgeEndBundle.h
+include/geos35/geos/operation/relate/EdgeEndBundleStar.h
+include/geos35/geos/operation/relate/RelateComputer.h
+include/geos35/geos/operation/relate/RelateNode.h
+include/geos35/geos/operation/relate/RelateNodeFactory.h
+include/geos35/geos/operation/relate/RelateNodeGraph.h
+include/geos35/geos/operation/relate/RelateOp.h
+include/geos35/geos/operation/sharedpaths/SharedPathsOp.h
+include/geos35/geos/operation/union/CascadedPolygonUnion.h
+include/geos35/geos/operation/union/CascadedUnion.h
+include/geos35/geos/operation/union/GeometryListHolder.h
+include/geos35/geos/operation/union/PointGeometryUnion.h
+include/geos35/geos/operation/union/UnaryUnionOp.h
+include/geos35/geos/operation/valid/ConnectedInteriorTester.h
+include/geos35/geos/operation/valid/ConsistentAreaTester.h
+include/geos35/geos/operation/valid/IsValidOp.h
+include/geos35/geos/operation/valid/QuadtreeNestedRingTester.h
+include/geos35/geos/operation/valid/RepeatedPointTester.h
+include/geos35/geos/operation/valid/SimpleNestedRingTester.h
+include/geos35/geos/operation/valid/SweeplineNestedRingTester.h
+include/geos35/geos/operation/valid/TopologyValidationError.h
+include/geos35/geos/planargraph.h
+include/geos35/geos/planargraph/DirectedEdge.h
+include/geos35/geos/planargraph/DirectedEdgeStar.h
+include/geos35/geos/planargraph/Edge.h
+include/geos35/geos/planargraph/GraphComponent.h
+include/geos35/geos/planargraph/Node.h
+include/geos35/geos/planargraph/NodeMap.h
+include/geos35/geos/planargraph/PlanarGraph.h
+include/geos35/geos/planargraph/Subgraph.h
+include/geos35/geos/planargraph/algorithm/ConnectedSubgraphFinder.h
+include/geos35/geos/platform.h
+include/geos35/geos/precision.h
+include/geos35/geos/precision/CommonBits.h
+include/geos35/geos/precision/CommonBitsOp.h
+include/geos35/geos/precision/CommonBitsRemover.h
+include/geos35/geos/precision/EnhancedPrecisionOp.h
+include/geos35/geos/precision/GeometryPrecisionReducer.h
+include/geos35/geos/precision/PrecisionReducerCoordinateOperation.h
+include/geos35/geos/precision/SimpleGeometryPrecisionReducer.h
+include/geos35/geos/profiler.h
+include/geos35/geos/simplify/DouglasPeuckerLineSimplifier.h
+include/geos35/geos/simplify/DouglasPeuckerSimplifier.h
+include/geos35/geos/simplify/LineSegmentIndex.h
+include/geos35/geos/simplify/TaggedLineSegment.h
+include/geos35/geos/simplify/TaggedLineString.h
+include/geos35/geos/simplify/TaggedLineStringSimplifier.h
+include/geos35/geos/simplify/TaggedLinesSimplifier.h
+include/geos35/geos/simplify/TopologyPreservingSimplifier.h
+include/geos35/geos/spatialIndex.h
+include/geos35/geos/timeval.h
+include/geos35/geos/triangulate/DelaunayTriangulationBuilder.h
+include/geos35/geos/triangulate/IncrementalDelaunayTriangulator.h
+include/geos35/geos/triangulate/VoronoiDiagramBuilder.h
+include/geos35/geos/triangulate/quadedge/LastFoundQuadEdgeLocator.h
+include/geos35/geos/triangulate/quadedge/LocateFailureException.h
+include/geos35/geos/triangulate/quadedge/QuadEdge.h
+include/geos35/geos/triangulate/quadedge/QuadEdgeLocator.h
+include/geos35/geos/triangulate/quadedge/QuadEdgeSubdivision.h
+include/geos35/geos/triangulate/quadedge/TrianglePredicate.h
+include/geos35/geos/triangulate/quadedge/TriangleVisitor.h
+include/geos35/geos/triangulate/quadedge/Vertex.h
+include/geos35/geos/unload.h
+include/geos35/geos/util.h
+include/geos35/geos/util/Assert.h
+include/geos35/geos/util/AssertionFailedException.h
+include/geos35/geos/util/CoordinateArrayFilter.h
+include/geos35/geos/util/GEOSException.h
+include/geos35/geos/util/GeometricShapeFactory.h
+include/geos35/geos/util/IllegalArgumentException.h
+include/geos35/geos/util/IllegalStateException.h
+include/geos35/geos/util/Interrupt.h
+include/geos35/geos/util/Machine.h
+include/geos35/geos/util/TopologyException.h
+include/geos35/geos/util/UniqueCoordinateArrayFilter.h
+include/geos35/geos/util/UnsupportedOperationException.h
+include/geos35/geos/util/math.h
+include/geos35/geos/version.h
+include/geos35/geos_c.h
+lib/libgeos-%%PORTVERSION%%.so
+lib/libgeos35.a
+lib/libgeos35.so