aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gexiv2
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2010-09-07 10:49:13 +0800
committerlioux <lioux@FreeBSD.org>2010-09-07 10:49:13 +0800
commit24727fadf12c7e51385538f551135826ee08dfcf (patch)
tree029cef348bdbc7219570a1dc07c86936be32d5c3 /graphics/gexiv2
parentef12fd4ab4fa3d104e122c2ab9f630818b6a0a61 (diff)
downloadfreebsd-ports-gnome-24727fadf12c7e51385538f551135826ee08dfcf.tar.gz
freebsd-ports-gnome-24727fadf12c7e51385538f551135826ee08dfcf.tar.zst
freebsd-ports-gnome-24727fadf12c7e51385538f551135826ee08dfcf.zip
New port gexiv2 version 0.2.0: GObject-based wrapper around the
Exiv2 library
Diffstat (limited to 'graphics/gexiv2')
-rw-r--r--graphics/gexiv2/Makefile33
-rw-r--r--graphics/gexiv2/distinfo3
-rw-r--r--graphics/gexiv2/pkg-descr4
-rw-r--r--graphics/gexiv2/pkg-plist12
4 files changed, 52 insertions, 0 deletions
diff --git a/graphics/gexiv2/Makefile b/graphics/gexiv2/Makefile
new file mode 100644
index 000000000000..47fc009867c8
--- /dev/null
+++ b/graphics/gexiv2/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: gexiv2
+# Date created: Tue Sep 7 02:00:03 UTC 2010
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gexiv2
+PORTVERSION= 0.2.0
+CATEGORIES= graphics
+MASTER_SITES= http://yorba.org/download/gexiv2/${PORTVERSION:R}/
+DISTNAME= libgexiv2-${PORTVERSION}
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= GObject-based wrapper around the Exiv2 library
+
+BUILD_DEPENDS= libtool:${PORTSDIR}/devel/libtool22 \
+ gm4:${PORTSDIR}/devel/m4 \
+ pkg-config:${PORTSDIR}/devel/pkg-config
+LIB_DEPENDS= exiv2:${PORTSDIR}/graphics/exiv2
+
+USE_BZIP2= yes
+USE_GNOME= glib20
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+
+post-patch:
+ @${REINPLACE_CMD} -E \
+ -e 's|^([[:space:]]+)m4[[:space:]]|\1gm4 |' \
+ -e 's|\$$\(LIB\)/pkgconfig|libdata/pkgconfig|g' \
+ ${WRKSRC}/${MAKEFILE}
+
+.include <bsd.port.mk>
diff --git a/graphics/gexiv2/distinfo b/graphics/gexiv2/distinfo
new file mode 100644
index 000000000000..c0e30e46fb3a
--- /dev/null
+++ b/graphics/gexiv2/distinfo
@@ -0,0 +1,3 @@
+MD5 (libgexiv2-0.2.0.tar.bz2) = 2bdedaa705260a1f36ae335a5a426f6a
+SHA256 (libgexiv2-0.2.0.tar.bz2) = 1c91599dd95d65b068aa4f598ce85a03ad93d05d361676b2e6e38acbe8490df7
+SIZE (libgexiv2-0.2.0.tar.bz2) = 24117
diff --git a/graphics/gexiv2/pkg-descr b/graphics/gexiv2/pkg-descr
new file mode 100644
index 000000000000..3c38c3d67f86
--- /dev/null
+++ b/graphics/gexiv2/pkg-descr
@@ -0,0 +1,4 @@
+gexiv2 is a GObject-based wrapper around the Exiv2 library. It makes
+the basic features of Exiv2 available to GNOME applications.
+
+WWW: http://trac.yorba.org/wiki/gexiv2/
diff --git a/graphics/gexiv2/pkg-plist b/graphics/gexiv2/pkg-plist
new file mode 100644
index 000000000000..844c184463d3
--- /dev/null
+++ b/graphics/gexiv2/pkg-plist
@@ -0,0 +1,12 @@
+include/gexiv2/gexiv2.h
+include/gexiv2/gexiv2-metadata.h
+include/gexiv2/gexiv2-managed-stream.h
+include/gexiv2/gexiv2-preview-properties.h
+include/gexiv2/gexiv2-preview-image.h
+lib/libgexiv2.so.0
+lib/libgexiv2.so
+lib/libgexiv2.la
+lib/libgexiv2.a
+libdata/pkgconfig/gexiv2.pc
+share/vala/vapi/gexiv2.vapi
+@dirrmtry include/gexiv2