aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/giflib
diff options
context:
space:
mode:
authorshaun <shaun@FreeBSD.org>2006-11-16 23:21:45 +0800
committershaun <shaun@FreeBSD.org>2006-11-16 23:21:45 +0800
commit18056f89f1006d5e6f5777db85f609aca7fe73b2 (patch)
tree78262607dacd0af0d0a10ea0d1211548c18cfda3 /graphics/giflib
parent449c545c11a28c4bd26112437f3facc8bf005886 (diff)
downloadfreebsd-ports-gnome-18056f89f1006d5e6f5777db85f609aca7fe73b2.tar.gz
freebsd-ports-gnome-18056f89f1006d5e6f5777db85f609aca7fe73b2.tar.zst
freebsd-ports-gnome-18056f89f1006d5e6f5777db85f609aca7fe73b2.zip
Add a patch to prevent a segfault under certain circumstances.
Submitted by: Mark Martinec via freebsd-ports Obtained from: http://fuzzyocr.own-hero.net/wiki/Downloads
Diffstat (limited to 'graphics/giflib')
-rw-r--r--graphics/giflib/Makefile2
-rw-r--r--graphics/giflib/files/patch-util_giftext.c9
2 files changed, 10 insertions, 1 deletions
diff --git a/graphics/giflib/Makefile b/graphics/giflib/Makefile
index 60013d68bbe4..b7afbf883232 100644
--- a/graphics/giflib/Makefile
+++ b/graphics/giflib/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libungif
PORTVERSION= 4.1.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/graphics/giflib/files/patch-util_giftext.c b/graphics/giflib/files/patch-util_giftext.c
new file mode 100644
index 000000000000..6227d274d74f
--- /dev/null
+++ b/graphics/giflib/files/patch-util_giftext.c
@@ -0,0 +1,9 @@
+--- util/giftext.c.orig Mon Oct 10 08:08:51 2005
++++ util/giftext.c Mon Aug 28 17:01:18 2006
+@@ -136,5 +136,5 @@
+ printf("\tColorResolution = %d, BitsPerPixel = %d, BackGround = %d.\n",
+ GifFile->SColorResolution,
+- GifFile->SColorMap->BitsPerPixel,
++ GifFile->SColorMap?GifFile->SColorMap->BitsPerPixel:0,
+ GifFile->SBackGroundColor);
+ if (GifFile->SColorMap)