aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gimageview/Makefile
diff options
context:
space:
mode:
authordaichi <daichi@FreeBSD.org>2003-07-27 16:21:25 +0800
committerdaichi <daichi@FreeBSD.org>2003-07-27 16:21:25 +0800
commit39ddc6a5d419f7e5ae2fdf60728617c2d1469ffc (patch)
tree6f7e99a62287c3e4db2c6f0900677fafb3735807 /graphics/gimageview/Makefile
parent7a1cd464b3a8eb8c7ff0b31cb81bb8ac7814f2f5 (diff)
downloadfreebsd-ports-gnome-39ddc6a5d419f7e5ae2fdf60728617c2d1469ffc.tar.gz
freebsd-ports-gnome-39ddc6a5d419f7e5ae2fdf60728617c2d1469ffc.tar.zst
freebsd-ports-gnome-39ddc6a5d419f7e5ae2fdf60728617c2d1469ffc.zip
fix graphics/gimageview: make package fail
Submitted by: TATEISHI Katsuyuki <katsu@iec.hiroshima-u.ac.jp> (maintainer) Pointed out by: bento via kris
Diffstat (limited to 'graphics/gimageview/Makefile')
-rw-r--r--graphics/gimageview/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/graphics/gimageview/Makefile b/graphics/gimageview/Makefile
index bb9e0112ea6f..385cd4358c35 100644
--- a/graphics/gimageview/Makefile
+++ b/graphics/gimageview/Makefile
@@ -49,24 +49,39 @@ WITH_MPLAYER= yes
.if defined(WITH_LIBMNG)
LIB_DEPENDS+= mng.1:${PORTSDIR}/graphics/libmng
+PLIST_SUB+= WITH_LIBMNG=""
+.else
+PLIST_SUB+= WITH_LIBMNG="@comment "
.endif
.if defined(WITH_LIBWMF)
LIB_DEPENDS+= wmf.2:${PORTSDIR}/graphics/libwmf
+PLIST_SUB+= WITH_LIBWMF=""
+.else
+PLIST_SUB+= WITH_LIBWMF="@comment "
.endif
.if defined(WITH_LIBRSVG)
LIB_DEPENDS+= rsvg.1:${PORTSDIR}/graphics/librsvg
+PLIST_SUB+= WITH_LIBRSVG=""
+.else
+PLIST_SUB+= WITH_LIBRSVG="@comment "
.endif
.if defined(WITH_MPLAYER)
RUN_DEPENDS+= mplayer:${PORTSDIR}/multimedia/mplayer
CONFIGURE_ARGS+= --enable-mplayer
+PLIST_SUB+= WITH_LIBMPLAYER=""
+.else
+PLIST_SUB+= WITH_LIBMPLAYER="@comment "
.endif
.if defined(WITH_LIBXINE)
LIB_DEPENDS+= xine.3:${PORTSDIR}/graphics/libxine
CONFIGURE_ARGS+= --with-xine
+PLIST_SUB+= WITH_LIBXINE=""
+.else
+PLIST_SUB+= WITH_LIBXINE="@comment "
.endif
post-patch: