aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gimp-app
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2016-01-09 22:01:02 +0800
committerpawel <pawel@FreeBSD.org>2016-01-09 22:01:02 +0800
commit0f0fc3400258b4dc795088cd450072090eb90cf1 (patch)
tree944411f02aff022e199340f128131b64edf9c73d /graphics/gimp-app
parent6f279d4cef34b2ac9deb26ce0add97354a4971b4 (diff)
downloadfreebsd-ports-gnome-0f0fc3400258b4dc795088cd450072090eb90cf1.tar.gz
freebsd-ports-gnome-0f0fc3400258b4dc795088cd450072090eb90cf1.tar.zst
freebsd-ports-gnome-0f0fc3400258b4dc795088cd450072090eb90cf1.zip
- Switch to USES=execinfo localbase
- USE options plist substitutions - Convert to options helpers PR: 205556 Submitted by: myself Approved by: maintainer timeout
Diffstat (limited to 'graphics/gimp-app')
-rw-r--r--graphics/gimp-app/Makefile125
-rw-r--r--graphics/gimp-app/pkg-plist8
2 files changed, 33 insertions, 100 deletions
diff --git a/graphics/gimp-app/Makefile b/graphics/gimp-app/Makefile
index 81a21f006417..ed3170ae9631 100644
--- a/graphics/gimp-app/Makefile
+++ b/graphics/gimp-app/Makefile
@@ -24,8 +24,8 @@ LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
GNU_CONFIGURE= yes
-USES+= cpe desktop-file-utils gettext gmake jpeg libtool pathfix \
- pkgconfig tar:bzip2
+USES+= cpe desktop-file-utils execinfo gettext gmake jpeg libtool \
+ localbase pathfix pkgconfig tar:bzip2
USE_XORG= xpm xmu xext
USE_GNOME+= intlhack gtk20
USE_LDCONFIG= yes
@@ -43,8 +43,7 @@ CONFIGURE_ARGS?=--with-html-dir=${PREFIX}/share/doc/gimp \
--docdir=${PREFIX}/share/doc/gimp \
--enable-default-binary
CONFIGURE_ENV= GIMP_THREAD_LIBS=-lpthread
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
+LIBS+= -lexecinfo
CPE_PRODUCT= gimp
CPE_VENDOR= gnu
@@ -56,13 +55,12 @@ OPTIONS_DEFINE?= AA DBUS LIBEXIF GHOSTSCRIPT GVFS HELPBROWSER JASPER \
LIBMNG LIBRSVG2 POPPLER SIMD WMF
OPTIONS_DEFAULT= AA DBUS LIBEXIF GVFS HELPBROWSER LIBMNG LIBRSVG2 \
POPPLER WMF
+OPTIONS_SUB= yes
AA_DESC= Ascii-art Plug-in
HELPBROWSER_DESC= Internal help browser
.endif
-.include <bsd.port.options.mk>
-
.if defined(GIMP_SLAVE)
PKG_CONFIG?= ${LOCALBASE}/bin/pkg-config
GIMP_LIBS= `${PKG_CONFIG} --libs gimp-2.0`
@@ -73,112 +71,47 @@ LIB_DEPENDS+= libgimp-2.0.so:${PORTSDIR}/graphics/gimp-app
.else
-.if ${PORT_OPTIONS:MDEBUG}
-CONFIGURE_ARGS+= --enable-debug
-.endif
+DEBUG_CONFIGURE_ON= --enable-debug
-.if ${PORT_OPTIONS:MAA}
-LIB_DEPENDS+= libaa.so:${PORTSDIR}/graphics/aalib
-PLIST_SUB+= AA=""
-.else
-CONFIGURE_ARGS+= --without-aa
-PLIST_SUB+= AA="@comment "
-.endif
+AA_LIB_DEPENDS= libaa.so:${PORTSDIR}/graphics/aalib
+AA_CONFIGURE_OFF= --without-aa
-.if ${PORT_OPTIONS:MDBUS}
-LIB_DEPENDS+= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
-CONFIGURE_ARGS+= --with-dbus
-.else
-CONFIGURE_ARGS+= --without-dbus
-.endif
+DBUS_LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
+DBUS_CONFIGURE_WITH= dbus
-.if ${PORT_OPTIONS:MGHOSTSCRIPT}
-USES+= ghostscript
-CONFIGURE_ARGS+= --with-gs
-PLIST_SUB+= GS=""
-.else
-CONFIGURE_ARGS+= --without-gs
-PLIST_SUB+= GS="@comment "
-.endif
+GHOSTSCRIPT_USES= ghostscript
+GHOSTSCRIPT_CONFIGURE_WITH= gs
-.if ${PORT_OPTIONS:MGVFS}
-USE_GNOME+= gvfs
-.else
-LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
-CONFIGURE_ARGS+= --without-gvfs
-.endif
+GVFS_USE= GNOME=gvfs
+GVFS_LIB_DEPENDS_OFF= libcurl.so:${PORTSDIR}/ftp/curl
+GVFS_CONFIGURE_OFF= --without-gvfs
-.if ${PORT_OPTIONS:MHELPBROWSER}
-LIB_DEPENDS+= libwebkitgtk-1.0.so:${PORTSDIR}/www/webkit-gtk2
-CONFIGURE_ARGS+= --with-webkit
-PLIST_SUB+= HELPBROWSER=""
-.else
-CONFIGURE_ARGS+= --without-webkit
-PLIST_SUB+= HELPBROWSER="@comment "
-.endif
+HELPBROWSER_LIB_DEPENDS= libwebkitgtk-1.0.so:${PORTSDIR}/www/webkit-gtk2
+HELPBROWSER_CONFIGURE_WITH= webkit
-.if ${PORT_OPTIONS:MJASPER}
-LIB_DEPENDS+= libjasper.so:${PORTSDIR}/graphics/jasper
-CONFIGURE_ARGS+= --with-libjasper
-PLIST_SUB+= JASPER=""
-.else
-CONFIGURE_ARGS+= --without-libjasper
-PLIST_SUB+= JASPER="@comment "
-.endif
+JASPER_LIB_DEPENDS= libjasper.so:${PORTSDIR}/graphics/jasper
+JASPER_CONFIGURE_WITH= libjasper
-.if ${PORT_OPTIONS:MLIBEXIF}
-LIB_DEPENDS+= libexif.so:${PORTSDIR}/graphics/libexif
-PLIST_SUB+= EXIF=""
-.else
-CONFIGURE_ARGS+= --without-libexif
-PLIST_SUB+= EXIF="@comment "
-.endif
+LIBEXIF_LIB_DEPENDS= libexif.so:${PORTSDIR}/graphics/libexif
+LIBEXIF_CONFIGURE_OFF= --without-libexif
-.if ${PORT_OPTIONS:MLIBMNG}
-LIB_DEPENDS+= libmng.so:${PORTSDIR}/graphics/libmng
-PLIST_SUB+= MNG=""
-.else
-CONFIGURE_ARGS+= --without-libmng
-PLIST_SUB+= MNG="@comment "
-.endif
+LIBMNG_LIB_DEPENDS= libmng.so:${PORTSDIR}/graphics/libmng
+LIBMNG_CONFIGURE_OFF= --without-libmng
-.if ${PORT_OPTIONS:MLIBRSVG2}
-USE_GNOME+= librsvg2
-CONFIGURE_ARGS+= --with-librsvg
-PLIST_SUB+= SVG=""
-.else
-CONFIGURE_ARGS+= --without-librsvg
-PLIST_SUB+= SVG="@comment "
-.endif
+LIBRSVG2_USE= GNOME=librsvg2
+LIBRSVG2_CONFIGURE_WITH=librsvg
-.if ${PORT_OPTIONS:MPOPPLER}
-LIB_DEPENDS+= libpoppler-glib.so:${PORTSDIR}/graphics/poppler-glib
-PLIST_SUB+= POPPLER=""
-.else
-CONFIGURE_ARGS+= --without-poppler
-PLIST_SUB+= POPPLER="@comment "
-.endif
+POPPLER_LIB_DEPENDS= libpoppler-glib.so:${PORTSDIR}/graphics/poppler-glib
+POPPLER_CONFIGURE_OFF= --without-poppler
-.if !${PORT_OPTIONS:MSIMD}
-CONFIGURE_ARGS+= --disable-mmx \
+SIMD_CONFIGURE_OFF= --disable-mmx \
--disable-sse \
--disable-altivec
-.endif
-
-.if ${PORT_OPTIONS:MWMF}
-LIB_DEPENDS+= libwmf.so:${PORTSDIR}/graphics/libwmf
-PLIST_SUB+= WMF=""
-.else
-CONFIGURE_ARGS+= --without-wmf
-PLIST_SUB+= WMF="@comment "
-.endif
-.endif
+WMF_LIB_DEPENDS= libwmf.so:${PORTSDIR}/graphics/libwmf
+WMF_CONFIGURE_OFF= --without-wmf
-.if ${OSVERSION} < 1000052
-LIB_DEPENDS+= libexecinfo.so:${PORTSDIR}/devel/libexecinfo
.endif
-LIBS+=-lexecinfo
post-patch:
@${REINPLACE_CMD} -e 's|%%GIMP_LIBS%%|${GIMP_LIBS}|; \
diff --git a/graphics/gimp-app/pkg-plist b/graphics/gimp-app/pkg-plist
index f62c20a1e70e..e46ad196deb7 100644
--- a/graphics/gimp-app/pkg-plist
+++ b/graphics/gimp-app/pkg-plist
@@ -333,7 +333,7 @@ libexec/gimp/2.2/plug-ins/file-html-table
libexec/gimp/2.2/plug-ins/file-ico
%%JASPER%%libexec/gimp/2.2/plug-ins/file-jp2-load
libexec/gimp/2.2/plug-ins/file-jpeg
-%%MNG%%libexec/gimp/2.2/plug-ins/file-mng
+%%LIBMNG%%libexec/gimp/2.2/plug-ins/file-mng
libexec/gimp/2.2/plug-ins/file-pat
libexec/gimp/2.2/plug-ins/file-pcx
%%POPPLER%%libexec/gimp/2.2/plug-ins/file-pdf-load
@@ -341,14 +341,14 @@ libexec/gimp/2.2/plug-ins/file-pdf-save
libexec/gimp/2.2/plug-ins/file-pix
libexec/gimp/2.2/plug-ins/file-png
libexec/gimp/2.2/plug-ins/file-pnm
-%%GS%%libexec/gimp/2.2/plug-ins/file-ps
+%%GHOSTSCRIPT%%libexec/gimp/2.2/plug-ins/file-ps
libexec/gimp/2.2/plug-ins/file-psd-load
libexec/gimp/2.2/plug-ins/file-psd-save
libexec/gimp/2.2/plug-ins/file-psp
libexec/gimp/2.2/plug-ins/file-raw
libexec/gimp/2.2/plug-ins/file-sgi
libexec/gimp/2.2/plug-ins/file-sunras
-%%SVG%%libexec/gimp/2.2/plug-ins/file-svg
+%%LIBRSVG2%%libexec/gimp/2.2/plug-ins/file-svg
libexec/gimp/2.2/plug-ins/file-tga
libexec/gimp/2.2/plug-ins/file-tiff-load
libexec/gimp/2.2/plug-ins/file-tiff-save
@@ -387,7 +387,7 @@ libexec/gimp/2.2/plug-ins/mail
libexec/gimp/2.2/plug-ins/map-object
libexec/gimp/2.2/plug-ins/max-rgb
libexec/gimp/2.2/plug-ins/maze
-%%EXIF%%libexec/gimp/2.2/plug-ins/metadata
+%%LIBEXIF%%libexec/gimp/2.2/plug-ins/metadata
libexec/gimp/2.2/plug-ins/mosaic
libexec/gimp/2.2/plug-ins/newsprint
libexec/gimp/2.2/plug-ins/nl-filter