aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gimp-app
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2009-01-10 13:22:13 +0800
committermarcus <marcus@FreeBSD.org>2009-01-10 13:22:13 +0800
commit6d8ed8f7c7511223163de715a97ffc04bf6fada9 (patch)
tree40dc015efe383243b0880df377f73ee250da7de7 /graphics/gimp-app
parentc7f342a8d7b82e85b9625c4403600fc20ce41da6 (diff)
downloadfreebsd-ports-gnome-6d8ed8f7c7511223163de715a97ffc04bf6fada9.tar.gz
freebsd-ports-gnome-6d8ed8f7c7511223163de715a97ffc04bf6fada9.tar.zst
freebsd-ports-gnome-6d8ed8f7c7511223163de715a97ffc04bf6fada9.zip
Presenting GNOME 2.24 for FreeBSD.
See http://library.gnome.org/misc/release-notes/2.24/ for the general release notes. On the FreeBSD front, this release introduces Fuse support in HAL, adds multi-CPU support to libgtop, WebKit updates, and fixes some long-standing seahorse and gnome-keyring bugs. The documentation updates to the website are forthcoming. This release features commits by adamw, ahze, kwm, mezz, and myself. It would not have been possible without are contributors and testers: Alexander Loginov Craig Butler [1] Dmitry Marakasov [6] Eric L. Chen Joseph S. Atkinson Kris Moore Lapo Luchini [7] Nikos Ntarmos Pawel Worach Romain Tartiere TAOKA Fumiyoshi [3] Yasuda Keisuke Zyl aZ [4] bf [2] [5] Florent Thoumie Peter Wemm pluknet PR: 125857 [1] 126993 [2] 130031 [3] 127399 [4] 127661 [5] 124302 [6] 129570 [7] 129936 123790
Diffstat (limited to 'graphics/gimp-app')
-rw-r--r--graphics/gimp-app/Makefile27
-rw-r--r--graphics/gimp-app/pkg-plist40
2 files changed, 29 insertions, 38 deletions
diff --git a/graphics/gimp-app/Makefile b/graphics/gimp-app/Makefile
index a181ab614ee4..a886eae50499 100644
--- a/graphics/gimp-app/Makefile
+++ b/graphics/gimp-app/Makefile
@@ -3,12 +3,12 @@
# Whom: erich@FreeBSD.org
#
# $FreeBSD$
-# $MCom: ports-stable/graphics/gimp-app/Makefile,v 1.4 2008/06/17 03:24:09 mezz Exp $
+# $MCom: ports/graphics/gimp-app/Makefile,v 1.30 2009/01/04 22:16:26 marcus Exp $
#
PORTNAME= gimp-app
DISTVERSION= 2.6.4
-PORTREVISION?= 0
+PORTREVISION?= 1
PORTEPOCH?= 1
CATEGORIES?= graphics gnome
MASTER_SITES= ftp://ftp.gimp.org/pub/%SUBDIR%/ \
@@ -45,7 +45,7 @@ USE_XORG= xpm xmu xext
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
USE_GNOME+= gnomehack intltool intlhack gtk20 libartlgpl2 ltverhack \
- desktopfileutils
+ desktopfileutils librsvg2
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
@@ -56,7 +56,7 @@ CONFIGURE_ARGS?=--with-html-dir=${PREFIX}/share/doc/gimp \
--with-desktop-dir=${PREFIX}/share \
--docdir=${PREFIX}/share/doc/gimp \
--enable-default-binary \
- --without-gvfs
+ --without-gnomevfs
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
GIMP_THREAD_LIBS=${PTHREAD_LIBS}
@@ -66,10 +66,9 @@ WANT_GNOME= yes
OPTIONS?= DEBUG "debugging" off \
DBUS "D-BUS support" on \
- GNOMEVFS "Use GNOME VFS for the URI plug-in" on \
+ GVFS "Use GVFS for the URI plug-in" on \
HELPBROWSER "internal help browser" on \
- MP "multiple processor support" off \
- RSVG "SVG format support" on
+ MP "multiple processor support" off
.endif
.include <bsd.port.pre.mk>
@@ -91,14 +90,6 @@ MLINKS= gimp-2.6.1 gimp.1 \
gimp-console-2.6.1 gimp-console.1 \
gimprc-2.6.5 gimprc.5
-.if defined(WITHOUT_RSVG)
-CONFIGURE_ARGS+= --without-librsvg
-PLIST_SUB+= SVG="@comment "
-.else
-USE_GNOME+= librsvg2
-PLIST_SUB+= SVG=""
-.endif
-
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+= --enable-debug
.endif
@@ -117,7 +108,7 @@ PLIST_SUB+= GNOME="@comment "
.endif
.if defined(WITH_HELPBROWSER)
-LIB_DEPENDS+= WebKitGtk.1:${PORTSDIR}/www/webkit-gtk2
+LIB_DEPENDS+= webkit-1.0.1:${PORTSDIR}/www/webkit-gtk2
CONFIGURE_ARGS+= --with-webkit
PLIST_SUB+= HELPBROWSER=""
.else
@@ -132,9 +123,9 @@ CONFIGURE_ARGS+= --with-dbus
CONFIGURE_ARGS+= --without-dbus
.endif
-.if defined(WITH_GNOMEVFS) || ${HAVE_GNOME:Mgnomevfs2}!=""
+.if defined(WITH_GVFS) || ${HAVE_GNOME:Mgvfs}!=""
LIB_DEPENDS+= gnome-keyring.0:${PORTSDIR}/security/gnome-keyring
-USE_GNOME+= gnomevfs2
+USE_GNOME+= gvfs
. if ${HAVE_GNOME:Mlibgnomeui}!=""
USE_GNOME+= libgnomeui
. endif
diff --git a/graphics/gimp-app/pkg-plist b/graphics/gimp-app/pkg-plist
index 4d7f111ef351..ca271443a601 100644
--- a/graphics/gimp-app/pkg-plist
+++ b/graphics/gimp-app/pkg-plist
@@ -2026,26 +2026,6 @@ share/locale/zh_TW/LC_MESSAGES/gimp20-script-fu.mo
share/locale/zh_TW/LC_MESSAGES/gimp20-std-plug-ins.mo
share/locale/zh_TW/LC_MESSAGES/gimp20-tips.mo
share/locale/zh_TW/LC_MESSAGES/gimp20.mo
-@dirrmtry share/locale/zh_HK/LC_MESSAGES
-@dirrmtry share/locale/zh_HK
-@dirrmtry share/locale/yi/LC_MESSAGES
-@dirrmtry share/locale/yi
-@dirrmtry share/locale/xh/LC_MESSAGES
-@dirrmtry share/locale/xh
-@dirrmtry share/locale/tt/LC_MESSAGES
-@dirrmtry share/locale/tt
-@dirrmtry share/locale/sr@latin/LC_MESSAGES
-@dirrmtry share/locale/sr@latin
-@dirrmtry share/locale/rw/LC_MESSAGES
-@dirrmtry share/locale/rw
-@dirrmtry share/locale/oc/LC_MESSAGES
-@dirrmtry share/locale/oc
-@dirrmtry share/locale/km/LC_MESSAGES
-@dirrmtry share/locale/km
-@dirrmtry share/locale/dz/LC_MESSAGES
-@dirrmtry share/locale/dz
-@dirrmtry share/locale/ca@valencia/LC_MESSAGES
-@dirrmtry share/locale/ca@valencia
@dirrm share/gimp/tips
@dirrm share/gimp/themes/Small
@dirrm share/gimp/themes/Default/images/preferences
@@ -2098,3 +2078,23 @@ share/locale/zh_TW/LC_MESSAGES/gimp20.mo
@dirrm etc/gimp
@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
+@dirrmtry share/locale/yi/LC_MESSAGES
+@dirrmtry share/locale/yi
+@dirrmtry share/locale/xh/LC_MESSAGES
+@dirrmtry share/locale/xh
+@dirrmtry share/locale/tt/LC_MESSAGES
+@dirrmtry share/locale/tt
+@dirrmtry share/locale/sr@latin/LC_MESSAGES
+@dirrmtry share/locale/sr@latin
+@dirrmtry share/locale/rw/LC_MESSAGES
+@dirrmtry share/locale/rw
+@dirrmtry share/locale/oc/LC_MESSAGES
+@dirrmtry share/locale/oc
+@dirrmtry share/locale/km/LC_MESSAGES
+@dirrmtry share/locale/km
+@dirrmtry share/locale/dz/LC_MESSAGES
+@dirrmtry share/locale/dz
+@dirrmtry share/locale/ca@valencia/LC_MESSAGES
+@dirrmtry share/locale/ca@valencia