aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gimp-app
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-06-28 02:35:22 +0800
committerjylefort <jylefort@FreeBSD.org>2005-06-28 02:35:22 +0800
commit90b66c2a66b68722e52f60d029e33ab32b8e9289 (patch)
treee565faea0eb5833d4e88b75d1574c4140dbea912 /graphics/gimp-app
parent92f689d2f651092b9abaafd550dfa62f1dd6ffb3 (diff)
downloadfreebsd-ports-gnome-90b66c2a66b68722e52f60d029e33ab32b8e9289.tar.gz
freebsd-ports-gnome-90b66c2a66b68722e52f60d029e33ab32b8e9289.tar.zst
freebsd-ports-gnome-90b66c2a66b68722e52f60d029e33ab32b8e9289.zip
- Unconditionally enable image handlers
- Convert other tunables to OPTIONS [1] [1]: PR: ports/78931 Submitted by: Miguel Mendez <flynn@energyhq.es.eu.org>
Diffstat (limited to 'graphics/gimp-app')
-rw-r--r--graphics/gimp-app/Makefile105
-rw-r--r--graphics/gimp-app/pkg-plist16
2 files changed, 31 insertions, 90 deletions
diff --git a/graphics/gimp-app/Makefile b/graphics/gimp-app/Makefile
index 39ad930e920d..7a600f5e4c83 100644
--- a/graphics/gimp-app/Makefile
+++ b/graphics/gimp-app/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gimp
PORTVERSION= 2.2.6
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= graphics gnome
MASTER_SITES= ftp://ftp.gimp.org/pub/%SUBDIR%/ \
@@ -21,16 +22,25 @@ MASTER_SITE_SUBDIR= gimp/v${PORTVERSION:R}
MAINTAINER= gnome@FreeBSD.org
COMMENT= A GNU Image Manipulation Program
+LIB_DEPENDS= wmf.2:${PORTSDIR}/graphics/libwmf \
+ aa.1:${PORTSDIR}/graphics/aalib \
+ exif.12:${PORTSDIR}/graphics/libexif \
+ mng.1:${PORTSDIR}/graphics/libmng \
+ png.5:${PORTSDIR}/graphics/png \
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ tiff.4:${PORTSDIR}/graphics/tiff
+
CONFLICTS= gimp-1.*
SHLIBVER?= 200
+USE_REINPLACE= yes
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_XPM= yes
USE_GMAKE= yes
USE_LIBTOOL_VER=15
-USE_GNOME= gnomehack intltool intlhack gtk20 libartlgpl2
+USE_GNOME= gnomehack intltool intlhack gtk20 libartlgpl2 librsvg2
WANT_GNOME= yes
INSTALLS_SHLIB= yes
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
@@ -47,66 +57,13 @@ GIMP_DISTFILE= ${DISTDIR}/${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
MAN1= gimp.1 gimp-2.2.1 gimp-remote.1 gimp-remote-2.2.1 gimptool-2.0.1
MAN5= gimprc.5 gimprc-2.2.5
-.if defined(WITHOUT_WMF) && !exists(${LOCALBASE}/bin/libwmf-config)
-PLIST_SUB+= WMF="@comment "
-.else
-LIB_DEPENDS+= wmf.2:${PORTSDIR}/graphics/libwmf
-PLIST_SUB+= WMF=""
-.endif
-
-.if defined(WITHOUT_RSVG2) && !exists(${X11BASE}/bin/rsvg)
-PLIST_SUB+= SVG="@comment "
-.else
-USE_GNOME+= librsvg2
-PLIST_SUB+= SVG=""
-.endif
-
-.if defined(WITHOUT_AA)
-CONFIGURE_ARGS+= --without-aa
-PLIST_SUB+= AA="@comment "
-.else
-LIB_DEPENDS+= aa.1:${PORTSDIR}/graphics/aalib
-PLIST_SUB+= AA=""
-.endif
+OPTIONS= DEBUG "debugging" off \
+ PYTHON "Python-Fu support" off \
+ PRINT "GIMP printing" on \
+ HTML_HELP_BROWSER "GIMP help browser" on \
+ MP "multiple processor support" off
-.if defined(WITHOUT_EXIF)
-CONFIGURE_ARGS+= --without-libexif
-.else
-LIB_DEPENDS+= exif.12:${PORTSDIR}/graphics/libexif
-.endif
-
-.if defined(WITHOUT_MNG)
-LIB_DEPENDS+= lcms.1:${PORTSDIR}/graphics/lcms
-CONFIGURE_ARGS+= --without-libmng
-PLIST_SUB+= MNG="@comment "
-.else
-LIB_DEPENDS+= mng.1:${PORTSDIR}/graphics/libmng
-PLIST_SUB+= MNG=""
-.endif
-
-.if defined(WITHOUT_PNG)
-CONFIGURE_ARGS+= --without-libpng
-PLIST_SUB+= PNG="@comment "
-.else
-LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
-PLIST_SUB+= PNG=""
-.endif
-
-.if defined(WITHOUT_JPEG)
-CONFIGURE_ARGS+= --without-libjpeg
-PLIST_SUB+= JPEG="@comment "
-.else
-LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg
-PLIST_SUB+= JPEG=""
-.endif
-
-.if defined(WITHOUT_TIFF)
-CONFIGURE_ARGS+= --without-libtiff
-PLIST_SUB+= TIFF="@comment "
-.else
-LIB_DEPENDS+= tiff.4:${PORTSDIR}/graphics/tiff
-PLIST_SUB+= TIFF=""
-.endif
+.include <bsd.port.pre.mk>
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+= --enable-debug
@@ -114,6 +71,9 @@ CONFIGURE_ARGS+= --enable-debug
.if defined(WITH_PYTHON)
USE_PYTHON= yes
+# we need to manually include this, because USE_PYTHON is defined
+# after including bsd.port.pre.mk
+.include "${PORTSDIR}/Mk/bsd.python.mk"
USE_GNOME+= pygtk2
CONFIGURE_ARGS+= --enable-python
PLIST_SUB+= PYTHON:=""
@@ -134,8 +94,6 @@ PLIST_SUB+= PRINT=""
CONFIGURE_ARGS+= --enable-mp
.endif
-.include <bsd.port.pre.mk>
-
.if ${HAVE_GNOME:Mgnomepanel}!=""
USE_GNOME+= gnomepanel desktopfileutils
CONFIGURE_ARGS+= --with-desktop-dir=${X11BASE}/share/gnome
@@ -148,32 +106,15 @@ PLIST_SUB+= GNOMEPANEL:="@comment "
CONFIGURE_ENV+= GIMP_THREAD_LIBS=${PTHREAD_LIBS}
.endif
-.if ${HAVE_GNOME:Mlibgtkhtml}!="" || defined(WITH_HTML_HELP_BROWSER)
+.if defined(WITH_HTML_HELP_BROWSER)
USE_GNOME+= libgtkhtml
PLIST_SUB+= HELPBROWSER:=""
.else
PLIST_SUB+= HELPBROWSER:="@comment "
+post-patch:
+ @${REINPLACE_CMD} -e 's|\(have_gtkhtml2=\)yes|\1no|' ${WRKSRC}/configure
.endif
-pre-everything::
- @${ECHO_MSG} ""
- @${ECHO_MSG} "gimp has the following tunable option(s):"
- @${ECHO_MSG} ""
- @${ECHO_MSG} " WITH_DEBUG=yes Turns on debugging"
- @${ECHO_MSG} " WITH_PYTHON=yes Turns on Python-Fu support"
- @${ECHO_MSG} " WITHOUT_PRINT=yes Turns off GIMP printing"
- @${ECHO_MSG} " WITH_HTML_HELP_BROWSER=yes Turns on the GIMP help browser"
- @${ECHO_MSG} " WITH_MP=yes Turns on multiple-processor support"
- @${ECHO_MSG} " WITHOUT_WMF=yes Turns off wmf support"
- @${ECHO_MSG} " WITHOUT_RSVG2=yes Turns off rsvg2 support"
- @${ECHO_MSG} " WITHOUT_AA=yes Turns off aa support"
- @${ECHO_MSG} " WITHOUT_EXIF=yes Turns off exif support"
- @${ECHO_MSG} " WITHOUT_MNG=yes Turns off mng support"
- @${ECHO_MSG} " WITHOUT_PNG=yes Turns off png support"
- @${ECHO_MSG} " WITHOUT_JPEG=yes Turns off jpeg support"
- @${ECHO_MSG} " WITHOUT_TIFF=yes Turns off tiff support"
- @${ECHO_MSG} ""
-
.if defined(GNOME_ENABLED)
post-install:
@-update-desktop-database
diff --git a/graphics/gimp-app/pkg-plist b/graphics/gimp-app/pkg-plist
index cd88b975eba1..52e62a10b60f 100644
--- a/graphics/gimp-app/pkg-plist
+++ b/graphics/gimp-app/pkg-plist
@@ -185,7 +185,7 @@ libexec/gimp/2.2/plug-ins/CML_explorer
libexec/gimp/2.2/plug-ins/FractalExplorer
libexec/gimp/2.2/plug-ins/Lighting
libexec/gimp/2.2/plug-ins/MapObject
-%%AA%%libexec/gimp/2.2/plug-ins/aa
+libexec/gimp/2.2/plug-ins/aa
libexec/gimp/2.2/plug-ins/align_layers
libexec/gimp/2.2/plug-ins/animationplay
libexec/gimp/2.2/plug-ins/animoptimize
@@ -263,7 +263,7 @@ libexec/gimp/2.2/plug-ins/illusion
libexec/gimp/2.2/plug-ins/imagemap
libexec/gimp/2.2/plug-ins/iwarp
libexec/gimp/2.2/plug-ins/jigsaw
-%%JPEG%%libexec/gimp/2.2/plug-ins/jpeg
+libexec/gimp/2.2/plug-ins/jpeg
libexec/gimp/2.2/plug-ins/laplace
libexec/gimp/2.2/plug-ins/lic
libexec/gimp/2.2/plug-ins/mail
@@ -271,7 +271,7 @@ libexec/gimp/2.2/plug-ins/mapcolor
libexec/gimp/2.2/plug-ins/max_rgb
libexec/gimp/2.2/plug-ins/maze
libexec/gimp/2.2/plug-ins/mblur
-%%MNG%%libexec/gimp/2.2/plug-ins/mng
+libexec/gimp/2.2/plug-ins/mng
libexec/gimp/2.2/plug-ins/mosaic
libexec/gimp/2.2/plug-ins/neon
libexec/gimp/2.2/plug-ins/newsprint
@@ -290,7 +290,7 @@ libexec/gimp/2.2/plug-ins/pix
libexec/gimp/2.2/plug-ins/pixelize
libexec/gimp/2.2/plug-ins/plasma
libexec/gimp/2.2/plug-ins/plugin-browser
-%%PNG%%libexec/gimp/2.2/plug-ins/png
+libexec/gimp/2.2/plug-ins/png
libexec/gimp/2.2/plug-ins/pnm
libexec/gimp/2.2/plug-ins/polar
libexec/gimp/2.2/plug-ins/postscript
@@ -327,10 +327,10 @@ libexec/gimp/2.2/plug-ins/spheredesigner
libexec/gimp/2.2/plug-ins/spread
libexec/gimp/2.2/plug-ins/struc
libexec/gimp/2.2/plug-ins/sunras
-%%SVG%%libexec/gimp/2.2/plug-ins/svg
+libexec/gimp/2.2/plug-ins/svg
libexec/gimp/2.2/plug-ins/tga
libexec/gimp/2.2/plug-ins/threshold_alpha
-%%TIFF%%libexec/gimp/2.2/plug-ins/tiff
+libexec/gimp/2.2/plug-ins/tiff
libexec/gimp/2.2/plug-ins/tile
libexec/gimp/2.2/plug-ins/tileit
libexec/gimp/2.2/plug-ins/tiler
@@ -347,9 +347,9 @@ libexec/gimp/2.2/plug-ins/webbrowser
libexec/gimp/2.2/plug-ins/whirlpinch
libexec/gimp/2.2/plug-ins/wind
libexec/gimp/2.2/plug-ins/winicon
-%%WMF%%libexec/gimp/2.2/plug-ins/wmf
+libexec/gimp/2.2/plug-ins/wmf
libexec/gimp/2.2/plug-ins/xbm
-%%JPEG%%libexec/gimp/2.2/plug-ins/xjt
+libexec/gimp/2.2/plug-ins/xjt
libexec/gimp/2.2/plug-ins/xpm
libexec/gimp/2.2/plug-ins/xwd
libexec/gimp/2.2/plug-ins/zealouscrop