aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gimp-devel
diff options
context:
space:
mode:
authorreg <reg@FreeBSD.org>2000-04-17 08:18:05 +0800
committerreg <reg@FreeBSD.org>2000-04-17 08:18:05 +0800
commit8b766534122d71052c9f8e5a0752944edf0450f8 (patch)
tree255862bd3b0c32802317a9ddc3193fd714753916 /graphics/gimp-devel
parente0c8ef49d897de0719277097a1e6578f291f493e (diff)
downloadfreebsd-ports-gnome-8b766534122d71052c9f8e5a0752944edf0450f8.tar.gz
freebsd-ports-gnome-8b766534122d71052c9f8e5a0752944edf0450f8.tar.zst
freebsd-ports-gnome-8b766534122d71052c9f8e5a0752944edf0450f8.zip
Standardize all user defined options to the booleans WITH_FOO and
WITHOUT_FOO. Begin the process of reserving these prefixes for user defined options. No comment by: ports
Diffstat (limited to 'graphics/gimp-devel')
-rw-r--r--graphics/gimp-devel/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/graphics/gimp-devel/Makefile b/graphics/gimp-devel/Makefile
index d8b829a0f21a..f61b62b80f6e 100644
--- a/graphics/gimp-devel/Makefile
+++ b/graphics/gimp-devel/Makefile
@@ -15,7 +15,7 @@ MASTER_SITES= ftp://ftp.gimp.org/pub/gimp/unstable/v${PORTVERSION}/ \
MAINTAINER= vanilla@FreeBSD.org
-.if defined(USE_PERL)
+.if !defined(WITHOUT_PERL)
BUILD_DEPENDS= perldl:${PORTSDIR}/math/PDL \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Gtk.pm:${PORTSDIR}/x11-toolkits/p5-Gtk
RUN_DEPENDS= perldl:${PORTSDIR}/math/PDL \
@@ -39,7 +39,7 @@ USE_GMAKE= yes
USE_LIBTOOL= yes
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
-.if !defined(USE_PERL)
+.if defined(WITHOUT_PERL)
CONFIGURE_ARGS= --disable-perl
.endif
@@ -51,11 +51,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= gimp.1 gimptool.1
MAN5= gimprc.5
-.if !defined(WITH_GNOME) && exists(${X11BASE}/bin/gnome-config)
-WITH_GNOME= yes
-.endif
-
-.if !defined(USE_PERL)
+.if defined(WITHOUT_PERL)
PLISTORIG= ${PKGDIR}/PLIST
PLIST= ${WRKDIR}/PLIST
.else
@@ -66,7 +62,8 @@ pre-fetch:
@${ECHO} "'make -DWITHOUT_PERL' instead"
.endif
-.if defined(WITH_GNOME) && ${WITH_GNOME} == yes
+.if defined(WITH_GNOME) || (exists(${X11BASE}/bin/gnome-config) \
+ && !defined(WITHOUT_GNOME))
LIB_DEPENDS+= gtkxmhtml.3:${PORTSDIR}/x11/gnomelibs
pre-install:
@${CAT} ${PLISTORIG} > ${PLIST}