aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gimp-ez-perspective-plugin
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2014-04-08 07:51:58 +0800
committerlioux <lioux@FreeBSD.org>2014-04-08 07:51:58 +0800
commit8410d08b304e08e3bad7cdd311f2e2975a778aff (patch)
tree7b7f044ca84c201c5c42079d9be2ef51d1957010 /graphics/gimp-ez-perspective-plugin
parent805884115a028b2c3380c6b10dc8419f612b08d8 (diff)
downloadfreebsd-ports-gnome-8410d08b304e08e3bad7cdd311f2e2975a778aff.tar.gz
freebsd-ports-gnome-8410d08b304e08e3bad7cdd311f2e2975a778aff.tar.zst
freebsd-ports-gnome-8410d08b304e08e3bad7cdd311f2e2975a778aff.zip
New port ez-perspective 0.1.2: GIMP plugin to sharpen by increasing contrast in high frequency space
Approved by: eadler (mentor)
Diffstat (limited to 'graphics/gimp-ez-perspective-plugin')
-rw-r--r--graphics/gimp-ez-perspective-plugin/Makefile51
-rw-r--r--graphics/gimp-ez-perspective-plugin/distinfo2
-rw-r--r--graphics/gimp-ez-perspective-plugin/files/LICENSE10
-rw-r--r--graphics/gimp-ez-perspective-plugin/pkg-descr7
4 files changed, 70 insertions, 0 deletions
diff --git a/graphics/gimp-ez-perspective-plugin/Makefile b/graphics/gimp-ez-perspective-plugin/Makefile
new file mode 100644
index 000000000000..c1a585bce457
--- /dev/null
+++ b/graphics/gimp-ez-perspective-plugin/Makefile
@@ -0,0 +1,51 @@
+# Created by: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= ez-perspective
+PORTVERSION= 0.1.2
+CATEGORIES= graphics
+MASTER_SITES= http://registry.gimp.org/files/
+PKGNAMEPREFIX= gimp-
+PKGNAMESUFFIX= -plugin
+DISTNAME= ${PORTNAME}.py
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= GIMP plugin to sharpen by increasing contrast in high frequency space
+
+LICENSE= EZPERSPECTIVE
+LICENSE_NAME= End User License Agreement
+LICENSE_FILE= ${FILESDIR}/LICENSE
+LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
+LICENSE_DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
+
+RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gimp-2.0.pc:${PORTSDIR}/graphics/gimp-app \
+ ${LOCALBASE}/libexec/gimp/2.2/python/gimpfu.py:${PORTSDIR}/graphics/py-gimp
+
+USES= zip
+USE_PYTHON_RUN= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+PLIST_SUB= PLUGIN_DIR=${PLUGIN_DIR}
+PLUGIN_DIR?= libexec/gimp/2.2/plug-ins/
+
+# installed files
+PLIST_FILES= %%PLUGIN_DIR%%/${DISTNAME}
+
+# installed dirs
+PLIST_DIRSTRY= libexec/gimp/2.2/plug-ins \
+ libexec/gimp/2.2 \
+ libexec/gimp
+
+post-patch:
+ @${REINPLACE_CMD} \
+ -e 's|/usr/bin/python|${PYTHON_CMD}|' \
+ ${WRKSRC}/${DISTNAME}
+
+do-install:
+# plugin
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${PLUGIN_DIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${DISTNAME} \
+ ${STAGEDIR}${PREFIX}/${PLUGIN_DIR}
+
+.include <bsd.port.mk>
diff --git a/graphics/gimp-ez-perspective-plugin/distinfo b/graphics/gimp-ez-perspective-plugin/distinfo
new file mode 100644
index 000000000000..c2b1fbe0647e
--- /dev/null
+++ b/graphics/gimp-ez-perspective-plugin/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ez-perspective.py.zip) = 276ce9efeaf75d0cd50d36f29166f95481fb157f4ee09bbb867b5bde92f960be
+SIZE (ez-perspective.py.zip) = 5744
diff --git a/graphics/gimp-ez-perspective-plugin/files/LICENSE b/graphics/gimp-ez-perspective-plugin/files/LICENSE
new file mode 100644
index 000000000000..f6e9a590283d
--- /dev/null
+++ b/graphics/gimp-ez-perspective-plugin/files/LICENSE
@@ -0,0 +1,10 @@
+[ License information extracted from source code. Read the plug-in source code to make sure this is the correct license. You've been warned. ]
+
+By Nils R. Barth, 2010 June 28, Portland, OR, USA
+
+I dedicate this program to the Public Domain, and claim no rights to it.
+Formally, under the Creative Commons CC0 license:
+
+To the extent possible under law, I, Nils Roland Barth have waived all copyright and
+related or neighboring rights to this program.
+This work is published from the United States of America.
diff --git a/graphics/gimp-ez-perspective-plugin/pkg-descr b/graphics/gimp-ez-perspective-plugin/pkg-descr
new file mode 100644
index 000000000000..593450f54722
--- /dev/null
+++ b/graphics/gimp-ez-perspective-plugin/pkg-descr
@@ -0,0 +1,7 @@
+GIMP plug-in particularly well-suited for the needs of photographers
+seeking to correct perspective, but flexible enough to be used by
+all those wishing to add perspective to an otherwise flat scene.
+
+The plugin can be found under "Filters > Distorts > EZ Perspective"
+
+WWW: http://registry.gimp.org/node/24537