aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gimp-focusblur-plugin
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2009-06-05 10:26:52 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2009-06-05 10:26:52 +0800
commit9c9899e3f106d63a32a73c71d602ed3936417472 (patch)
tree10adcc03bc9c7dc88ea7adaeebf6586dd355c54c /graphics/gimp-focusblur-plugin
parent6687137b47c665b03e94fa48e0741e0937c68f2e (diff)
downloadfreebsd-ports-gnome-9c9899e3f106d63a32a73c71d602ed3936417472.tar.gz
freebsd-ports-gnome-9c9899e3f106d63a32a73c71d602ed3936417472.tar.zst
freebsd-ports-gnome-9c9899e3f106d63a32a73c71d602ed3936417472.zip
This plug-in makes a out of focus with luminosity and depth, like a
sight or lenses. It can be used with depth map, depth fakes and shining effect. Also it works as a simple and applicable blur. WWW: http://sudakyo.hp.infoseek.co.jp/gimp/fblur/focusblur_e.html PR: 135220 Submitted by: Denis Barov <dindin@dindin.ru>
Diffstat (limited to 'graphics/gimp-focusblur-plugin')
-rw-r--r--graphics/gimp-focusblur-plugin/Makefile46
-rw-r--r--graphics/gimp-focusblur-plugin/distinfo3
-rw-r--r--graphics/gimp-focusblur-plugin/files/patch-pixmaps-Makefile.in19
-rw-r--r--graphics/gimp-focusblur-plugin/pkg-descr5
-rw-r--r--graphics/gimp-focusblur-plugin/pkg-plist4
5 files changed, 77 insertions, 0 deletions
diff --git a/graphics/gimp-focusblur-plugin/Makefile b/graphics/gimp-focusblur-plugin/Makefile
new file mode 100644
index 000000000000..ca0497827c3f
--- /dev/null
+++ b/graphics/gimp-focusblur-plugin/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: gimp-focusblur
+# Date created: 03 Jun 2009
+# Whom: Denis Barov <dindin@dindin.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= focusblur
+PORTVERSION= 3.2.4
+CATEGORIES= graphics
+MASTER_SITES= http://sudakyo.hp.infoseek.co.jp/gimp/fblur/ \
+ http://www.dindin.ru/download/
+PKGNAMEPREFIX= gimp-
+PKGNAMESUFFIX= -plugin
+
+MAINTAINER= dindin@dindin.ru
+COMMENT= Gimp realistic focus blur plugin
+
+LIB_DEPENDS= gimp-2.0:${PORTSDIR}/graphics/gimp-app \
+ fftw3.5:${PORTSDIR}/math/fftw3
+
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GNOME= gtk20
+MAKE_JOBS_SAFE= yes
+
+PLUGIN_DIR?= libexec/gimp/2.2/plug-ins
+PLIST_SUB= PLUGIN_DIR=${PLUGIN_DIR}
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS+= --disable-rpath
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^bindir = .*|bindir = ${PREFIX}/${PLUGIN_DIR}|g' ${WRKSRC}/src/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/graphics/gimp-focusblur-plugin/distinfo b/graphics/gimp-focusblur-plugin/distinfo
new file mode 100644
index 000000000000..beda65457d19
--- /dev/null
+++ b/graphics/gimp-focusblur-plugin/distinfo
@@ -0,0 +1,3 @@
+MD5 (focusblur-3.2.4.tar.bz2) = a99cb16d7bcdd0f462d663a4edb13c18
+SHA256 (focusblur-3.2.4.tar.bz2) = d215982f61b19e60bac095af18dfd37392c7487a560976d7d7602e79f1787c13
+SIZE (focusblur-3.2.4.tar.bz2) = 182145
diff --git a/graphics/gimp-focusblur-plugin/files/patch-pixmaps-Makefile.in b/graphics/gimp-focusblur-plugin/files/patch-pixmaps-Makefile.in
new file mode 100644
index 000000000000..df786187d11d
--- /dev/null
+++ b/graphics/gimp-focusblur-plugin/files/patch-pixmaps-Makefile.in
@@ -0,0 +1,19 @@
+--- pixmaps/Makefile.in.orig 2008-10-18 18:50:12.000000000 +0400
++++ pixmaps/Makefile.in 2009-06-03 20:31:46.000000000 +0400
+@@ -350,11 +350,12 @@
+ { echo -e '#include <gdk-pixbuf/gdk-pixdata.h>\n' ; \
+ $(GDK_PIXBUF_CSOURCE) --struct --rle --build-list \
+ $$(for i in $(icons) ; do \
+- name=$${i%%.*} ; \
+- name=$${name//-/_} ; \
+- echo $$name $$i ; \
++ echo $$i | sed -e 's/\..*//g' \
++ -e 's/-/_/g' | tr '\n' ' '; \
++ echo $$i ; \
+ done) | \
+- sed -e '/pixel_data:/a(guint8 *)' ; \
++ sed -e '/pixel_data:/a\
++(guint8 *)' ; \
+ } > $@
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/graphics/gimp-focusblur-plugin/pkg-descr b/graphics/gimp-focusblur-plugin/pkg-descr
new file mode 100644
index 000000000000..650c0d6bd2e2
--- /dev/null
+++ b/graphics/gimp-focusblur-plugin/pkg-descr
@@ -0,0 +1,5 @@
+This plug-in makes a out of focus with luminosity and depth, like a
+sight or lenses. It can be used with depth map, depth fakes and
+shining effect. Also it works as a simple and applicable blur.
+
+WWW: http://sudakyo.hp.infoseek.co.jp/gimp/fblur/focusblur_e.html
diff --git a/graphics/gimp-focusblur-plugin/pkg-plist b/graphics/gimp-focusblur-plugin/pkg-plist
new file mode 100644
index 000000000000..23833d741f32
--- /dev/null
+++ b/graphics/gimp-focusblur-plugin/pkg-plist
@@ -0,0 +1,4 @@
+%%PLUGIN_DIR%%/focusblur
+%%NLS%%share/locale/it/LC_MESSAGES/gimp20-focusblur.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/gimp20-focusblur.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/gimp20-focusblur.mo