aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/giram/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2002-11-05 20:29:34 +0800
committeredwin <edwin@FreeBSD.org>2002-11-05 20:29:34 +0800
commitd2a35a262da06cb5c47e2a499b723ae90b4cc9bb (patch)
tree461593852a7e2a8f555142be4213f2ed5a4d3613 /graphics/giram/Makefile
parentdef242236a4cab81401c82ed098945f5f727b3a8 (diff)
downloadfreebsd-ports-gnome-d2a35a262da06cb5c47e2a499b723ae90b4cc9bb.tar.gz
freebsd-ports-gnome-d2a35a262da06cb5c47e2a499b723ae90b4cc9bb.tar.zst
freebsd-ports-gnome-d2a35a262da06cb5c47e2a499b723ae90b4cc9bb.zip
port graphics/giram didn't patch properly.
Noticed by: bento
Diffstat (limited to 'graphics/giram/Makefile')
-rw-r--r--graphics/giram/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/graphics/giram/Makefile b/graphics/giram/Makefile
index fcfc3ddf2c0d..02750dbd81eb 100644
--- a/graphics/giram/Makefile
+++ b/graphics/giram/Makefile
@@ -17,6 +17,7 @@ RUN_DEPENDS= povray:${PORTSDIR}/graphics/povray31
USE_BZIP2= yes
USE_X_PREFIX= yes
+USE_REINPLACE= yes
USE_MESA= yes
USE_GMAKE= yes
USE_GNOMENG= yes
@@ -37,10 +38,12 @@ CONFIGURE_ARGS+=--disable-gnome
.endif
pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS:S/"//g}|g ; \
+ @${REINPLACE_CMD} -e \
+ 's|-lpthread|${PTHREAD_LIBS:S/"//g}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
- s|\$$\(top_builddir\)/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
+ s|\$$(top_builddir)/intl/libintl.a|-lintl|g' \
+ ${WRKSRC}/configure
post-install:
@${MKDIR} ${PREFIX}/share/doc/giram/SampleScenes