aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/glfw
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2016-02-11 10:57:55 +0800
committerpi <pi@FreeBSD.org>2016-02-11 10:57:55 +0800
commitf6ed3a9445fe2b6bc4376b714b8c4de16d14e6de (patch)
tree0da37a7aeae5f945cdf760d6113c6b06a5f28676 /graphics/glfw
parent966a1d2a9329fb5f1bbab6a0389ca7b3f79d3552 (diff)
downloadfreebsd-ports-gnome-f6ed3a9445fe2b6bc4376b714b8c4de16d14e6de.tar.gz
freebsd-ports-gnome-f6ed3a9445fe2b6bc4376b714b8c4de16d14e6de.tar.zst
freebsd-ports-gnome-f6ed3a9445fe2b6bc4376b714b8c4de16d14e6de.zip
graphics/glfw: 3.0.4 -> 3.1.2
Version 3.1.2 adds fixes for a large number of bugs that together affect all supported platforms, as well as dynamic loading work that simplifies compilation and linking. PR: 205460 Submitted by: f.degner@gmx.de Approved by: koalative@gmail.com (maintainer timeout)
Diffstat (limited to 'graphics/glfw')
-rw-r--r--graphics/glfw/Makefile19
-rw-r--r--graphics/glfw/distinfo4
-rw-r--r--graphics/glfw/files/patch-tests_empty.c10
-rw-r--r--graphics/glfw/pkg-descr12
-rw-r--r--graphics/glfw/pkg-plist4
5 files changed, 29 insertions, 20 deletions
diff --git a/graphics/glfw/Makefile b/graphics/glfw/Makefile
index 4eac9fc3f99c..bb4ade7670df 100644
--- a/graphics/glfw/Makefile
+++ b/graphics/glfw/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= glfw
-PORTVERSION= 3.0.4
-PORTREVISION= 2
+PORTVERSION= 3.1.2
CATEGORIES= graphics
MASTER_SITES= SF
@@ -12,7 +11,10 @@ COMMENT= Portable framework for OpenGL development
LICENSE= ZLIB
-USES= cmake
+LIB_DEPENDS= libXinerama.so:${PORTSDIR}/x11/libXinerama \
+ libXcursor.so:${PORTSDIR}/x11/libXcursor
+
+USES= cmake zip
USE_XORG= xi xrandr
USE_GL= glu
USE_GCC= yes
@@ -37,13 +39,13 @@ DOC_FILES3= *.html *.png *.css *.js
PORTEXAMPLES= *
EXAMPLESSRCDIR1= ${WRKSRC}/examples
-EXAMPLES_FILES1= boing gears heightmap simple splitview wave
+EXAMPLES_FILES1= boing gears heightmap particles simple splitview wave
EXAMPLESSRCDIR2= ${WRKSRC}/tests
EXAMPLESDIR2= ${EXAMPLESDIR}/tests
-EXAMPLES_FILES2= accuracy clipboard defaults events fsaa gamma glfwinfo \
- iconify joysticks modes peter reopen sharing tearing \
- threads title windows
+EXAMPLES_FILES2= clipboard cursor empty events gamma glfwinfo iconify \
+ joysticks monitors msaa reopen sharing tearing threads \
+ title windows
OPTIONS_DEFINE= DOCS EXAMPLES
@@ -51,13 +53,14 @@ post-patch:
@${REINPLACE_CMD} -e 's|lib$${LIB_SUFFIX}/pkgconfig|libdata/pkgconfig|' \
${WRKSRC}/CMakeLists.txt
-post-install:
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${STAGEDIR}${DOCSDIR}
@${MKDIR} ${STAGEDIR}${DOCSDIR2}
${INSTALL_DATA} ${DOC_FILES2:S|^|${DOCSRCDIR2}/|} ${STAGEDIR}${DOCSDIR2}
${INSTALL_DATA} ${DOC_FILES3:S|^|${DOCSRCDIR3}/|} ${STAGEDIR}${DOCSDIR3}
+do-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_PROGRAM} ${EXAMPLES_FILES1:S|^|${EXAMPLESSRCDIR1}/|} \
${STAGEDIR}${EXAMPLESDIR}
diff --git a/graphics/glfw/distinfo b/graphics/glfw/distinfo
index 8f97357a954e..9724c1040b68 100644
--- a/graphics/glfw/distinfo
+++ b/graphics/glfw/distinfo
@@ -1,2 +1,2 @@
-SHA256 (glfw-3.0.4.tar.gz) = c8bea730b1e3a6ec690370dfa0ec06716e3c4e454736c58bef584dff13cdb784
-SIZE (glfw-3.0.4.tar.gz) = 592216
+SHA256 (glfw-3.1.2.zip) = 2a38f4a32d2e1fcdffbe8c70052cd27020f9fef6e769afc8ccf8c7f9a1df635d
+SIZE (glfw-3.1.2.zip) = 1096151
diff --git a/graphics/glfw/files/patch-tests_empty.c b/graphics/glfw/files/patch-tests_empty.c
new file mode 100644
index 000000000000..65bc2503e8ff
--- /dev/null
+++ b/graphics/glfw/files/patch-tests_empty.c
@@ -0,0 +1,10 @@
+--- tests/empty.c.orig 2015-01-20 03:12:31 UTC
++++ tests/empty.c
+@@ -34,6 +34,7 @@
+ #include <math.h>
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <sys/time.h> /* CLOCK_REALTIME */
+
+ static volatile GLboolean running = GL_TRUE;
+
diff --git a/graphics/glfw/pkg-descr b/graphics/glfw/pkg-descr
index 93bf8a4b725c..fd911403b575 100644
--- a/graphics/glfw/pkg-descr
+++ b/graphics/glfw/pkg-descr
@@ -1,10 +1,6 @@
-GLFW is a free, Open Source, portable library for OpenGL and OpenGL ES
-application development. It provides a simple, platform-independent API for
-creating windows and contexts, reading input, handling events, etc.
-
-Version 3.0 brings a new API with many new features such as multiple windows
-and contexts, multi-monitor support, EGL and OpenGL ES support, clipboard text
-support, an error description callback, gamma ramp control, layout-independent
-keyboard input and UTF-8 for all strings.
+GLFW is a free, Open Source, multi-platform library for OpenGL and
+OpenGL ES application development. It provides a simple,
+platform-independent API for creating windows and contexts, reading
+input, handling events, etc.
WWW: http://www.glfw.org/
diff --git a/graphics/glfw/pkg-plist b/graphics/glfw/pkg-plist
index 5180fd90c224..d4539983e40b 100644
--- a/graphics/glfw/pkg-plist
+++ b/graphics/glfw/pkg-plist
@@ -1,7 +1,7 @@
include/GLFW/glfw3.h
include/GLFW/glfw3native.h
-lib/cmake/glfw/glfwConfig.cmake
-lib/cmake/glfw/glfwConfigVersion.cmake
+lib/cmake/glfw/glfw3Config.cmake
+lib/cmake/glfw/glfw3ConfigVersion.cmake
lib/cmake/glfw/glfwTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/glfw/glfwTargets.cmake
lib/libglfw3.a