aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gliv
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2001-11-04 18:04:08 +0800
committervanilla <vanilla@FreeBSD.org>2001-11-04 18:04:08 +0800
commit6fddbac6a6e86d0368413ed704627c62fa2974f2 (patch)
tree6658b21825f882cda614e436c72352d2a3a8e943 /graphics/gliv
parente7a6c5549aaee984608d1054cc83cecd3644bfba (diff)
downloadfreebsd-ports-gnome-6fddbac6a6e86d0368413ed704627c62fa2974f2.tar.gz
freebsd-ports-gnome-6fddbac6a6e86d0368413ed704627c62fa2974f2.tar.zst
freebsd-ports-gnome-6fddbac6a6e86d0368413ed704627c62fa2974f2.zip
Upgrade to 1.3.1.
PR: ports/31117 Submitted by: maintainer
Diffstat (limited to 'graphics/gliv')
-rw-r--r--graphics/gliv/Makefile2
-rw-r--r--graphics/gliv/distinfo2
-rw-r--r--graphics/gliv/files/patch-rendering.c17
3 files changed, 19 insertions, 2 deletions
diff --git a/graphics/gliv/Makefile b/graphics/gliv/Makefile
index ea9a8508cf08..7dcfb0eba2c2 100644
--- a/graphics/gliv/Makefile
+++ b/graphics/gliv/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gliv
-PORTVERSION= 1.2
+PORTVERSION= 1.3.1
CATEGORIES= graphics
MASTER_SITES= http://gliv.tuxfamily.org/
diff --git a/graphics/gliv/distinfo b/graphics/gliv/distinfo
index 65c67c490b70..fc36e616798e 100644
--- a/graphics/gliv/distinfo
+++ b/graphics/gliv/distinfo
@@ -1 +1 @@
-MD5 (gliv-1.2.tar.bz2) = c37f5749b0528ae3882f378545785aa9
+MD5 (gliv-1.3.1.tar.bz2) = 713433627e805ffe3265a1ec00ec2a41
diff --git a/graphics/gliv/files/patch-rendering.c b/graphics/gliv/files/patch-rendering.c
new file mode 100644
index 000000000000..49fa4a3155b4
--- /dev/null
+++ b/graphics/gliv/files/patch-rendering.c
@@ -0,0 +1,17 @@
+--- rendering.c.orig Thu Sep 13 12:55:36 2001
++++ rendering.c Sun Sep 30 20:47:40 2001
+@@ -27,9 +27,14 @@
+ #include <GL/glu.h>
+ #include "gliv.h"
+
++/* FreeBSD has no fminf/fmin, so fake it */
++#if 0
+ #ifndef HAVE_FMINF
+ #define fminf fmin
+ #endif
++#endif
++
++#define fminf(A, B) ((A) < (B) ? (A) : (B))
+
+ #ifndef HAVE_FABSF
+ #define fabsf fabs