aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/glosm/Makefile
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-01-18 07:44:12 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-01-18 07:44:12 +0800
commita4f46f5daad8da54fbf01675dd93f20f590e4596 (patch)
tree97d3fee63fd1c7df1bcf37d22a165403ebddbe57 /graphics/glosm/Makefile
parent137dfed0b0d60548a6fbeb431aed1e3cef195f72 (diff)
downloadfreebsd-ports-gnome-a4f46f5daad8da54fbf01675dd93f20f590e4596.tar.gz
freebsd-ports-gnome-a4f46f5daad8da54fbf01675dd93f20f590e4596.tar.zst
freebsd-ports-gnome-a4f46f5daad8da54fbf01675dd93f20f590e4596.zip
glosm is a framework for developing high-performance geospatial
data visualization applications of both interactive and batch nature featuring OpenGL-based 3D first-person and tile renderers. WWW: http://glosm.amdmi3.ru/about.html Feature safe: yes
Diffstat (limited to 'graphics/glosm/Makefile')
-rw-r--r--graphics/glosm/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/graphics/glosm/Makefile b/graphics/glosm/Makefile
new file mode 100644
index 000000000000..d00be757ab45
--- /dev/null
+++ b/graphics/glosm/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: glosm
+# Date created: 15 Jan 2011
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= glosm
+PORTVERSION= 0.0.1
+CATEGORIES= graphics geography
+MASTER_SITES= http://github.com/downloads/AMDmi3/glosm/ \
+ http://mirror.amdmi3.ru/distfiles/
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= 3D OpenGL renderer for OpenStreetMap
+
+LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
+ expat.6:${PORTSDIR}/textproc/expat2
+
+USE_BZIP2= yes
+USE_CMAKE= yes
+USE_GL= gl glu glut
+MAKE_JOBS_SAFE= yes
+
+PORTDOCS= README
+
+PLIST_FILES= bin/glosm-tiler bin/glosm-viewer lib/libglosm.so
+
+regression-test:
+ cd ${BUILD_WRKSRC} && ctest
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>