aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gmt
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-03-11 10:32:16 +0800
committermiwi <miwi@FreeBSD.org>2014-03-11 10:32:16 +0800
commit5d17b0120561d2ca289b36f189f83e01ea9c8e94 (patch)
treeacd434885c4ea04bfe02c5287931190a2533e1d4 /graphics/gmt
parentaacd1db9587d4ba968dd94fd704a8c4e1ed5ba2e (diff)
downloadfreebsd-ports-gnome-5d17b0120561d2ca289b36f189f83e01ea9c8e94.tar.gz
freebsd-ports-gnome-5d17b0120561d2ca289b36f189f83e01ea9c8e94.tar.zst
freebsd-ports-gnome-5d17b0120561d2ca289b36f189f83e01ea9c8e94.zip
- Update to 4.5.12
PR: 187290
Diffstat (limited to 'graphics/gmt')
-rw-r--r--graphics/gmt/Makefile6
-rw-r--r--graphics/gmt/distinfo8
-rw-r--r--graphics/gmt/files/patch-src__grdvector.c27
-rw-r--r--graphics/gmt/files/patch-src__ps2raster.c11
4 files changed, 7 insertions, 45 deletions
diff --git a/graphics/gmt/Makefile b/graphics/gmt/Makefile
index 7319f35ea6c7..8635e650c3c8 100644
--- a/graphics/gmt/Makefile
+++ b/graphics/gmt/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= gmt
-PORTVERSION= 4.5.11
-PORTREVISION= 1
+PORTVERSION= 4.5.12
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.soest.hawaii.edu/%SUBDIR%/ \
ftp://ftp.geologi.uio.no/pub/%SUBDIR%/ \
@@ -81,7 +80,8 @@ STRIP_FILES= blockmean blockmedian blockmode filter1d fitcircle \
psxy psxyz sample1d spectrum1d splitxyz \
surface trend1d trend2d triangulate xyz2grd
-GSHHG_DISTNAME= gshhg-gmt-nc4-2.2.4
+# http://www.soest.hawaii.edu/pwessel/gshhg/
+GSHHG_DISTNAME= gshhg-gmt-2.3.0
.include <bsd.port.options.mk>
diff --git a/graphics/gmt/distinfo b/graphics/gmt/distinfo
index 8bd12618c35e..e95ae5c95df7 100644
--- a/graphics/gmt/distinfo
+++ b/graphics/gmt/distinfo
@@ -1,4 +1,4 @@
-SHA256 (gmt-4.5.11-src.tar.bz2) = ec12b1206a8c91843587b241a478690bf61eb9350ff7458e28302a9f431a598e
-SIZE (gmt-4.5.11-src.tar.bz2) = 39410288
-SHA256 (gshhg-gmt-nc4-2.2.4.tar.gz) = 6ad702c67b2113fc5805f9901a070c963d93429c42c0b4ef253fd21025176e9f
-SIZE (gshhg-gmt-nc4-2.2.4.tar.gz) = 55184708
+SHA256 (gmt-4.5.12-src.tar.bz2) = f0ae83fe52842b1425341c0a3fb664e7270cba410253647bdea2e98e10a553c2
+SIZE (gmt-4.5.12-src.tar.bz2) = 39390743
+SHA256 (gshhg-gmt-2.3.0.tar.gz) = 123a969cf700c0d2607408af63f91c334e97bc456fa2deb3a51de0f50b1c911e
+SIZE (gshhg-gmt-2.3.0.tar.gz) = 57005361
diff --git a/graphics/gmt/files/patch-src__grdvector.c b/graphics/gmt/files/patch-src__grdvector.c
deleted file mode 100644
index ffeee46484e8..000000000000
--- a/graphics/gmt/files/patch-src__grdvector.c
+++ /dev/null
@@ -1,27 +0,0 @@
---- src/grdvector.c.orig
-+++ src/grdvector.c
-@@ -388,15 +388,7 @@
- if (!Ctrl->N.active) GMT_map_clip_on (GMT_no_rgb, 3);
-
- if (Ctrl->I.xinc != 0.0 && Ctrl->I.yinc != 0.0) { /* Gave a coarser grid spacing, we hope */
-- struct GRD_HEADER tmp_h;
-- double val;
-- tmp_h = h[0];
-- tmp_h.x_inc = Ctrl->I.xinc;
-- tmp_h.y_inc = Ctrl->I.yinc;
-- GMT_RI_prepare (&tmp_h); /* Convert to make sure we have correct increments */
-- Ctrl->I.xinc = tmp_h.x_inc;
-- Ctrl->I.yinc = tmp_h.y_inc;
-- val = Ctrl->I.yinc / h[0].y_inc;
-+ double val = Ctrl->I.yinc / h[0].y_inc;
- dj = irint (val);
- if (dj == 0 || fabs (val - dj) > GMT_CONV_LIMIT) {
- fprintf (stderr, "%s: Error: New y grid increment (%g) is not a multiple of actual grid increment (%g).\n", GMT_program, Ctrl->I.xinc, h[0].x_inc);
-@@ -408,6 +400,7 @@
- fprintf (stderr, "%s: Error: New x grid increment (%g) is not a multiple of actual grid increment (%g).\n", GMT_program, Ctrl->I.xinc, h[0].x_inc);
- exit (EXIT_FAILURE);
- }
-+ /* Determine starting point for straddled access */
- tmp = ceil (h[0].y_max / Ctrl->I.yinc) * Ctrl->I.yinc;
- if (tmp > h[0].y_max) tmp -= Ctrl->I.yinc;
- j0 = irint ((h[0].y_max - tmp) / h[0].y_inc);
diff --git a/graphics/gmt/files/patch-src__ps2raster.c b/graphics/gmt/files/patch-src__ps2raster.c
deleted file mode 100644
index 020521acb252..000000000000
--- a/graphics/gmt/files/patch-src__ps2raster.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/ps2raster.c.orig
-+++ src/ps2raster.c
-@@ -505,7 +505,7 @@
- for (k = 0; k < n_files; k++) {
- excessK = FALSE;
- memset ((void *)out_file, 0, BUFSIZ);
-- strcpy(ps_file,ps_names[k]);
-+ if (ps_file != ps_names[k]) strcpy(ps_file,ps_names[k]);
- if ((fp = fopen (ps_file, "r")) == NULL) {
- fprintf (stderr, "%s: Cannot to open file %s\n", GMT_program, ps_file);
- continue;