aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gnash
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2013-07-07 04:08:45 +0800
committermadpilot <madpilot@FreeBSD.org>2013-07-07 04:08:45 +0800
commit866510092542d41a845c4072a206623a7f126983 (patch)
tree176472c96b6a0db3ad98c0420598533ee49ce12a /graphics/gnash
parent34bb964c181bab9637ed4152ccf5e84f2774d224 (diff)
downloadfreebsd-ports-gnome-866510092542d41a845c4072a206623a7f126983.tar.gz
freebsd-ports-gnome-866510092542d41a845c4072a206623a7f126983.tar.zst
freebsd-ports-gnome-866510092542d41a845c4072a206623a7f126983.zip
Fix build of gnash [1] and vlc [2] after libva update.
PR: ports/180118 [2] Submitted by: Geraud CONTINSOUZAS <geraud@gcu.info> Approved by: dinoex [1], nox [2]
Diffstat (limited to 'graphics/gnash')
-rw-r--r--graphics/gnash/Makefile2
-rw-r--r--graphics/gnash/files/patch-libdevice-caapi-VaapiSurface.cpp13
2 files changed, 14 insertions, 1 deletions
diff --git a/graphics/gnash/Makefile b/graphics/gnash/Makefile
index 977056d648b6..c4aac1cfb705 100644
--- a/graphics/gnash/Makefile
+++ b/graphics/gnash/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gnash
PORTVERSION= 0.8.10
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics
MASTER_SITES= GNU/${PORTNAME}/${PORTVERSION}/
diff --git a/graphics/gnash/files/patch-libdevice-caapi-VaapiSurface.cpp b/graphics/gnash/files/patch-libdevice-caapi-VaapiSurface.cpp
new file mode 100644
index 000000000000..61c91730ff92
--- /dev/null
+++ b/graphics/gnash/files/patch-libdevice-caapi-VaapiSurface.cpp
@@ -0,0 +1,13 @@
+--- libdevice/vaapi/VaapiSurface.cpp.orig 2012-01-19 20:17:48.000000000 +0100
++++ libdevice/vaapi/VaapiSurface.cpp 2013-07-05 01:44:21.927681308 +0200
+@@ -62,8 +62,8 @@
+ VAStatus status;
+ VASurfaceID surface_id;
+ status = vaCreateSurfaces(gvactx->display(),
+- width, height, VA_RT_FORMAT_YUV420,
+- 1, &surface_id);
++ VA_RT_FORMAT_YUV420, width, height,
++ &surface_id, 1, NULL, 0);
+ if (!vaapi_check_status(status, "vaCreateSurfaces()")) {
+ return;
+ }