aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gnash
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2009-01-10 10:45:46 +0800
committermezz <mezz@FreeBSD.org>2009-01-10 10:45:46 +0800
commit867a335b88f91d457005fa0c7b3bb7c85c5fca14 (patch)
tree68af898c9a11dd756c516c49a6715cee75888e70 /graphics/gnash
parent6f64cd00171c29c1c7cdfb1e40393e23fc35151d (diff)
downloadfreebsd-ports-gnome-867a335b88f91d457005fa0c7b3bb7c85c5fca14.tar.gz
freebsd-ports-gnome-867a335b88f91d457005fa0c7b3bb7c85c5fca14.tar.zst
freebsd-ports-gnome-867a335b88f91d457005fa0c7b3bb7c85c5fca14.zip
Add a new framework for browser plugins, USE_WEBPLUGINS. It is for which foo
plugins support one of web browsers and can take care of plist (depend on how you use it) at the same time. I have written a complete document and even show how it works in the www/firefox/Makefile.webplugins so be sure to read in there. If there is anything that isn't clear in the document, please feel free to ask and I will try my best to improvement it. FYI: GNOME 2.24 depends on this, so it's coming. BTW: It's based on www/linux-mplayer-plugin/Makefile.npapi with heavy modified. Approved by: portmgr
Diffstat (limited to 'graphics/gnash')
-rw-r--r--graphics/gnash/Makefile7
-rw-r--r--graphics/gnash/pkg-plist4
2 files changed, 7 insertions, 4 deletions
diff --git a/graphics/gnash/Makefile b/graphics/gnash/Makefile
index 26d7a059158e..747f581b8560 100644
--- a/graphics/gnash/Makefile
+++ b/graphics/gnash/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnash
PORTVERSION= 0.8.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= http://getgnash.org/packages/releases/ \
${MASTER_SITE_GNU}
@@ -40,7 +40,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS} ${PTHREAD_LIBS}"
CONFIGURE_ARGS= --with-boost-incl="${LOCALBASE}/include" \
--with-boost-lib="${LOCALBASE}/lib" \
- --with-npapi-plugindir="${PREFIX}/lib/browser_plugins" \
+ --with-npapi-plugindir="${WEBPLUGINS_DIR}" \
--with-kde-pluginprefix="${PREFIX}"
GNASHVER= ${PORTVERSION}
@@ -66,6 +66,9 @@ OPTIONS= PLUGIN "Enable browser plugin" on \
# Plugin option processing
.if !defined(WITHOUT_GTK) && !defined(WITHOUT_PLUGIN)
+USE_WEBPLUGINS= native
+WEBPLUGINS_FILES= libgnashplugin.so
+.include "${PORTSDIR}/www/firefox/Makefile.webplugins"
PLIST_SUB+= FFPLUGIN=""
.else
PLIST_SUB+= FFPLUGIN="@comment "
diff --git a/graphics/gnash/pkg-plist b/graphics/gnash/pkg-plist
index d67932f9985a..03107d0aa589 100644
--- a/graphics/gnash/pkg-plist
+++ b/graphics/gnash/pkg-plist
@@ -6,7 +6,7 @@ bin/soldumper
%%GTK%%bin/gtk-gnash
%%KDE%%bin/kde-gnash
%%CYGNAL%%bin/cygnal
-%%FFPLUGIN%%lib/browser_plugins/libgnashplugin.so
+%%FFPLUGIN%%%%WEBPLUGINS_DIR%%/libgnashplugin.so
%%KONQPLUGIN%%share/apps/klash/pluginsinfo
%%KONQPLUGIN%%share/apps/klash/klashpartui.rc
%%KONQPLUGIN%%share/services/klash_part.desktop
@@ -55,4 +55,4 @@ share/locale/sv/LC_MESSAGES/gnash.mo
@dirrm %%DOCSDIR%%
@dirrm lib/gnash
%%KONQPLUGIN%%@dirrm share/apps/klash
-%%FFPLUGIN%%@dirrmtry lib/browser_plugins
+%%FFPLUGIN%%@dirrmtry %%WEBPLUGINS_DIR%%