aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gnofract4d/Makefile
diff options
context:
space:
mode:
authorlawrance <lawrance@FreeBSD.org>2005-04-26 20:45:31 +0800
committerlawrance <lawrance@FreeBSD.org>2005-04-26 20:45:31 +0800
commite81783e464e4e944ccc265352b84ddd18ec654cb (patch)
treeb1dab30b7b4318f493297e450943989bd3cd9326 /graphics/gnofract4d/Makefile
parent7609d4f7d73a008ed8d8042d5501266a3a71b418 (diff)
downloadfreebsd-ports-gnome-e81783e464e4e944ccc265352b84ddd18ec654cb.tar.gz
freebsd-ports-gnome-e81783e464e4e944ccc265352b84ddd18ec654cb.tar.zst
freebsd-ports-gnome-e81783e464e4e944ccc265352b84ddd18ec654cb.zip
Update the entertaining gnofract4d to version 2.6.
- contain the installation to its own DATADIR, rather than spreading bits everywhere PR: ports/76868 Submitted by: Edwin Young <edwin@bathysphere.org> (author) Approved by: clement (mentor)
Diffstat (limited to 'graphics/gnofract4d/Makefile')
-rw-r--r--graphics/gnofract4d/Makefile31
1 files changed, 16 insertions, 15 deletions
diff --git a/graphics/gnofract4d/Makefile b/graphics/gnofract4d/Makefile
index fd899dfa0519..ff6c2fbb7e1d 100644
--- a/graphics/gnofract4d/Makefile
+++ b/graphics/gnofract4d/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gnofract4d
-PORTVERSION= 1.9
-PORTREVISION= 4
+PORTVERSION= 2.6
CATEGORIES= graphics gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,19 +14,21 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Weird GNOME fractal generator
-USE_X_PREFIX= yes
USE_GNOME= gnomehack gnomeprefix gnometarget intlhack libgnomeui lthack
-USE_GMAKE= yes
-USE_INC_LIBTOOL_VER= 13
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
-INSTALLS_OMF= yes
-INSTALLS_SHLIB= yes
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+USE_REINPLACE= yes
+USE_GCC= 3.4
-.include <bsd.port.pre.mk>
+post-patch:
+# where to install libraries
+ ${REINPLACE_CMD} -e 's,\(^install_lib =\).*,\1${PREFIX}/lib/${PORTNAME},' ${WRKSRC}/setup.cfg
+# contain in DATADIR ('share/foobar/gnofract4d' -> 'share/gnofract4d/foobar')
+ ${FIND} ${WRKSRC} -name '*.py' -exec \
+ ${REINPLACE_CMD} -e "s,\([\"']\)share/\([^/]*\)/gnofract4d\1,\1${DATADIR:C/${PREFIX}\///}/\2\1," {} \;
+# libraries again
+ ${REINPLACE_CMD} -e "s,gnofract4d-${PORTVERSION},${PORTNAME}," ${WRKSRC}/gnofract4d
+# where to install docs
+ ${REINPLACE_CMD} -e "s,share/doc/gnofract4d-%s/'.*,${DOCSDIR:C/${PREFIX}\///}'\,," ${WRKSRC}/setup.py
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>